System tray/toolbar not working


╭─[email protected] in ~  
╰─λ inxi -Faz
System:
Kernel: 5.15.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=64706a94-d627-47bc-a2a5-c10e058ff518 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1
resume=UUID=13a9e0f7-0f67-4bdf-a746-27eb5d0b4182 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-F GAMING v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 3103
date: 06/17/2020
CPU:
Info: model: AMD Ryzen 7 3700X bits: 64 type: MT MCP arch: Zen 2
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 3718 high: 4299 min/max: 2200/4426 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3371 2: 3906
3: 3606 4: 3490 5: 3680 6: 3767 7: 3966 8: 3611 9: 3518 10: 4299 11: 4201
12: 3628 13: 3750 14: 3601 15: 3538 16: 3569 bogomips: 115202
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
vendor: Gigabyte driver: amdgpu v: kernel bus-ID: 0a:00.0
chip-ID: 1002:731f class-ID: 0300
Display: x11 server: X.Org 1.21.1.2 compositor: kwin_x11 driver:
loaded: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.0x11.2")
s-diag: 1055mm (41.5")
Monitor-1: DisplayPort-0 res: 1920x1080 dpi: 82
size: 598x336mm (23.5x13.2") diag: 686mm (27")
Monitor-2: HDMI-A-0 res: 1920x1080 dpi: 92 size: 532x304mm (20.9x12.0")
diag: 613mm (24.1")
OpenGL: renderer: AMD Radeon RX 5700 XT (NAVI10 DRM 3.42.0
5.15.8-zen1-1-zen LLVM 13.0.0)
v: 4.6 Mesa 21.3.1 direct render: Yes
Audio:
Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel
bus-ID: 0a:00.1 chip-ID: 1002:ab38 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 0c:00.4 chip-ID: 1022:1487
class-ID: 0403
Device-3: Realtek Realtek Audio USB type: USB driver: snd-usb-audio
bus-ID: 1-6:3 chip-ID: 0bda:4938 class-ID: 0102 serial: <filter>
Sound Server-1: ALSA v: k5.15.8-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
port: e000 bus-ID: 03:00.0 chip-ID: 8086:1539 class-ID: 0200
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 931.51 GiB used: 663.96 GiB (71.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SSD G5 BICS4
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 00WD scheme: GPT
Partition:
ID-1: / raw-size: 896.85 GiB size: 896.85 GiB (100.00%)
used: 663.96 GiB (74.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%)
used: 562 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 896.85 GiB size: 896.85 GiB (100.00%)
used: 663.96 GiB (74.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 896.85 GiB size: 896.85 GiB (100.00%)
used: 663.96 GiB (74.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 896.85 GiB size: 896.85 GiB (100.00%)
used: 663.96 GiB (74.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 34.4 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda3 maj-min: 8:3
ID-2: swap-2 type: zram size: 31.33 GiB used: 2.2 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 59.0 C
mem: 62.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:
Processes: 440 Uptime: 17m wakeups: 0 Memory: 31.34 GiB
used: 7.87 GiB (25.1%) Init: systemd v: 249 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1847 lib: 523 Shell: fish
v: 3.3.1 default: Bash v: 5.1.12 running-in: konsole inxi: 3.3.10

╭─[email protected] in ~ took 1s
╰─λ

so i booted into my pc today and everything was fine until discord crashed when opening which has become a frequent thing but that's not what my problem is,

my problem is that the toolbar/application tray is not appearing neither does pressing the super user key, i tried restarting multiple times and tried the fallback kernel then i tried "pacman -Syuu" i it updated and restarted it but nothing happened

im at a loss i don't know how to fix this

Hi there, welcome!
If you mean the latte dock on the bottom and the panel on top, open Krunner (normally shortcuts could be alt+space or alt+F2) and launch Garuda Assistant. From there, reset default settings for latte (flag). Maybe flag also something else if you want.
Then, to logoff or reboot you can right-click on the desktop and select Leave.
If for whatever reason Krunner doesn't start, launch garuda-assistant from the terminal (disregard some error messages there).
Last option, right-click on desktop, add widget and add a menu widget: from there you'll be able to launch Garuda Assistant.

PS: please put
~~~
before and after your inxi block, for readability

1 Like

Is the command used to downgrade. (uu) Is that really what you want to use? Where did you learn it?

3 Likes

oh sorry i wasn't thinking when i tried that what i meant was -Syyu

1 Like
sudo pacman -Syu

is all that you need.

4 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.