System slow and unstable

Hi Garudians ,

I am new to Garuda and Arch type of Linux.
2 days ago I have installed Garuda just to try it.
Installation went smooth, my computer is quite old, overclocked Haswell i5-4670 12 gb ram and Radeon HD 7850. For everyday work I run on it macos Big Sur and for what I need I am quite happy with the performance of this old machine. Never been a fan of Windows I always wanted an open source os but I use few commercial products available only on Windows And Mac unless you employ some virtualization like Wine or so. Using wine on such old computer would only make the performance worse. But last week my daughters nintendo switch died, so I had idea to try Ryujinx or Yuzu on my computer to let her play. Then I found out that there is no OpenGL support on Big Sur and all efforts to run Ryujinx in Vulkan mode failed. So I came with new Idea of installing some linux distro for the Ryujinx and also for a tryout of some windows programs on Wine. Quick search for best performing distros for Wine and games brought me here. I have installed it on an old hd and gave it a try. There must be some problem with my installation since the system is slow and unstable. On the very same computer opencore big sure starts in <20 sec. Garuda needs minutes. Fully encrypted debian on identical old hd and again same computer starts as slow as garuda without disk encryption. I can browse, watch videos on YT etc but opening apps takes long and some stuff hangs. Installing wifi drivers using yay was taking ages. Type hit enter and wait .......wait .....wait. Some programs stops to responding . For instance if I run the Ryujinx in Vulcan mode it will hang, then it will be hard to kill it and the whole system will react slower even after closint the non responding app. I can run the Ryujinx in OpenGL mode but is not playable anyway, since the audio is lagging. Tried zen and lts. Lts seems to be little bit faster but the wi fi drivers works only on Zen. Is my computer too old for this OS or there is a chance to improve the performance and let this divine creature fly ?

λ garuda-inxi
Kernel: 6.2.13-zen-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=92e1b84b-b35d-429c-8823-effec4577bec rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Desktop System: Gigabyte product: Z87-HD3 v: N/A
serial: Chassis: type: 3 serial:
Mobo: Gigabyte model: Z87-HD3 v: x.x serial:
UEFI: American Megatrends v: F8 date: 08/12/2014
Device-1: hidpp_battery_0 model: Logitech ERGO M575 Trackball
serial: charge: 95% rechargeable: yes status: discharging
Info: model: Intel Core i5-4670K bits: 64 type: MCP arch: Haswell
gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm
family: 6 model-id: 0x3C (60) stepping: 3 microcode: 0x28
Topology: cpus: 1x cores: 4 smt: cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 4301 high: 4396 min/max: 800/4400 scaling:
driver: intel_cpufreq governor: performance cores: 1: 4029 2: 4390 3: 4396
4: 4392 bogomips: 27137
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Device-1: AMD Pitcairn PRO [Radeon HD 7850 / R7 265 R9 270 1024SP]
vendor: PC Partner / Sapphire driver: radeon v: kernel alternate: amdgpu
arch: GCN-1 code: Southern Islands process: TSMC 28nm built: 2011-20 pcie:
gen: 3 speed: 8 GT/s lanes: 16 ports: active: DP-1,DVI-D-1
empty: DVI-I-1,HDMI-A-1 bus-ID: 01:00.0 chip-ID: 1002:6819 class-ID: 0300
temp: 50.0 C
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: kwin_x11 driver: X: loaded: radeon unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: radeon display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.00x11.22")
s-diag: 1055mm (41.54")
Monitor-1: DVI-D-1 mapped: DVI-0 pos: left model: Acer K272HL
serial: built: 2014 res: 1920x1080 hz: 60 dpi: 82 gamma: 1.2
size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
Monitor-2: DP-1 mapped: DisplayPort-0 pos: primary,right
model: BenQ XL2430T serial: built: 2015 res: 1920x1080 hz: 60
dpi: 92 gamma: 1.2 size: 531x298mm (20.91x11.73") diag: 609mm (24")
ratio: 16:9 modes: max: 1920x1080 min: 720x400
API: OpenGL v: 4.5 Mesa 23.0.3 renderer: PITCAIRN ( LLVM 15.0.7 DRM 2.50
6.2.13-zen-1-zen) direct-render: Yes
Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: Gigabyte
driver: snd_hda_intel bus-ID: 3-13:9 v: kernel chip-ID: 0d8c:013c
bus-ID: 00:1b.0 chip-ID: 8086:8c20 class-ID: 0300 class-ID: 0403
Device-2: AMD Oland/Hainan/Cape Verde/Pitcairn HDMI Audio [Radeon HD 7000
Series] vendor: PC Partner / Sapphire driver: snd_hda_intel v: kernel
pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 1002:aab0
class-ID: 0403
Device-3: C-Media CM108 Audio Controller type: USB
driver: hid-generic,snd-usb-audio,usbhid
API: ALSA v: k6.2.13-zen-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac:
Device-2: TP-Link 802.11ac WLAN Adapter type: USB driver: rtl8821au
bus-ID: 3-9:7 chip-ID: 2357:011f class-ID: 0000 serial:
IF: wlp0s20u9 state: up mac:
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
driver: btusb v: 0.8 bus-ID: 3-3.2:6 chip-ID: 0a12:0001 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address:
Local Storage: total: 4.22 TiB used: 39.25 GiB (0.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Hitachi model: HTS541612J9SA00
size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 1.5 Gb/s
type: N/A serial: rev: C70P scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 870 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: rev: 1B6Q scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Toshiba model: HDWD120 size: 1.82 TiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD
rpm: 7200 serial: rev: ACF0 scheme: GPT
ID-4: /dev/sdd maj-min: 8:48 vendor: Seagate model: ST2000DM001-1CH164
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: rev: CC27 scheme: GPT
ID-5: /dev/sde maj-min: 8:64 type: USB vendor: SanDisk model: USB 3.2Gen1
size: 14.34 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-1: / raw-size: 111.49 GiB size: 111.49 GiB (100.00%)
used: 39.25 GiB (35.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 1.4 MiB (0.5%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 111.49 GiB size: 111.49 GiB (100.00%)
used: 39.25 GiB (35.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 111.49 GiB size: 111.49 GiB (100.00%)
used: 39.25 GiB (35.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 111.49 GiB size: 111.49 GiB (100.00%)
used: 39.25 GiB (35.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 11.62 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 53.0 C mobo: N/A gpu: radeon temp: 51.0 C
Fan Speeds (RPM): N/A
Processes: 221 Uptime: 26m wakeups: 2 Memory: 11.62 GiB
used: 2.65 GiB (22.8%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1808
libs: 521 tools: octopi,paru Shell: fish v: 3.6.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.26
Garuda (2.6.16-1):
System install date: 2023-04-28
Last full system update: 2023-05-01
Is partially upgraded: No
Relevant software: snapper NetworkManager dracut
Windows dual boot: No/Undetected
Failed units:

There are some things that may cause your slow-ish to be normal:

  • The computer is ancient, and Garuda is not aimed at old, or even low-spec computers.
  • The HDD, for me, that's the biggest issue. HDDs speeds are poor as everyone knows, plus, Garuda uses BTRFS and snapshots, which are great but cause some overhead which is specially noticeable on HDDs.
  • The graphics... it's a laptop card from 2012... and Garuda use fancy effects and all, the Gaming edition (or Dr4goniz3d) is specially heavy on that for the "eye candy" effects...

My recommendation is: try something like the XFCE version and see if it works better, but there's not much to do.


Thank you edu4rdshl,

I'll try with some ssd and lighter desktop. Easy to forget how ancient this computer is. Still does perform on macos 11. FreeCAD , Adobe photoshop and illustrator all I use runs smoothly.

hope ssd will help a bit

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.