System Settings Network module crashes after first update

Hello.

When i first installed Garuda (Cinnamon Edition), the System Settings Netowrk module worked just fine (I tested it then because I was re-installing because of this error). Once I did the initial update, I ran "cinnamon-settings" and got the following results:

$ cinnamon-settings

(cinnamon-settings.py:94778): Gtk-WARNING **: 00:02:42.015: Theme parsing error: gtk.css:5822:26: '-shadow' is not a valid color name

(cinnamon-settings.py:94778): Gtk-WARNING **: 00:02:42.015: Theme parsing error: gtk.css:5825:14: not a number

(cinnamon-settings.py:94778): Gtk-WARNING **: 00:02:42.015: Theme parsing error: gtk.css:5826:13: not a number

(cinnamon-settings.py:94778): Gtk-WARNING **: 00:02:42.015: Theme parsing error: gtk.css:5827:11: Expected a length
Using pam module (python3-pampy)



Loading Effects module
Loading General module
Loading Screensaver module
/usr/lib/python3.10/site-packages/gi/overrides/Gio.py:42: Warning: invalid unclassed pointer in cast to 'NMACertChooserButton'
  return Gio.Application.run(self, *args, **kwargs)
/usr/lib/python3.10/site-packages/gi/overrides/Gio.py:42: Warning: g_type_instance_get_private: assertion 'instance != NULL && instance->g_class != NULL' failed
  return Gio.Application.run(self, *args, **kwargs)
Segmentation fault (core dumped)

I can see it's a Python error, but I'm not a Python coder. I'm a Perl and Java coder. Plus, I figured that if I'm having this error, other people are, too.

The only thing I did to fix this was a fresh install -- which didn't work. (wry grin)

Here is my "garuda-inxi -Faz" output

# garuda-inxi -Faz
System:
  Kernel: 5.16.2-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=c23b2e10-cd96-42ab-9754-c271bcbfb5f3 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: Cinnamon 5.2.7 tk: GTK 3.24.31 wm: Muffin dm: LightDM 1.30.0
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Convertible System: HP product: HP Spectre x360 Convertible 15-eb0xxx
    v: N/A serial: <filter> Chassis: type: 31 serial: <filter>
  Mobo: HP model: 86E5 v: 01.33 serial: <filter> UEFI: AMI v: F.12
    date: 07/29/2021
Battery:
  ID-1: BAT0 charge: 67.6 Wh (100.0%) condition: 67.6/67.6 Wh (100.0%)
    volts: 12.9 min: 11.6 model: HP Primary type: Li-ion serial: <filter>
    status: Full cycles: 13
  Device-1: hid-0018:04F3:2A4F.0007-battery model: ELAN2514:00 04F3:2A4F
    serial: N/A charge: N/A status: N/A
  Device-2: hidpp_battery_0 model: Logitech Wireless Gaming Mouse
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: Discharging
CPU:
  Info: model: Intel Core i7-10510U socket: BGA1528 (U3E1) note: check
    bits: 64 type: MT MCP arch: Comet/Whiskey Lake note: check family: 6
    model-id: 0x8E (142) stepping: 0xC (12) microcode: 0xEA
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 666 high: 700 min/max: 400/4900 base/boost: 2574/8300
    scaling: driver: intel_pstate governor: powersave volts: 0.8 V
    ext-clock: 100 MHz cores: 1: 600 2: 600 3: 634 4: 700 5: 700 6: 700
    7: 700 8: 700 bogomips: 36799
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds mitigation: TSX disabled
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: Hewlett-Packard
    driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:9b41 class-ID: 0300
  Device-2: NVIDIA GP108M [GeForce MX330] vendor: Hewlett-Packard
    driver: nvidia v: 495.46 alternate: nouveau,nvidia_drm bus-ID: 3b:00.0
    chip-ID: 10de:1d16 class-ID: 0302
  Device-3: Quanta HP True Vision HD Camera type: USB driver: uvcvideo
    bus-ID: 1-8:5 chip-ID: 0408:5440 class-ID: 0e02 serial: <filter>
  Display: server: X.Org 1.21.1.3 driver: loaded: modesetting,nvidia
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 7680x1440 s-dpi: 48 s-size: 4064x762mm (160.0x30.0")
    s-diag: 4135mm (162.8")
  Monitor-1: eDP-1 res: 2560x1440 dpi: 189 size: 344x193mm (13.5x7.6")
    diag: 394mm (15.5")
  Monitor-2: DP-1 res: 2560x1440 hz: 60 dpi: 93
    size: 697x392mm (27.4x15.4") diag: 800mm (31.5")
  Monitor-3: DP-2 res: 2560x1440 hz: 60 dpi: 93
    size: 697x392mm (27.4x15.4") diag: 800mm (31.5")
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Comet Lake PCH-LP cAVS vendor: Hewlett-Packard
    driver: sof-audio-pci-intel-cnl
    alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl
    bus-ID: 00:1f.3 chip-ID: 8086:02c8 class-ID: 0401
  Sound Server-1: ALSA v: k5.16.2-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.43 running: yes
Network:
  Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:02f0 class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB
    driver: r8152 bus-ID: 4-1.4:3 chip-ID: 0bda:8153 class-ID: 0000
    serial: <filter>
  IF: enp58s0u1u4 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: anbox0 state: down mac: <filter>
Drives:
  Local Storage: total: 1.14 TiB used: 40.32 GiB (3.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/mmcblk0 maj-min: 179:0 model: GE8QT size: 238.5 GiB
    block-size: physical: 512 B logical: 512 B type: SSD serial: <filter>
    scheme: MBR
  ID-2: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 1B4QFXO7
    temp: 38.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 399.71 GiB size: 399.71 GiB (100.00%)
    used: 17.46 GiB (4.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p6
    maj-min: 259:6
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 29.8 MiB (31.1%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1
  ID-3: /home raw-size: 399.71 GiB size: 399.71 GiB (100.00%)
    used: 17.46 GiB (4.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p6
    maj-min: 259:6
  ID-4: /var/log raw-size: 399.71 GiB size: 399.71 GiB (100.00%)
    used: 17.46 GiB (4.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p6
    maj-min: 259:6
  ID-5: /var/tmp raw-size: 399.71 GiB size: 399.71 GiB (100.00%)
    used: 17.46 GiB (4.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p6
    maj-min: 259:6
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 32 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: swap-2 type: zram size: 15.25 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 42.0 C pch: 39.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 302 Uptime: 43m wakeups: 7 Memory: 15.25 GiB
  used: 3.63 GiB (23.8%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1385 lib: 357
  Shell: Bash (sudo) v: 5.1.16 running-in: gnome-terminal inxi: 3.3.12
Garuda:
  System install date:     2022-01-24
  Last full system update: 2022-01-24
  Is partially upgraded:   No
  Using TLP:               No
  Windows dual boot:       Yes

Hi there, welcome to the community.

Can you update your laptop and try again?
It should be fixed now....

1 Like

Naman,

Thank you for responding. Unfortunately, it didn't work. I updated as you asked, and I think I did it right? I've been using Linux (RedHat/CentOS) and MacOS for years, but I'm brand new to Arch linux. When you said "update", I took that to mean:
Start Menu -> Administration -> Garuda Assistant, then click the "System update" button. That didn't fix it. So I tried it two more times. Still no joy.

Did I do that wrong? Is there a different way you'd suggest I update? Preferably a command-line method?

Any help is greatly appreciated.

  1. Just use
garuda-update

in terminal.

  1. If not installed
sudo pacman -Syu garuda-update

then

2 Likes

Thank you! Still didn't work. This is what I did:

  1. ran "sudo garuda-update"
  2. tested the network module
    • it crashed.
  3. Logged out and back in again, then tested the network module
    • It crashed
  4. Restarted the laptop, logged in, and tested the network module
    • It crashed

Here's the error msg again, in case it helps:

$ cinnamon-settings

(cinnamon-settings.py:3857): Gtk-WARNING **: 20:53:56.598: Theme parsing error: gtk.css:5822:26: '-shadow' is not a valid color name

(cinnamon-settings.py:3857): Gtk-WARNING **: 20:53:56.598: Theme parsing error: gtk.css:5825:14: not a number

(cinnamon-settings.py:3857): Gtk-WARNING **: 20:53:56.598: Theme parsing error: gtk.css:5826:13: not a number

(cinnamon-settings.py:3857): Gtk-WARNING **: 20:53:56.598: Theme parsing error: gtk.css:5827:11: Expected a length
Using pam module (python3-pampy)
Loading Applets module

(cinnamon-settings.py:3857): nm-CRITICAL **: 20:54:06.203: ((../NetworkManager/src/libnm-core-impl/nm-setting-vpn.c:221)): assertion '<dropped>' failed

(cinnamon-settings.py:3857): nm-CRITICAL **: 20:54:06.203: ((../NetworkManager/src/libnm-core-impl/nm-setting-vpn.c:221)): assertion '<dropped>' failed
/usr/lib/python3.10/site-packages/gi/overrides/Gio.py:42: Warning: invalid unclassed pointer in cast to 'NMACertChooserButton'
  return Gio.Application.run(self, *args, **kwargs)
/usr/lib/python3.10/site-packages/gi/overrides/Gio.py:42: Warning: g_type_instance_get_private: assertion 'instance != NULL && instance->g_class != NULL' failed
  return Gio.Application.run(self, *args, **kwargs)
Segmentation fault (core dumped)

I appreciate y'all lookin' at this problem.

Seems it's being fixed.
I hope a fix to cinnamon-control-center will come also into arch and then here soon.

3 Likes

Yes they updated the package in Artix. I installed it, no issue. On arch linux, the package is still flagged "out of date".

1 Like

Looks like they did it (at least I hope so, I can't check it):
https://archlinux.org/packages/community/x86_64/cinnamon-control-center/

6 Likes

It's working properly now. Yay!

Once they'd updated it, my personal fix was, from the command line:

sudo garuda-update ; cinnamon-settings

Then I clicked on the "Network" button under hardware. I knew it was fixed when the network preferences window came up.

Thank you so much to everyone who responded! I appreciate you and the time you spent helping me out.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.