System Freeze after clicking on second display

Hi guys, it's my first time that i use Garuda Linux.

I have an Alienware 15 R2 as a PC and i use also a second monitor with HDMI connection, but every time i click on the second display it freezes the entire system. The second monitor is set as an left-extension of the primary monitor.

Is it maybe a driver problem? Thanks a lot whoever can help me! (My goal is to set the second monitor as an exentension of the primary as Windows 10 do)

I don't think anyone can help, without any useful info.
It seems you haven't done any effort to find a solution.
Read garuda wiki, especially this.

  • Search the internet
  • Search the forum
  • Collect system info and logs
  • Post info (in text, not images, unless it is requested)
  • Explain what you have tried until now
6 Likes

Yes sorry, i try to be more specific.

Pc specs:

  • CPU: Intel I7 6820HK
  • GPU: Nvidia Gtx 980m 4gb
  • SSD: Nvme gen 3 Sabrent
  • RAM: 16 gb

Actually i have Garuda Dragonized (gaming distro). After a fresh install in dual boot, i've run sudo pacman -Syu to update every package and then i connect my second monitor with hdmi. After connection i choose the extension: it comes with a black screen, if i work on the prymary screen ( the screen of my portable pc) it works fine, but if i click somewhere on the second screen it freeze the entire system! I checked drivers if them are installed and performance with htop

Have you rebooted?
Check for journal and Xorg errors.

1 Like

Yes i've rebooted, when i try to do again sudo pacman -Syu says only that the version of paleofetch installed is newer than the version there in chaotic-auror, nothing else.

Here you are if u want to know what i'm using actually:

    System:    Kernel: 5.10.6-110-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq 
           root=UUID=5a331664-5833-482b-b658-8c21ab9dae7f rw [email protected] quiet splash 
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 
           Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Garuda Linux 
Machine:   Type: Laptop System: Alienware product: Alienware 15 R2 v: 1.6.1 serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: Alienware model: 0950W2 v: X01 serial: <filter> UEFI: Alienware v: 1.6.1 date: 07/17/2018 
Battery:   ID-1: BAT1 charge: N/A condition: N/A volts: 13.2/15.0 model: COMPAL PABAS0241231 type: Li-ion 
           serial: <filter> status: Unknown 
CPU:       Info: Quad Core model: Intel Core i7-6820HK bits: 64 type: MT MCP arch: Skylake-S family: 6 
           model-id: 5E (94) stepping: 3 microcode: E2 L2 cache: 8 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 43246 
           Speed: 3200 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 3200 2: 3254 3: 3233 4: 3249 5: 3203 
           6: 3202 7: 3208 8: 3200 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable 
Graphics:  Device-1: Intel HD Graphics 530 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:191b 
           Device-2: NVIDIA GM204M [GeForce GTX 980M] vendor: Dell driver: nvidia v: 460.32.03 
           alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:13d7 
           Device-3: Sunplus Innovation Integrated_Webcam_HD type: USB driver: uvcvideo bus ID: 1-7:6 
           chip ID: 1bcf:2b8c 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: modesetting,nvidia 
           alternate: fbdev,intel,nouveau,nv,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
           OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) v: 4.6 Mesa 20.3.3 direct render: Yes 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Dell driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:a170 
           Device-2: Samson Meteor condenser microphone type: USB driver: hid-generic,snd-usb-audio,usbhid 
           bus ID: 1-2:3 chip ID: 17a0:0310 
           Sound Server: ALSA v: k5.10.6-110-tkg-bmq 
Network:   Device-1: Qualcomm Atheros Killer E2400 Gigabit Ethernet driver: alx v: kernel port: d000 
           bus ID: 3b:00.0 chip ID: 1969:e0a1 
           IF: enp59s0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Bigfoot Networks 
           driver: ath10k_pci v: kernel port: d000 bus ID: 3c:00.0 chip ID: 168c:003e 
           IF: wlp60s0 state: up mac: <filter> 
           Device-3: Qualcomm Atheros QCA61x4 Bluetooth 4.0 type: USB driver: btusb bus ID: 1-5:5 
           chip ID: 0cf3:e300 
Drives:    Local Storage: total: 1.38 TiB used: 18.85 GiB (1.3%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Sabrent model: N/A size: 476.94 GiB block size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: RKT343.1 temp: 28.9 C 
           ID-2: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS541010A9E680 size: 931.51 GiB block size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: A560 
Partition: ID-1: / raw size: 132.63 GiB size: 132.63 GiB (100.00%) used: 18.83 GiB (14.2%) fs: btrfs 
           dev: /dev/nvme0n1p2 maj-min: 259:2 
           ID-2: /boot/efi raw size: 500 MiB size: 196.9 MiB (39.38%) used: 24.9 MiB (12.6%) fs: vfat 
           dev: /dev/nvme0n1p7 maj-min: 259:5 
           ID-3: /home raw size: 132.63 GiB size: 132.63 GiB (100.00%) used: 18.83 GiB (14.2%) fs: btrfs 
           dev: /dev/nvme0n1p2 maj-min: 259:2 
           ID-4: /var/log raw size: 132.63 GiB size: 132.63 GiB (100.00%) used: 18.83 GiB (14.2%) fs: btrfs 
           dev: /dev/nvme0n1p2 maj-min: 259:2 
           ID-5: /var/tmp raw size: 132.63 GiB size: 132.63 GiB (100.00%) used: 18.83 GiB (14.2%) fs: btrfs 
           dev: /dev/nvme0n1p2 maj-min: 259:2 
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 1.94 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 1.94 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1 
           ID-3: swap-3 type: zram size: 1.94 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2 
           ID-4: swap-4 type: zram size: 1.94 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3 
           ID-5: swap-5 type: zram size: 1.94 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4 
           ID-6: swap-6 type: zram size: 1.94 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5 
           ID-7: swap-7 type: zram size: 1.94 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6 
           ID-8: swap-8 type: zram size: 1.94 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7 
Sensors:   System Temperatures: cpu: 71.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 270 Uptime: 15m wakeups: 1 Memory: 15.5 GiB used: 4.17 GiB (26.9%) Init: systemd v: 247 
           Compilers: gcc: 10.2.0 Packages: pacman: 1555 lib: 483 Shell: fish v: 3.1.2 running in: konsole 
           inxi: 3.2.01

No errors.
Then everything is fine.

2 Likes

@petsam should he not in this case be running:

sudo pacman -Syyuu
2 Likes

Ok, i've more information for you:

-It seems not a real system freeze, only a graphical/render freeze; i tried to do CTRL+T to open terminal, i wrote reboot and it worked, also i've seen nothing graphically.
-This multi-monitor bug applies only with screen extension, if i double the screen everything works fine.

Who knows? As you know, we are facing bad weather, winter, lots of clouds, so even my really good Crystal Ball cannot see through.

3 Likes

Is it maybe a graphic problem, for example, with Xorg or Xandr? (i don't know what Garuda use)

Have you ever read what is suggested in previous posted links?

If you don't provide any error messages from system and Xorg, this topic will end.

3 Likes

No errors, i'm only supposing, i think it wii be unsolved so.

1 Like