System crash on power saving

Hello everyone.

As the tittle says, I have been experiencing crashes when the monitors turn off for power saving. I think it has been so for the last month. After a while with the monitors off, the HDD led starts blinking regularly and when I use the mouse or keyboard to bring the system back, I am greeted by a frozen desktop screen.

Any help will be appreciated.

Note: I have Kscreen disabled as workaround for a previous problem. It had work for months without problems, but I thought that it would be worth mentioning

Kernel: 6.0.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=810cddd0-3d54-45f7-88fa-84f8b12b1038 rw [email protected]
rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 5.26.3 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-I GAMING v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 4901
date: 07/25/2022
Info: model: AMD Ryzen 7 3700X bits: 64 type: MT MCP arch: Zen 2 gen: 3
level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 3884 high: 4125 min/max: 2200/4426 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 4125 2: 3600
3: 3600 4: 3600 5: 4093 6: 4100 7: 4091 8: 4099 9: 3600 10: 4107 11: 4109
12: 4122 13: 3600 14: 3600 15: 3600 16: 4099 bogomips: 115196
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
always-on, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
vendor: Gigabyte driver: amdgpu v: kernel arch: RDNA-1 code: Navi
process: TSMC n7 (7nm) built: 2019-20 pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: DP-1,DP-3 empty: DP-2,HDMI-A-1 bus-ID: 09:00.0
chip-ID: 1002:731f class-ID: 0300
Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
bus-ID: 1-1:2 chip-ID: 046d:0825 class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1185x381mm (46.65x15.00")
s-diag: 1245mm (49.01")
Monitor-1: DP-1 mapped: DisplayPort-0 pos: primary,top-right
model: MSI MAG274QRF-QD serial: <filter> built: 2021 res: 2560x1440 dpi: 109
gamma: 1.2 size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9
modes: max: 2560x1440 min: 640x480
Monitor-2: DP-3 mapped: DisplayPort-2 pos: bottom-l model: AOC 2590G4
serial: <filter> built: 2019 res: 1920x1080 dpi: 90 gamma: 1.2
size: 544x303mm (21.42x11.93") diag: 623mm (24.5") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
API: OpenGL v: 4.6 Mesa 22.2.3 renderer: AMD Radeon RX 5700 (navi10 LLVM
14.0.6 DRM 3.48 6.0.8-zen1-1-zen) direct render: Yes
Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel pcie:
bus-ID: 1-1:2 chip-ID: 046d:0825 gen: 4 class-ID: 0102 speed: 16 GT/s
serial: <filter> lanes: 16 bus-ID: 09:00.1 chip-ID: 1002:ab38
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0b:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
Device-4: Logitech G432 Gaming Headset type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-2:3 chip-ID: 046d:0a9c
class-ID: 0300 serial: <filter>
Sound API: ALSA v: k6.0.8-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.60 running: yes
Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 04:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: ASUSTeK
driver: rtw_8822be v: N/A modules: rtw88_8822be pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: c000 bus-ID: 05:00.0 chip-ID: 10ec:b822 class-ID: 0280
IF: wlp5s0 state: up mac: <filter>
Device-1: ASUSTek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 1-8:5 chip-ID: 0b05:185c class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Local Storage: total: 1.84 TiB used: 1.49 TiB (80.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: A-Data model: SX8200PNP
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 type: SSD serial: <filter> rev: S0118C temp: 32.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10SPZX-00Z10T0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 1A01 scheme: MBR
ID-1: / raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 699.5 GiB (73.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 699.5 GiB (73.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 699.5 GiB (73.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 699.5 GiB (73.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.54 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 39.0 C mobo: 52.0 C gpu: amdgpu temp: 56.0 C
mem: 60.0 C
Fan Speeds (RPM): cpu: 656 case-1: 705 gpu: amdgpu fan: 0
Power: 12v: 9.97 5v: N/A 3.3v: N/A vbat: 3.23 gpu: amdgpu watts: 32.00
Processes: 394 Uptime: 11m wakeups: 0 Memory: 15.54 GiB
used: 4.09 GiB (26.3%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 2004
pm: pacman pkgs: 1996 libs: 572 tools: octopi,paru pm: flatpak pkgs: 8
Shell: fish v: 3.5.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.23
Garuda (2.6.9-1):
System install date:     2022-06-25
Last full system update: 2022-11-18 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            mnt-sr0.mount fancontrol.service NetworkManager-wait-online.service

This might be unrelated, but what is this failed unit? Do you have an optical media drive?

Paste into the thread the output of

cat /etc/fstab

I would test a few other kernels and see if you can recreate the issue, such as the LTS kernel or the vanilla Linux kernel.

I have two physical drives and an optical one. As far as I know, they all work properly. Although, now you mention, about the same time the problems started, Garuda randomly fails to load the desktop wallpapers on startup. They are located on the data secondary drive

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=23C8-50C1                              /boot/efi             vfat    umask=0077                                               0 2
UUID=810cddd0-3d54-45f7-88fa-84f8b12b1038   /                     btrfs   subvol=/@,noatime,compress=zstd,discard=async,ssd        0 0
UUID=810cddd0-3d54-45f7-88fa-84f8b12b1038   /home                 btrfs   subvol=/@home,noatime,compress=zstd,discard=async,ssd    0 0
UUID=810cddd0-3d54-45f7-88fa-84f8b12b1038   /root                 btrfs   subvol=/@root,noatime,compress=zstd,discard=async,ssd    0 0
UUID=810cddd0-3d54-45f7-88fa-84f8b12b1038   /srv                  btrfs   subvol=/@srv,noatime,compress=zstd,discard=async,ssd     0 0
UUID=810cddd0-3d54-45f7-88fa-84f8b12b1038   /var/cache            btrfs   subvol=/@cache,noatime,compress=zstd,discard=async,ssd   0 0
UUID=810cddd0-3d54-45f7-88fa-84f8b12b1038   /var/log              btrfs   subvol=/@log,noatime,compress=zstd,discard=async,ssd     0 0
UUID=810cddd0-3d54-45f7-88fa-84f8b12b1038   /var/tmp              btrfs   subvol=/@tmp,noatime,compress=zstd,discard=async,ssd     0 0
tmpfs                                       /tmp                  tmpfs   noatime,mode=1777                                        0 0
/dev/disk/by-uuid/4CAA6027AA600FAE /mnt/4CAA6027AA600FAE auto uid=1000,noatime,nodiratime,async,nofail,x-gvfs-show 0 0
/dev/sr0 /mnt/sr0 auto nosuid,nodev,nofail,x-gvfs-show 0 0

Remove these two lines and reboot to test it.
They seem to have been added by gnome disks (or similar app).
You can use other methods to achieve what you need, if removing them solves your issue.

1 Like

Actually they were added by me :sweat_smile:. I always keep my user data in a different disk than my O.S. as a security measure and I needed to auto-mount it before my session starts or kde would forget the folder customization.

It worked for the last 5 months or so but I am willing to test it. Maybe an update screwed it.

Well, it seems you were right: Removing those lines appears to prevent the system from crashing on power saving. The "Hows" and "Whys" are beyond me, and I'll like to understand then. Starting with why did it work without problems until this month.

But right now what I need is a workaround that allows the disc to be automounted on start up without funny stuff like having to configure the custom "Documents", Videos" etc folders on every start up.
In the past I tried:

UUID="4CAA6027AA600FAE"      /run/media/antonio/WD10SPZX SATA   ntfs   defaults   0   0


UUID="4CAA6027AA600FAE"       /home/antonio/datos   ntfs    users

but I experienced some funny behavior, like file being moved to the main drive trash on deletion, instead of using the trash folder on their own drive or not being able to execute programs from the drive.

I would be thankful if I could have some assistance on the matter.

I am no expert on ntfs, though I can only give some advice.

  • Use a mount point at /media/, or at /srv/ to follow Arch/Linux FS directives
  • To better handle auto mounting, use this noauto,x-systemd.automount. Read more advice at fstab wiki article.
  • Before you add an entry at fstab, test/try mounting the partition manually, using mount options that would serve your purpose.
  • Read the latest mount options for mount command, as they change by time, and some old advice may not be perfect/successful
  • Since trying2learn :wink: , I suggest you try the systemd-mount command.
  • See how others do it, for example this (from ddg search)

Thanks for the info.

Sadly, I must inform that I was a little too enthusiastic about the problem being gone: I am still having some funny behavior even with the secondary disk unmounted.

Sometimes the system doesn't totally freeze but comes back very slow and Late dock and panels are nowhere to be seem.

I am starting to suspect about Latte more than about the HDD.

Latte development has paused, thus with the rapid KDE advancements, some glitches might be expected. I would advise you to replace Latte functionalities with standard Plasma panels, as they can do a lot (not like Latte, but still :person_shrugging: ).

1 Like

What type of suspend is in use? Check with:

cat /sys/power/mem_sleep

Someone else recently started having issues with their device resuming from suspend--maybe a kernel bug, who knows?--and their issue was resolved by switching from suspend-to-disk to suspend-to-RAM.

See the solution here:

Most of the drawbacks of using this method are related to laptop use (suspend-to-RAM continues to draw power while suspended, which can slowly drain a laptop battery). Considering you have a desktop machine, this may be a good solution for you.


Well, it wasn't Latte either. But now I spent the afternoon rebuilding my U.I. to the default Plasma panels, I'm keeping then. Latte was always a little buggy to me. :sweat_smile:

What type of suspend is in use? Check with:

cat /sys/power/mem_sleep

Someone else recently started having issues with their device resuming from suspend--maybe a kernel bug, who knows?--and their issue was resolved by switching from suspend-to-disk to suspend-to-RAM.


s2idle [deep]

I am willing to test that too. But I would like to have a rollback command, if possible :smile:

You can switch to s2idle like so:

echo s2idle | sudo tee /sys/power/mem_sleep

The command won't survive a reboot, so I guess the "rollback" is built-in on this one. :wink:

Run the command and test resuming from suspend. If it resolves the issue, you can make it permanent by adding mem_sleep_default=s2idle to your kernel parameters.


have you tried

  1. reboot
  2. update
  3. launch fish and sudo dkms autoinstall? Then see if the sleep problem persists?

This might be unrelated but right after installing garuda on my laptop it was having black screen problems after resuming from sleep. I tried all the articles on black screen from the forum with no changes. Posted my problem here and was suggested to use linux-lts which worked fine for a day and then problem resurfaced. nothing was working for me but and at my wits end I accidentally figured this fix for me.

I don't know why this fixed it but it did and now I run sudo dkms autoinstall after every update and so far have no problems with sleep ever since.

Without the 1st sudo :

echo s2idle | sudo tee /sys/power/mem_sleep

The same command with the other option:

echo deep | sudo tee /sys/power/mem_sleep

Thanks a lot. s2idle seems to be working for the moment. I want to keep testing it just to be sure before I flag it as the solution, but so far, so good.

Also, I think I'll keep going without Latte from now on anyway. It was cool, but it was always buggy for me so, brains before beauty ...

1 Like

Well, since I switched to s2idle I haven't been able to reproduce the problem. So we have a solution. :slightly_smiling_face:

Thanks for the help.

1 Like

I tested the other solution first and it worked for me , so I haven't used your. But thanks nonetheless.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.