Symbol 'efi_wrap_1' not found

Yes. I have done those two.

All right try to reboot and see if it works.

1 Like

IT WORKS!! My PC is back to normal. Thank you so so so much! Thank you for helping me!

That’s great news :smile:. Do remember that updating your system would lead you stuck at initramfs error again so read this thread in it’s entirety to understand why this is happening and how to avoid it. (it’s not long)

1 Like

I am going to read it right now. Thank you again for your help! I hope you will have a wonderful day!

I am going to mark your first answer as solution.

Sure, if you find yourself stuck somewhere you can reach out :+1:


I was wondering...if I wait few days (updating my system can wait few days), will the bug in plymouth-git be solved? Or updating now and then getting the rude stuck at initramfs solved is the only way to update my system?

I'd not wait for an update with the fix.
The issue was reported by a user in our forum a few days ago, but it seems that so far it has not been taken into consideration... So it will take time.
I'd rather replace plymouth-git with plymouth or simply override it removing the splash boot parameter. Better to keep your system up to date...


So if I understand it, all I need to do to avoid any errors is:

sudo pacman -S plymouth

To replace the -git version and then I can garuda-update and restart?


sudo pacman -S plymouth

you would have to update your initramfs following this post

Then you should update.


Okay, I am doing it.
What is dracut-rebuild? I don't have that command. :sweat_smile:

Can you give me your garuda-inxi I will give correct steps accordingly


  Kernel: 6.3.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=e1fd8aa5-3909-4e25-beac-5e11b1b3a928 rw rootflags=subvol=@
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.27.5 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: STRIX B250G GAMING v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 0809
    date: 07/07/2017
  Device-1: hidpp_battery_0 model: Logitech Wireless KeyboarWir serial: N/A
    charge: 50% (should be ignored) rechargeable: yes status: N/A
  Info: model: Intel Core i5-7500 bits: 64 type: MCP arch: Kaby Lake
    gen: core 7 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 9 microcode: 0xF2
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 3700 high: 3702 min/max: 800/3800 scaling:
    driver: intel_pstate governor: performance cores: 1: 3701 2: 3700 3: 3700
    4: 3702 bogomips: 27199
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: ASUSTeK driver: nvidia
    v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
    status: current (as of 2023-05) arch: Pascal code: GP10x
    process: TSMC 16nm built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:1c03 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
    compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
    alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 5520x1163 s-dpi: 88 s-size: 1594x335mm (62.76x13.19")
    s-diag: 1629mm (64.13")
  Monitor-1: DP-1 pos: top-left res: 1680x1050 dpi: 91
    size: 470x300mm (18.5x11.81") diag: 558mm (21.95") modes: N/A
  Monitor-2: HDMI-0 pos: primary,bottom-c res: 1920x1080 hz: 60 dpi: 82
    size: 598x336mm (23.54x13.23") diag: 686mm (27.01") modes: N/A
  Monitor-3: HDMI-1 pos: bottom-r res: 1920x1080 hz: 60 dpi: 82
    size: 598x336mm (23.54x13.23") diag: 686mm (27.01") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce GTX 1060
    6GB/PCIe/SSE2 direct-render: Yes
  Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel alternate: snd_soc_avs bus-ID: 00:1f.3
    chip-ID: 8086:a2f0 class-ID: 0403
  Device-2: NVIDIA GP106 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:10f1 class-ID: 0403
  Device-3: Kingston HyperX Cloud II Wireless
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-7:4 chip-ID: 0951:1718 class-ID: 0300
    serial: <filter>
  API: ALSA v: k6.3.5-zen1-1-zen status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 0.3.71 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: br0 state: up speed: 1000 Mbps duplex: unknown mac: <filter>
  IF-ID-2: docker0 state: down mac: <filter>
  IF-ID-3: virbr0 state: down mac: <filter>
  Local Storage: total: 1.02 TiB used: 181.2 GiB (17.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SUV400S37120G
    size: 111.79 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 87RA scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD10EZRZ-00HTKB0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
    fw-rev: 1A01 scheme: GPT
  ID-1: / raw-size: 111.53 GiB size: 111.53 GiB (100.00%)
    used: 105.27 GiB (94.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%)
    used: 562 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 111.53 GiB size: 111.53 GiB (100.00%)
    used: 105.27 GiB (94.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 111.53 GiB size: 111.53 GiB (100.00%)
    used: 105.27 GiB (94.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 111.53 GiB size: 111.53 GiB (100.00%)
    used: 105.27 GiB (94.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.56 GiB used: 2.19 GiB (14.1%)
    priority: 100 dev: /dev/zram0
  System Temperatures: cpu: 41.0 C mobo: N/A gpu: nvidia temp: 54 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 26%
  Processes: 315 Uptime: 2h 20m wakeups: 22 Memory: available: 15.56 GiB
  used: 6.96 GiB (44.7%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7 Packages: 1768 pm: dpkg
  pkgs: 0 pm: pacman pkgs: 1754 libs: 410 tools: octopi,paru pm: snap pkgs: 14
  Shell: fish v: 3.6.1 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.27
Garuda (2.6.16-1):
  System install date:     2021-10-22
  Last full system update: 2023-06-30
  Is partially upgraded:   Yes
  Relevant software:       snapper NetworkManager mkinitcpio nvidia-dkms
  Windows dual boot:       No/Undetected
  Failed units:            postgresql.service 

Oh so you are still on mkinitcpio to generate your initramfs. Here:

  1. sudo pacman -S plymouth
    to switch from plymouth-git to plymouth

  2. sudo plymouth-set-default-theme -R dr460nized
    This will both set the default dr460nized theme as your boot splash and rebuild your initramfs


That’s the command to regenerate initramfs for systems using dracut. We switched from using mkinitcpio to dracut for generating initramfs. It automatically detects what needs to be in the initramfs for your system unlike mkinitcpio that generates a generic initramfs. This means less modules to load on boot and thus faster bootups.

If you wish to know more about it or switch to dracut here:


Thanks for the info! I updated to dracut. I did the things, now I am going to update my system. Will be back soon with info.

Finally after an hour I could free up some space. Now, when I garuda-update, there is an error:

error: failed to commit transaction (conflicting files)

How can I force it to install all packages no matter what conflicts?

post the full output of garuda-update let's have a look at it. Also can you post your updated garuda-inxi just once more?

I solved it. I though it would be the situation with ALL packages. I followed this ARCH docs to "force update" that package and as it turns out no other package reports conflict.

Can you still post the output of

grep '2023-07-04' /var/log/pacman.log | tb

to be on the safe side.