Boot stucks at "loading initial ramdisk" after every Update

Hello my friends,

i recently updated my system, now it´s "stuck" on "loading initial ramdisk" while booting.

As suggested in a few threads here, i tried to load an Pre-Update-Snapshot.
After selecting the snapshot via GRUB garuda loads sucessfully, everything seems to work.
Snapper told me to immediatly reboot, i did this.
After Reboot i only came to grub rescue mode.

As described in another Thread here, i boot from garuda iso and repaired GRUB (via "Garuda Boot Repair" from garuda-welcome).
After that i restarted again and garuda still boots fine.

Then Discover told me that i´ve got (about 340) Updates outstanding, so i installed them.
After this, garuda-maintanence told me that i should perform a full update (partially updates are not supported), wich i did.
After Updating and restarting, i´ve got the same problem again, boot stucks at "loading initial ramdisk".

You´ve got any ideas how to fix this and perform updates again?


1 Like

Ty, i´ll try this and report you if it helped :wink:

I've had the same issue on both Garuda Xfce and Garuda Dr460nized.
Choosing the repair boot option in the Garuda bootloader gui solved it !

1 Like

Repair Boot didnt worked.

As mentioned by @NaN i´ve tried to delete "splash" from GRUB, and now my system booted normally again.

Problem seems to be solved through this.

Just for my knowledge, any Idea why "splash" made a problem?
Don´t want it to happen again :wink:


The latest plymouth-git update has a bug. That’s why removing the splash kernel parameter disabled plymouth’s execution and allowed you to boot normally,
You can resolve this by going from plymouth-git to plymouth. The reason why garuda uses plymouth-git by default is because the “regular” plymouth package doesn’t receive updates as often.

To switch the packages:

sudo pacman -S plymouth

This will ask you to remove plymouth-git since it conflicts with plymouth enter Y to do so and continue installing. After the installation is done to update the initramfs follow the post below, It’s necessary for plymouth.


I had the same issue, but none of my snapshots or even the repair option was working. Got stuck at a black screen only showing Setup Virtual Console failed to load. I reinstalled before I saw the thread here on the forum.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.