Switching Activity Randomly Freezes Windows

There’s a very annoying issue since upgrading to Plasma 6. I’m using 2 Activities (not desktops) and switch back and forth with Meta+Tab.

Every now and then, it causes application to stop responding to mouse and keyboard inputs. Pressing Alt+Tab a few times usually restores functionality. But Jetbrains Rider app doesn’t recover from it, and the only solution is to close it when that happens, possibly losing some work.

Now this is a KDE bug and probably should be reported there… it asks on which product to report the bug from a long list and I’m really not sure where that goes!

My inxi (I do need to reboot but that’s not related)

Kernel: 6.9.1-arch1-1.1 arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux
root=UUID=58203bda-e2e2-4c32-a006-c91d933cad4e rw rootflags=subvol=@
loglevel=3 quiet intel_iommu=on iommu=pt ibt=off
Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.2.0
wm: kwin_x11 with: krunner vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Type: Laptop System: Acer product: Predator PH315-53 v: V2.04
serial: <superuser required>
Mobo: CML model: QX50_CMS v: V2.04 serial: <superuser required>
part-nu: 0000000000000000 uuid: <superuser required> UEFI: Insyde v: 2.04
date: 08/20/2021
ID-1: BAT1 charge: 43.7 Wh (100.0%) condition: 43.7/58.8 Wh (74.4%)
volts: 16.4 min: 15.4 model: SMP AP18E7M type: Li-ion serial: <filter>
status: full
Info: model: Intel Core i7-10750H bits: 64 type: MT MCP arch: Comet Lake
gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm family: 6
model-id: 0xA5 (165) stepping: 2 microcode: 0xFA
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 2707 high: 4703 min/max: 800/5000 scaling:
driver: intel_pstate governor: performance cores: 1: 800 2: 800 3: 800
4: 4559 5: 800 6: 4652 7: 4703 8: 4663 9: 4521 10: 800 11: 4596 12: 800
bogomips: 62431
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Acer Incorporated ALI
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: none off: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0
chip-ID: 8086:9bc4 class-ID: 0300
Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile]
vendor: Acer Incorporated ALI driver: nvidia v: 550.78
alternate: nouveau,nvidia_drm non-free: 550.xx+ status: current (as of
2024-04; EOL~2026-12-xx) arch: Turing code: TUxxx process: TSMC 12nm FF
built: 2018-2022 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
speed: 8 GT/s ports: active: none off: HDMI-A-2 empty: DP-1
bus-ID: 01:00.0 chip-ID: 10de:1f15 class-ID: 0300
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia dri: iris
gpu: i915,nvidia,nvidia-nvswitch display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-2 mapped: HDMI-1-0 note: disabled pos: primary
model: Samsung serial: <filter> built: 2016 res: 1920x1080 hz: 60 dpi: 40
gamma: 1.2 size: 1210x680mm (47.64x26.77") diag: 1168mm (46") ratio: 16:9
modes: max: 1920x1080 min: 640x480
Monitor-2: eDP-1 note: disabled model: AU Optronics 0x82ed built: 2018
res: 1920x1080 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 394mm (15.5") ratio: 16:9 modes: 1920x1080
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 1 drv: iris device: 3 drv: swrast surfaceless:
drv: nvidia x11: drv: iris inactive: gbm,wayland,device-2
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.0.7-arch1.3.1
glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics (CML GT2)
device-ID: 8086:9bc4 memory: 15.09 GiB unified: yes
API: Vulkan v: 1.3.285 layers: 11 device: 0 type: integrated-gpu
name: Intel UHD Graphics (CML GT2) driver: mesa intel v: 24.0.7-arch1.3.1
device-ID: 8086:9bc4 surfaces: xcb,xlib device: 1 type: discrete-gpu
name: NVIDIA GeForce RTX 2060 driver: nvidia v: 550.78
device-ID: 10de:1f15 surfaces: xcb,xlib device: 2 type: cpu name: llvmpipe
(LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.7-arch1.3.1 (LLVM
17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel Comet Lake PCH cAVS vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel alternate: snd_soc_skl, snd_soc_avs,
snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0403
Device-2: NVIDIA TU106 High Definition Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:10f9 class-ID: 0403
Device-3: Texas Instruments PCM2900B Audio CODEC
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 1-1.3:10 chip-ID: 08bb:29b0 class-ID: 0300
API: ALSA v: k6.9.1-arch1-1.1 status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 1.0.6 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Comet Lake PCH CNVi WiFi vendor: Rivet Networks Dual Band
Wi-Fi 6 Killer AX1650i 160MHz 2x2 driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-2: Realtek Killer E2600 GbE vendor: Acer Incorporated ALI
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000
bus-ID: 08:00.0 chip-ID: 10ec:2600 class-ID: 0200
IF: enp8s0 state: down mac: <filter>
IF-ID-1: docker0 state: down mac: <filter>
IF-ID-2: virbr0 state: down mac: <filter>
IF-ID-3: virbr1 state: down mac: <filter>
Info: services: NetworkManager, smbd, systemd-networkd,
systemd-timesyncd, wpa_supplicant
Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:9 chip-ID: 8087:0026
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 5.2 lmp-v: 11
status: discoverable: no pairing: no
Local Storage: total: 3.19 TiB used: 1.64 TiB (51.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:2 vendor: Western Digital
model: WD Blue SN570 2TB size: 1.82 TiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 234200WD temp: 54.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Western Digital model: PC SN730
SDBQNTY-512G-1014 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 11101100 temp: 59.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS721010A9E630
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: A3J0 scheme: GPT
ID-1: / raw-size: 1.81 TiB size: 1.81 TiB (100.00%) used: 571.04 GiB (30.8%)
fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 51.2 MiB (53.4%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:3
ID-3: /home raw-size: 1.81 TiB size: 1.81 TiB (100.00%)
used: 571.04 GiB (30.8%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 1.81 TiB size: 1.81 TiB (100.00%)
used: 571.04 GiB (30.8%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 1.81 TiB size: 1.81 TiB (100.00%)
used: 571.04 GiB (30.8%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: partition size: 11.72 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p2 maj-min: 259:4
ID-2: swap-2 type: zram size: 15.45 GiB used: 7.9 GiB (51.1%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12
dev: /dev/zram0
System Temperatures: cpu: 75.0 C pch: 80.0 C mobo: N/A
Fan Speeds (rpm): N/A
Memory: total: 16 GiB available: 15.45 GiB used: 9.32 GiB (60.3%)
Processes: 394 Power: uptime: 4d 5h 23m states: freeze,mem,disk
suspend: deep avail: s2idle wakeups: 0 hibernate: platform avail: shutdown,
reboot, suspend, test_resume image: 6.14 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 2256 libs: 576 tools: octopi,pamac,paru
pm: appimage pkgs: 0 Compilers: clang: 17.0.6 gcc: 14.1.1 alt: 11
Shell: garuda-inxi default: Bash v: 5.2.26 running-in: konsole
inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2021-11-24
Last full system update: 2024-05-22 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       Probably (Run as root to verify)
Failed units:            systemd-networkd-wait-online.service

im not sure if it will solve your issue but there is this fix tell plasma fixes it

I was thinking of this as well.
Even on fast drives I’ve noticed some unpredictable stability issues when using alt+tab and using a task switcher visualization. Nothing concrete to put into a report quite yet however as it is very random across my machines (and sessions).
Wouldn’t hurt to try going to KDE’s Settings and within the Task Switcher options to turn off the visualization as a quick troubleshooting step however. (Maybe a restart after to reset the cache.)

Hopefully this issue is related to 487043 – Extreme stutters/hangs when using certain desktop effects when "~/.cache" is on slow storage in some way and the KDE fix will hopefully just utilize RAM instead of a storage cache for desktop effects. (or at least as an option. There are systems out there with low RAM, although low powered systems should shut off all desktop effects anyways)


Ya there are quite a few annoying issues since Plasma 6. From freezing apps, to bottom toolbar that stays on top of windows even when “auto-hiding”, to micro-lags and stuff. Just the bottom toolbar seemed to be a bunch of different bugs and factors, really hard to report and track down.

Btw my main drive is a fast 2GB NVMe so no problem there.

What I always notice about your garuda-inxis is this:

Why do you always have such high temperatures?

Well it’s a laptop… it’s always running on NVidia RTX 2060 when outputting on the TV. Plus it’s damn hot in Mexico. Still Helios 300 got pretty good ventilation; and I put a stone under it to lift it and give more breathing space. Never goes above 90 when gaming though. That laptop is a beast.

You could consider that the breathe of a dragon.

Also got a lot of audios playing constantly in the background, makes some constant CPU activity.

1 Like

and I didn’t mention that when switching activity, or leaving the computer and coming back; sometimes windows snapped into a certain position on the screen lose their position

All bugs hard to track down and report…

that one is reported. at least iv’e seen it on the weekly updates they put out

Plasma 6.0.5 should be in the repos soon, maybe this will fix some of your issues.

You have had a number of issues since Plasma 6 and your Garuda installation is already very old (respect, btw). I would recommend a new installation, then you have a clean and solid foundation.

Did you just call me old?? I’m 39 but look like 30.

oh ya got this other issue… when booting laptop takes 1 minute to show the BIOS logo after a long blank screen, and eventually boots the OS after 10 minutes; and then EVERYTHING WORKS FINE. When shutting down, Linux complains about USB port 5 not responding; but there’s only 4 USB ports on a Acer Helios 300. Where the heck is Port #5 ??? I’m not sure I’d want to try re-installing the OS until that’s resolved. BIOS settings are too slow and don’t respond to keyboard inputs. Anyone ever seen anything like this? I tried removing all hard drive and all USB connections.

1 Like

And I look like I’m 20 :smiley:

This usually means that there is a problem with the hardware initialization. Does this happen even if you don’t have an external monitor connected?

Since you probably have Windows dual boot: are Fast Boot and Fast Startup disabled in the BIOS and Windows? Are you shutting down Windows correctly?

As for temperatures, CPU/GPU/NVME throttle if they get too hot - but the PCH doesn’t. Have you ever disassembled the laptop and cleaned the fans/coolers? Another point is the thermal paste; at permanently high temperatures it dries out more quickly and dissipates heat much more poorly.

btt: run a live journal (sudo journalctl -f) and see if anything useful is displayed if you have freezes in the activities.

Now we’re on 2 separate issues.

For Plasma, there is this in the journal

kf.plasma.quick: Exposed with no visual parent. Window positioning broken.

When an app froze from mouse inputs, there’s this error

qt.gui.icc: fromIccProfile: failed minimal tag size sanity

Playing around with windows, this appeared

kwin_core: XCB error: 152 (BadDamage), sequence: 39608, resource id: 24770480, major code: 143 (DAMAGE), minor code: 3 (Subtract)

Meh log is full of errors. Haven’t been able to reproduce Rider freeze that doesn’t recover yet.

For boot, I unplugged everything, HDMI, USB, hard drives. There is no Windows; not sure why it still says dual-boot.

If I bring to the repair shop, perhaps I could ask to redo the pasting, good idea.

When Rider froze, I got this error

org.kde.plasma.notificationmanager: Trying to replace notification with id 2625 which doesn't exist, creating a new one. This is an application bug!

your trackpad an keyboard can sometimes be on usb internally or sd card slots an such

1 Like

All USB ports are working fine. Keyboard and trackpad are also working just fine. No SD card slot.

As far as I know, you can ignore the journal messages shown.

Have you tried creating a new user account to check whether you have the same issues?

This is what @elite refers to. Your integrated webcam should actually also be connected internally via USB.


OHHHHHH!!! Yes I did have issues with the Webcam!! BINGO

1 Like

It is not displayed in your garuda-inxi either.
This could be why you are having BIOS issues and long initialization/boot times.
Either the webcam is broken or the plug is not properly connected to the mobo.

You should check your hardware or have someone check it.

As for your kde plasma issues, have you tried that:

It is also possible that a Linux driver or firmware update messed with your camera.

Test different boot disks to find out if the camera works with Ubuntu etc.

I tried booting on Windows (on a USB stick) and the webcam wasn’t working either. Need to go to a technician.

Will try a new user account later and report.

Alright I did create a new account. Very annoying: the keyboard shortcut to switch between laptop output and TV output appears but has no effect! It remains on expanding laptop display onto the TV and I can’t change that. That’s again a totally separate issue…

Unless I open Display Settings and disable the integrated display.

JetBrains Rider didn’t follow into the new account so I can’t test everything, but I’ll let you know if I see those issues again.

(and I’m pretty sure the webcam issue is causing heating and stutter issues)

Edit: The toolbar auto-hide appears to be working smoother. I have yet to encounter the Plasma issues yet.