Sweet/main plugin can't be loaded after the last update

Hey guys this is my issue

I'm trying to revert a snapshot but it's loading indefinitely

What should I do? I can't get into the desktop

First thing I'd try would be to boot to a TTY and update. If necessary chroot.

No pictures please. Especially the 2nd one is useless and could have been easilty described (this is the plymouth spalsh screen)

1 Like

Kde plug in not loading tho, the snapper is not working... My system did that after the octopi update

I may have to reinstall

I'd not give up so early.
For the sddm theme problem you could try to tty or chroot and
sudo pacman -Syu sweet-theme-git
Hopefully the update might fix anything else missing.
In the worst case you could reinstall plasma-desktop, but I'd not reinstall everything before trying something.
For the snapshots problem, we'll see after...


How do I get into the console? I can't get to the desktop, when I put my psw it freezes

When you're in the grub line you normally use, press button E instead of enter.
Go at the end of the line starting with linux and add a 3 (with a space before, of course).
Then ctrl+X to boot to the console.

What? Where do I have to put the 3?

I have no idea

The line before echo should finish with
loglevel=3 3

1 Like

I'm sorry, I'm too dumb to understand where is the thing you are asking me...

To be honest it will be quicker to reinstall, all my stuff is on a separate drive

How to switch to runlevel 3 at the Grub2 boot menu:

You should have tried switching to a TTY (ctrl + alt + f3) and retried the update before attempting a system rollback IMO.


I need to get my system working fast... Have commissions to finish and get paid, so now I will brute force it.

All was working correctly until the last package update, bah reinstall may fix all the crap I did anyway

At the end of the line that starts with 'linux' and ends with 'loglevel=3'. That's where you'd add a ' 3' and hit F10 to continue boot. Another quick option if you did have snapshots would be to boot a garuda live environment and use the btrfs assistant application to restore a snapshot.


thanks i surely will if something like that happens again... i reinstalled and doing that some stuff i destroyed now work... win win xD

i have done some dumb stuff when using it for the first time, it was a question of time for the system to die on me

thank you guys

@LimticBun snapshots will save you a lot of trouble countless number of times in the Arch world. I highly suggest you learn about them and start using them. :smiley: And you're at the right place, Garuda has made this feature very easy to use for everyone.


I'm kinda confused by this error. I might be wrong, but this looks rather like some Plasma version mismatches. I've seen this happening on kde-git, when some packages needed a rebuild. Is there anything in the in themes QML built against other packages?

1 Like

@FGD yeah i tried but no snapshot would boot, I've used it many times but it would not work at all this time...

@dr460nf1r3 it's strange that i couldn't even login, the funny thing is that i updated the day before it did the same but i used the Snap thinking it was something that would be fixed today, but it seems was something only i had T_T

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.