SWAY + NVidia

So currently i am running Garuda with KDE on my system. It works perfectly fine.

Now i installed Garuda Sway on my AMD Laptop and switched SWAY for Hyprland and fell in love with it.

I want to try it on my main system that runs a NVidia RTX3070. Because i see that many people are reporting that wayland gaming with NVidia seems to be stable enough...

But when i try to boot into Garuda Sway (fresh download and checked for checksum) i can't proceed.

  1. If i take the nouvou drivers, it will kernel panic
  2. If i take proprietary drivers it will run infinitely in MHWD for the drivers (actually forgot about it when i went to work and came back to the same screen with the timer running for 10 hours straight lol)

I wanted to use SWAY as the foundation for my Hyprland setup because 1) it worked beautifully fine on my laptop and 2) Hyprland is supposed to be a drop in replacement for sway, so many applications that are configured for sway work perfectly fine with the same config for hyprland.

Any ideas? It's not urgent but i'd love to give it a shot on a spereate SSD to see if the state of wayland is good enough for my day to day use and gaming.

Cheers!

Running Sway on Nvidia hardware is possible, but requires special configuration and is emphatically not supported. This is from the Sway website:

Nvidia users

All proprietary graphics drivers are unsupported. This includes the Nvidia proprietary driver. The open source Nouveau driver can be used instead. Tip: buy your hardware with open source support in mind.

From the ArchWiki page:

Note: All proprietary graphics drivers are not supported, including NVIDIA. After NVIDIA driver version 495, sway works if you enable kernel mode setting and run sway with --unsupported-gpu.

If you still want to try making it work, add the --unsupported-gpu flag after "sway" on the command = line in /etc/greetd/config.toml, or try running sway --unsupported-gpu from a TTY.

The mandatory run flag used to be "--my-next-gpu-wont-be-nvidia", so I guess you could say they have mellowed out some over the years. :smirk:

5 Likes

I thought this changed because i read some articles that 470 drivers and forward would be supported by sway....what a shame

well then i will try it with the --unsupported-gpu flag and see if it works reliably after i install Hyprland (because it is supported by them and many ppl report very good stability)

I first have to google however how i would enable this flag :smiley: never actually fiddled around with kernel / boot flags and stuff lol

To be clear, this is not a kernel or boot flag. Although you don't see it happening, your greeter literally runs the command sway after you log in, which launches the desktop. The same can be done from a TTY to start a Sway session. This is just a flag added to that command--nothing to do with the kernel or the boot process.

1 Like

oh okay...yeah but i don't even get to a login screen or anything.

When i chose the USB boot drive and see your garuda-grub screen where i can chose my keyboard layout and whether i want to boot with nouvou or proprietary drivers, i THEN get in the loop...so either kernel panic or endless MHWD.

So how would i access that /etc/greetd/config.toml file to put --unsupported-gpu in then?

:thinking: Hmm, you are right--it sounds like your issue is something other than what I was going on and on about. Sorry I did not read your post more carefully, I just saw Sway + Nvidia and assumed I knew what the issue was.

I can guarantee that both my usb drive and the method i use are not the problem. Because i checked and didn't trust myself lol.

I used multiple drives and multiple methods. Plus my go-to-method works perfectly fine with other ISOs. That is Ventoy on a high-quality USB Drive. Other ISOs on that drive boot perfectly fine.

I download Garuda Wayfire now because it is also based on wlroots and i try if i can boot that. And if yes if Hyprland would work with the preinstalled applications just as good as it does with sway.

Choose the "nouveau" option but add module_blacklist=nouveau,nvidia,nvidia-drm to kernel parameters. Garuda should use neither open source nor propriearty drivers allowing you to boot with a fallback driver. If this works send your garuda-inxi, install Garuda, add these kernel parameters again, do a system update, add unsupported GPU flag in /usr/share/wayland-sessions/sway.desktop, install Nvidia drivers

sudo pacman -Syu nvidia-dkms

and reboot.

2 Likes

Thanks for the guide!

but add module_blacklist=nouveau,nvidia,nvidia-drm to kernel parameters

this means i press "E" while in grub and add the line at the very end?

Press "e", go to the line that starts with "linux", most likely there already is a module_blacklist=... parameter, delete that and type what I mentioned.

Thank you so much! i give it a try and see if can continue!