Sway nvidia troubles


I recently installed Garuda sway on my PC and had major troubles after installing proprietary nvidia drivers.

The system always hangs when creating ramdisk, not even trying to change tty works. Sadly for this reason I can't post the output of commands as my pc is completely borked.

The weird thing that I noticed is that the nvidia driver install process complains about mkinitpcio, which does not make much sense as I have downloaded the latest iso and I checked and mkinitpcio is not installed.

I tried the steps on the boot issues faq and even tried to force Dracut to update but came empty handed.

Please post the output of garuda-inxi for all topics in an Issues & Assistance category.

You need to launch Sway with the --unsupported-gpu flag if you want to try using an Nvidia card, see here:

Note: All proprietary graphics drivers are not supported, including NVIDIA. After NVIDIA driver version 495, sway works if you enable kernel mode setting and run sway with --unsupported-gpu .

If you are using a wrapper script to set some environment variables when you launch Sway, just add the flag to the wrapper script. Otherwise you can add it to the config file for your display manager.