Super key views workspace & views all apps at the same time

Hi,

So looking at the new updates for the gnome version, i decided to reapply my configs to use the new version for Garuda ver. "Hawk Eagle". Therefore, I did the following:

Garuda Welcome > Garuda Assistant > Maintenance > "APPLY NEW CONFIGS/RESTORE DEFAULTS CONFIGS"

After this, when i press the super key, the view of my workspace looks like this:

Looks like restoring from timeshift doesn't help. Maybe it's an extension? Nothing is set to just "Super" in my keyboard shortcuts.

Edit: Also, logging out freezes the computer instead. What have i done?
Edit2: Timeshift fixed the logging out freezing issue.
Edit3: Looks like a re-log kinda fixes this problem, but i can reproduce the issue by doing the following:

  1. Ctrl + a: to view all apps
  2. Exit all apps screen by pressing escape twice or "super+a"
  3. Now when pressing super key, it looks like the above image.
  4. Logout and log back in to fix.

Best workaround: Disable 'dash to dock' extension. No app bar on the bottom anymore, but no problems with app view along with workspace overview being displayed at the same time.
Better workaround: Alt+F2 to enter custom command and enter 'r' to relaunch gnome desktop environment
Workaround: Exit view apps screen by pressing super key instead. (Application view is now unscrollable until gnome DE is refreshed)

Are you sure it's not as intended (a feature)?
Have you read Gnome User Manual?

2 Likes

It wasnt like this before i clicked "restore default configs". I could just spam super+a and the application view would open and close. Looks like someone else is having this problem as well, but no solution: gnome - Getting stuck on a glitch that looks like a combo of show applications and the activities screen - Ask Ubuntu

Which leads me to believe that this is a config issue somewhere. But I'm not sure where the configs are for the application menu.

Even when i reset gnome to default (gnome tweaks > 3dot menu on top bar > reset defaults), the issue isn't solved.

1 Like

Still avoiding to answer... :man_shrugging:

1 Like

haha, sorry. If you mean the link below, I've tried searching through it, but no luck.

I have no idea where you can find it.
I just know that the User Guide would show you what's a feature and what's not :wink:

I have decided to use Plasma/KDE, just to have peace of mind! :laughing:

and the posted link has old timestamps, so not updated...

Looks like if i disable the 'Dash to Dock' extension, it solves all the problems with the application overview and the workspace overview being displayed at the same time with the super key.

This takes away the bottom bar though.

Edit: I'll mark this as the solution. Looks to be a bug from the dash-to-dock' gnome extension. I'll post this to their github.

I was originally on KDE/Plasma on manjaro and garuda but the UI was very laggy with my nvidia proprietary drivers with my GTX 980ti so i gave up on it :sweat_smile:

1 Like

Final solution found here: Application overview behind activities and search · Issue #1344 · micheleg/dash-to-dock · GitHub

Gnome extensions > Dash to Dock > Launchers > enable show applications icon

@petsam fyi, it looks like setting default configs in garuda assistant removes this setting

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.