Sudden drop in battery percentage

I have installed garuda dragonized edition just 3-4 days back. I am noticing low battery life and when the battery percentage reaches around 35% there is a sudden drop in battery percentage to 5%-10%. What are the possible cause for this and How can this be fixed ?

inxi -Fza
System:    Kernel: 5.12.10-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=ed07f0e4-525f-490e-8eb6-bbd3414e5b1f  
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.22.0 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Laptop System: Dell product: Inspiron 5570 v: N/A serial: <filter> Chassis: type: 10  
serial: <filter>  
Mobo: Dell model: 0GHXK4 v: A00 serial: <filter> UEFI: Dell v: 1.4.1 date: 12/24/2020  
Battery:   ID-1: BAT0 charge: 17.3 Wh (62.5%) condition: 27.7/42.0 Wh (66.1%) volts: 11.3 min: 11.4  
model: SMP DELL Y3F7Y6B type: Li-ion serial: <filter> status: Discharging  
CPU:       Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Kaby Lake note: check  
family: 6 model-id: 8E (142) stepping: A (10) microcode: EA cache: L2: 6 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28800  
Speed: 3400 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 3400 2: 3401 3: 3400 4: 3401  
5: 3401 6: 3400 7: 3404 8: 3400  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable  
Type: mds mitigation: Clear CPU buffers; SMT vulnerable  
Type: meltdown mitigation: PTI  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2  
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling  
Type: srbds mitigation: Microcode  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0  
chip-ID: 8086:5917 class-ID: 0300  
Device-2: Sunplus Innovation Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-5:2  
chip-ID: 1bcf:28c1 class-ID: 0e02  
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: amdgpu,ati,intel  
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1  
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")  
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3")  
OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.1.2 direct render: Yes  
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel  
alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403  
Sound Server-1: ALSA v: k5.12.10-zen1-1-zen running: yes  
Sound Server-2: JACK v: 0.125.0 running: no  
Sound Server-3: PulseAudio v: 14.2 running: no  
Sound Server-4: PipeWire v: 0.3.30 running: yes  
Network:   Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169 v: kernel  
port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8136 class-ID: 0200  
IF: enp2s0 state: down mac: <filter>  
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Dell  
driver: ath10k_pci v: kernel port: d000 bus-ID: 03:00.0 chip-ID: 168c:0042 class-ID: 0280  
IF: wlp3s0 state: up mac: <filter>  
Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-7:4 chip-ID: 0cf3:e009  
class-ID: e001  
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>  
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: f060  
bus-ID: 00:17.0 chip-ID: 8086.282a rev: 21 class-ID: 0104  
Drives:    Local Storage: total: 1.82 TiB used: 13.78 GiB (0.7%)  
SMART Message: Unable to run smartctl. Root privileges required.  
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000LM007-1R8174 size: 1.82 TiB  
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter>  
rev: SDM2 scheme: GPT
Partition: ID-1: / raw-size: 101 GiB size: 101 GiB (100.00%) used: 10.22 GiB (10.1%) fs: btrfs
dev: /dev/sda5 maj-min: 8:5
ID-2: /boot/efi raw-size: 500 MiB size: 496 MiB (99.20%) used: 102.9 MiB (20.7%) fs: vfat
dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 234.29 GiB size: 234.29 GiB (100.00%) used: 3.46 GiB (1.5%) fs: btrfs
dev: /dev/sda12 maj-min: 8:12
ID-4: /var/log raw-size: 101 GiB size: 101 GiB (100.00%) used: 10.22 GiB (10.1%) fs: btrfs
dev: /dev/sda5 maj-min: 8:5
ID-5: /var/tmp raw-size: 101 GiB size: 101 GiB (100.00%) used: 10.22 GiB (10.1%) fs: btrfs
dev: /dev/sda5 maj-min: 8:5
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: zram size: 981.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-2: swap-2 type: zram size: 981.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-3: swap-3 type: zram size: 981.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-4: swap-4 type: zram size: 981.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3
ID-5: swap-5 type: zram size: 981.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4
ID-6: swap-6 type: zram size: 981.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5
ID-7: swap-7 type: zram size: 981.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6
ID-8: swap-8 type: zram size: 981.2 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7
Sensors:   System Temperatures: cpu: 67.0 C mobo: 50.0 C sodimm: SODIMM C gpu: amdgpu temp: 60.0 C
Fan Speeds (RPM): cpu: 3678
Info:      Processes: 307 Uptime: 4m wakeups: 2 Memory: 7.67 GiB used: 2.79 GiB (36.4%) Init: systemd
v: 248 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.0 Packages: pacman: 1193 lib: 293
Shell: fish v: 3.2.2 running-in: konsole inxi: 3.3.04

This post details how to enable power saving:

Maybe this will help increase battery? Garuda is a gaming distro so it is by default configured to provide maximum performance. This is great, but not so good for laptops and battery powered devices because this can drain out the power quickly. This linked post details how to configure garuda for laptops and stop this from happening to save your battery.

2 Likes

okay will try out things listed there....I actually saw this post several times but didn't open it since there was no battery keyword listed in title.

I would assume that goes without saying since laptop is very clearly in the title.

actually I didn't know that garuda linux is more focussed towards desktop computers rather than laptops

I'm rolling exclusively on laptops, no issue with that. Its more of a question of how long batteries last with performance oriented defaults although its not hard to change that, as seen in the previously linked thread :grimacing:

3 Likes

hmm I changed to power-tweaks doesn't seem to have much improvement will probably use auto-cpufreq now...will keep posting updates here

What do you use for cpu management?

Im using auto-cpufreq. Have been trying tlp in the past for managing governors but that was waaaay to aggressive for my taste, setting powersave on battery just makes everything lagg like hell. So for me, auto-cpufreq is a nice middle way which still retains some performance.

1 Like

I was using auto-cpufreq uptil now but it interferes with my vm preventing the CPU from ramping up when gaming so I have been looking for alternatives. The 2nd post in my laptop thread makes mention of pstate-frequency which I have tried and , while it does work better, overall my laptop runs hotter than on auto-cpufreq . So I am looking for either an alternative or just edit the power plans for these.

using linux-lts with power-tweaks on....quite better than before....I think that's the best I can get without compromising performance. I am getting around 2 hours of screen on time with current settings.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.