Stunt Rally - dedicated GPU

Hello, I tried install this game but I didnt find it in repository (octopi). So I used flatpak version (I know that flatpak is not reommended).

Problem: I am not able to run it with dedicated nvidia GPU (proprietary driver).
(a bit lagging graphics and GreenWithEnvy doesnt show any load).

I tried edit launcher and add “run-prime” instead of “run” and no change, still running with intel graphics with small power. In Steam i can do this and dedicated GPU is working with mentioned command.

I tried also this: Plasma/Tips - KDE UserBase Wiki
But I have no item “discrete GPU” here.

Question 1: how to enforce flatpak appliccations to run with Nvidia (how to change launcher) … (I hope that my method to observe working of nvidia = GPU % item in GreenWithEnvy is correct)

Question 2: maybe I was searching wrong and there is some package with this game in garuda? (even if so, I would like to know also answer for question 1 for the future - and also i it is possible to explain me how to search for packages - octopi does not find “stunt”)

Thank you very much for your help and patience :slight_smile:

With Wine the same situation - I am not able to enforce using discrete GPU - I dont know how to edit launcher. I tried give “run-prime” everywhere in it and nothing is working - or the launcher doesnt work or it works but game is working with integrated intel (max 30 fps in Counter Strike 1.6). There are columns “program”, “arguments” and “working path”.

When I run this in console:

WINEPREFIX=/home/lenovo/.wine prime-run wine 'C:\users\lenovo\AppData\Roaming\Microsoft\Windows\Start Men

it runs with NVIDIA correctly. But when I put into .desktop into “program column” value “prime-run wine”, launcher stop to work. So what I shoud write into CS.desktop setting to achieve to run it with above mentioned command which is working?
When I switch it to “run in terminal” and “dont close after ending”, I will get reason why the launcher is not working: “run-prime wine”: directory or file doesnt exist. So how to adjust launcher please?

when I put into env variables “WINEPREFIX=/home/lenovo/.wine prime-run”, during saving the “prime-run” is shifted to “program” column and “wine” from program is shifted to arguments column. After that it launch with wine and probably also with prime-run but the launching is stopped after few rows. Despite of EDIT2 command it doesnt work, game is not launched.

The similar I made with Stunt Rally - edited .desktop file, put:

Exec=prime-run /usr/bin/flatpak run --branch=stable --arch=x86_64 --command=stuntrally org.tuxfamily.StuntRally

Also there already was:


After launching in terminal, everything looked ok, but in one moment it ended.
But despite to wine situation, here is not heping when I give it to terminal - the same result, game not launch with prime-run. No error written, just stop write outputs to terminal and thats it.

I already know the difference between launching with launcher .desktop and launching immediatelly in terminal. When I run .desktop, the program will stop in one moment -

0024:fixme:exec:SHELL_execute flags ignored: 

and when I run in terminal, in the absolutely same moment program stop, and I can see “lenovo@lenovo in ~ took 5s” and after that it CONTINUES (thats the difference!) with “C:\users\lenovo\Counter-Strike 1.6>start hl.exe -steam -game cstrike -noforcemaccel -noforcemparms” and game launches. So whats wrong with .desktop that this step will not come?

Even if i am running with prime-run, it is writing:

MESA-INTEL: warning: Haswell Vulkan support is incomplete

But GreenWithEnvy shows that Nvidia GPU is loaded. But FPS is still not great (about 40)… does it mean that Nvidia is running through incomplete Vulkan? Or it is ok? I am affraid if steam dont use some better Vulkan, because I feel through steam are results bit better.

After 1000 trials I finaly got working .desktop for wine/CS16 - after edit with Kate, following form was working:

Exec=env WINEPREFIX=/home/lenovo/.wine prime-run wine 'C:\\users\\lenovo\\AppData\\Roaming\\Microsoft\\Windows\\Start Menu\\Programs\\Counter-Strike.lnk'

The same I made in .desktop for flatpak/stunt rally:

Exec=prime-run flatpak run --branch=stable --arch=x86_64 --command=stuntrally org.tuxfamily.StuntRally
But here ISSUE REMAINS - after launching with "prime-run"  it will crash:
Registering ResourceManager for type Texture
RenderSystem::_createRenderWindow "Stunt Rally", 1920x1080 fullscreen  miscParams: FSAA=0 parentWindowHandle=119537666 title=Stunt Rally vsync=true

Then black blink screen and end.
When I delete “prime-run” from above mentioned .desktop formula, its running normally… But on Intel…

It’s available in the AUR.

╭─user@zbook in /etc🔒 as 🧙 took 338ms
[🔴] × pamac search stuntrally
stuntrally-git  2.7.r37.g747b901d-1                                                                                                                                                                  AUR
A 3D racing game based on VDrift and OGRE with track editor
stuntrally-bin  2.6-1                                                                                                                                                                                AUR
A 3D racing game based on VDrift and OGRE with track editor

(I use pamac-aur for my aur helper because I think my paru got stuck using a proxy that doesn’t work with it anyway and pamac uses my proxy without fuss). But if your paru works with aur you can use it to install either one, or you can build either one manually with makepkg if you know how. If you don’t, look here…it’s the “recommended by arch” way. I personally like the aur helpers, but I use makepkg quite often when aur helpers fail, which is quite often for me.

We rarely, if ever, don’t have something in arch. That’s why we don’t use flatpaks unless there is really no other option.

Anyway, thanks for the tip. I’m gonna check it out!!

BTW, your garuda-inxi is missing.

And do you use a switching method? Like optimus-manager or the like? What happens when you run just the nvidia graphics? I can’t tell without your garuda-inxi which gpu is your current renderer. You should add it before a mod deletes your post. It’s required…just edit your post and add the output of garuda-inxi.

Here’s a good read if you haven’t read it.

NVIDIA Optimus - ArchWiki.

It pertains to your computer’s graphics setup and how to switch GPUs. I personally use optimus-manager and optimus-manager-qt.

I believe you are correct. My GreenWithEnvy won’t even open if nvidia is not my renderer. You can also run inxi -G and see which one is the renderer. I recommend you just install either aur pkg and see if it helps first with nvidia as the renderer.

EDIT: stuntrally-bin is working with my Nvidia graphics while switched to Nvidia as my renderer.

╭─user@zbook in ~ took 68ms
╰─λ optimus-manager --status
Optimus Manager (Client) version 1.5

Current GPU mode : nvidia
GPU mode requested for next login : no change
GPU at startup : nvidia
Temporary config path: no

╭─user@zbook in ~ took 259ms
╰─λ inxi -G
Device-1: Intel HD Graphics 530 driver: i915 v: kernel
Device-2: NVIDIA GM107GLM [Quadro M2000M] driver: nvidia v: 545.29.06
Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4 driver: X:
loaded: modesetting,nvidia dri: iris gpu: i915 resolution: 1920x1080~60Hz
API: EGL v: 1.5 drivers: iris,nvidia,swrast
platforms: x11,surfaceless,device
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06
renderer: Quadro M2000M/PCIe/SSE2
API: Vulkan v: 1.3.276 drivers: nvidia surfaces: xcb,xlib

It would not load properly at all with my Intel HD 530 graphics as renderer.

This is the 1st graphically intense game I’ve tried with my “new” laptop (an HP Zbook 15 G3) and I upgraded the GPU a couple of days ago from a Quadro M600M to a Quadro M2000M and I’m very impressed with my new card. I turned on all the effects and still it stays at 60fps. I’m going to see how much it takes to make it drop. The game is hard as hell though. After my 6th try I still haven’t cleared the 1st tutorial stage. Lol. Thanks for the game!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.