Stuck trying to migrate system to nvme

Hello,

I am trying to migrate my garuda installation from ssd to nvme

Here is what i did

  1. Did a device to device clone with clonezilla

  2. Didn't boot so i booted from a live usb

3.followed these directions Grub fails after update - #3 by librewish

  1. When i use the
    "sudo mount /dev/sdxy /mnt" command on the nvme (nvme0n1p2)
    I get
    "mount: /mnt: mount(2) system call failed: file exists.

Not sure what to do from here other than a fresh install. Any tips?

Did you verify /etc/fstab?

This might be the cleanest solution. Then bring the new installation up to date and copy over your files and configs.

What did it do? Any error messages? How far into the boor process did you get?

Please connect to the forum from the live environment and paste the exact input/output from the terminal into the thread.

1 Like

BluishHumility
This might be the cleanest solution. Then bring the new installation up to date and copy over your files and configs.

If i just copy the home/ directory and /etc/ will that work?

I would not blindly copy over /etc if you are not copying over the rest of the system files. What you need will be recreated when you reinstall your packages. Files in /etc you have explicitly modified (if you have a customized pacman.conf or sshd_config or something) you can copy over piecemeal. For most folks, going back after the fact and adjusting any configs that were forgotten will be trivial.

Most of your user-specific configuration is stored in dot files in the home folder. After you have finished installing all your packages, if you copy over the home folder you will probably be pretty close to where you left off--even your browser history, etc should be in there.

Are you giving up on the disk migration? It seems like something that should be possible--just a little tricky, because you are changing from a /dev/sda to a /dev/nvme0n1. I would expect /etc/fstab may need to be revised, and reinstalling Grub was not a bad call.

1 Like

This is exactly what i ended up doing,

Its caused a few issues when installing stuff but its usually some file already exists
I solved it by deleting some file and then re-attempting the installation.

i haven't noticed any other issues so far apart from this in steam
proton-ge-custom (Unsupported AUR package [native])
but that might be unrelated i'm trying to figure it out right now.

fixed it, same solution

sudo rm -rf /etc/security/limits.d/10-games.conf

then reinstalled proton-ge

I had tried to do the same and after like 2 hours of tinkering and even asking my friend who has more experience with Linux...we both gave up and i just backed up what i wanted and did a clean install. :frowning:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.