Stuck on loading initial ramdisk after update - solved

Hello to all,
first of all: my laptop is a dell precision, with windows 11 and dual boot for garuda (2 nvme disks).
i had some issues with my Dell precision laptop with Garuda. The boot crashes after first big system update.
I tried many way to solve the problem:
Use LTS kernel: same problem
Use nvidia open drivers : same problem
And i finally found the problem, on that laptop, Dell configures harddisk to work with RAID instead of AHCI. I had to switch my windows installation disk to AHCI and bios configuration also.
I reinstalled garuda and updated it: all is working perfectly !! :slight_smile:
Hope it will help some of you !!

Yes, that’s right. This is mentioned under Installation Procedure on the download page:

  • Make sure that your device’s SATA controller is set to AHCI mode in your device’s setup utility. Otherwise, the Linux kernel may not be able to detect your drive.

Just another one of those charming Windows features that needs to be disabled so you can actually use your computer. :wink:

Glad to hear you got it working @dom, and welcome to the community. :slightly_smiling_face:


Thank you @BluishHumility ! After 5 days of using it, my Garuda linux is very stable :slight_smile: ++ :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.