Stuck on initial ramdisk after updating

Hey everyone, newbie looking to get some help. I did a fresh install of garuda last week and it worked fine although I had some errors that prevented me from updating. Was to lazy to figure out what they were so held off on it. I did a fresh install yesterday and now I can finish the setup assistant, but everytime I restart it gets stuck on

loading initial ramdisk...

I was looking through the forums and found different causes and different solutions. I suspect it’s an nvidia driver issue. I’m sorry if the answer exists but I executed it incorrectly.

Things I’ve tried:

  • pressing E before booting and removing splash or itd=off (itd=off already present and splash isn’t there)
  • switching from plymouth to plymouth-git
  • switch kernels

The two latter ones give me some mirrorlist errors and I don’t know if they’re related to my problem. I became garuda only a while ago and would love to stick with it. Thanks beforehand!


12Kernel 6.2.2-zen1-1-zen 12arch x86_64 12bits 64 12compiler gcc 12v 12.2.1 12clocksource tsc
12available acpi_pm 12parameters BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
misobasedir=garuda root=miso:LABEL=GARUDA_DR460NIZED_RAPTOR quiet systemd.show_status=1
ibt=off driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=1
12Console N/A 12Distro Garuda Linux 12base Arch Linux
12Type Convertible 12System LENOVO 12product 81CU 12v Lenovo YOGA 730-15IKB 12serial <filter> 12Chassis
12type 31 12v Lenovo YOGA 730-15IKB 12serial <filter>
12Mobo LENOVO 12model LNVNB161216 12v SDK0R32862 WIN 12serial <filter> 12UEFI LENOVO 12v 7KCN33WW(V1.14)
12date 12/29/2020

(upower:312): UPower-WARNING **: 21:20:10.047: Cannot connect to upowerd: Could not connect: No such file or d
12ID-1 BAT1 12charge 19.1 Wh (100.0%) 12condition 19.1/51.5 Wh (37.0%) 12volts 12.6 12min 11.4 12model 0x4C
0x47 0x43 0x00 0x31 0x PABAS0241231 12type Li-ion 12serial <filter> 12status full 12cycles 1163
12Device-1 wacom_battery_0 12model Wacom HID 516A 12serial N/A 12charge N/A 12status N/A
12Info 12model Intel Core i7-8550U 12socket BGA1356 (U3E1) 12note check 12bits 64 12type MT MCP
12arch Coffee Lake 12gen core 8 12level v3 12note check 12built 2017 12process Intel 14nm 12family 6
12model-id 0x8E (142) 12stepping 0xA (10) 12microcode 0xF0
12Topology 12cpus 1x 12cores 4 12tpc 2 12threads 8 12smt enabled 12cache 12L1 256 KiB
12desc d-4x32 KiB; i-4x32 KiB 12L2 1024 KiB 12desc 4x256 KiB 12L3 8 MiB 12desc 1x8 MiB
12Speed (MHz) 12avg 1679 12high 2000 12min/max 400/4000 12base/boost 3000/8300 12scaling
12driver intel_pstate 12governor powersave 12volts 0.9 V 12ext-clock 100 MHz 12cores 121 2000 122 2000 123
124 2000 125 700 126 2000 127 734 128 2000 12bogomips 31999
12Flags avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
12Vulnerabilities <filter>
12Device-1 Intel UHD Graphics 620 12vendor Lenovo 12driver i915 12v kernel 12arch Gen-9.5
12process Intel 14nm 12built 2016-20 12ports 12active eDP-1 12empty DP-1,HDMI-A-1,HDMI-A-2
12bus-ID 0000:00:02.0 12chip-ID 8086:5917 12class-ID 0300
12Device-2 NVIDIA GP107M [GeForce GTX 1050 Mobile] 12vendor Lenovo 12driver nvidia 12v 525.89.02
12alternate nouveau,nvidia_drm 12non-free 545.xx+ 12status current (as of 2023-10; EOL~2026-12-xx)
12arch Pascal 12code GP10x 12process TSMC 16nm 12built 2016-2021 12bus-ID 0000:3b:00.0 12chip-ID 10de:1c8d
12class-ID 0302
12Device-3 Chicony Integrated Camera 12driver uvcvideo 12type USB 12rev 2.0 12speed 480 Mb/s 12lanes 1
12mode 2.0 12bus-ID 1-5:3 12chip-ID 04f2:b61e 12class-ID 0e02 12serial <filter>
12Display 12server 12v 12with Xwayland 12v 23.2.2 12driver 12X 12loaded modesetting,nouveau
12failed nvidia 12alternate fbdev,intel,nv,vesa 12dri iris 12gpu i915 12tty 80x40
12Monitor-1 eDP-1 12model BOE Display 0x06f4 12built 2016 12res 3840x2160 12dpi 283 12gamma 1.2
12size 345x194mm (13.58x7.64") 12diag 396mm (15.6") 12ratio 16:9 12modes 3840x2160
12API EGL 12v 1.5 12hw 12drv intel iris 12platforms 12device 0 12drv iris 12device 2 12drv swrast 12gbm 12dr
v iris
12surfaceless 12drv swrast 12inactive wayland,x11,device-1
12API OpenGL 12v 4.6 12compat-v 4.5 12vendor mesa 12v 23.2.1-arch1.2 12note console (EGL sourced)
12renderer Mesa Intel UHD Graphics 620 (KBL GT2), llvmpipe (LLVM 16.0.6 256 bits)
12API Vulkan 12v 1.3.269 12layers 4 12device 0 12type integrated-gpu 12name Intel UHD Graphics 620 (KBL
GT2) 12driver mesa intel 12v 23.2.1-arch1.2 12device-ID 8086:5917 12surfaces N/A 12device 1 12type cpu
12name llvmpipe (LLVM 16.0.6 256 bits) 12driver mesa llvmpipe 12v 23.2.1-arch1.2 (LLVM 16.0.6)
12device-ID 10005:0000 12surfaces N/A
12Device-1 Intel Sunrise Point-LP HD Audio 12vendor Lenovo 12driver snd_hda_intel 12v kernel
12alternate snd_soc_skl,snd_soc_avs 12bus-ID 0000:00:1f.3 12chip-ID 8086:9d71 12class-ID 0403
12API ALSA 12v k6.2.2-zen1-1-zen 12status kernel-api 12tools N/A
12Server-1 PipeWire 12v 0.3.85 12status off 12with 121 pipewire-pulse 12status off 122 wireplumber 12status
123 pipewire-alsa 12type plugin 124 pw-jack 12type plugin 12tools pactl,pw-cat,pw-cli,wpctl
12Device-1 Intel Wireless 8265 / 8275 12driver iwlwifi 12v kernel 12bus-ID 0000:3a:00.0 12chip-ID 8086:24fd
12class-ID 0280
12IF wlp58s0 12state down 12mac <filter>
12Device-1 Intel Bluetooth wireless interface 12driver btusb 12v 0.8 12type USB 12rev 2.0 12speed 12 Mb/s
12lanes 1 12mode 1.1 12bus-ID 1-7:5 12chip-ID 8087:0a2b 12class-ID e001
12Report btmgmt 12ID hci0 12rfk-id 2 12state down 12bt-service N/A 12rfk-block 12hardware no 12software no
12address N/A
12Hardware-1 Intel 82801 Mobile SATA Controller [RAID mode] 12driver intel_nvme_remap 12v N/A 12port 4060
12bus-ID 0000:00:17.0 12chip-ID 8086:282a 12rev N/A 12class-ID 0104
12Local Storage 12total 484.16 GiB 12used 12.45 GiB (2.6%)
12ID-1 /dev/nvme0n1 12maj-min 259:0 12vendor Samsung 12model MZVLB512HAJQ-000L2 12size 476.94 GiB
12block-size 12physical 512 B 12logical 512 B 12tech SSD 12serial <filter> 12fw-rev 5L1QEXA7 12temp 28.9 C
12SMART yes 12health PASSED 12on 340d 3h 12cycles 5,576 12read-units 45,345,340 [23.2 TB]
12written-units 41,248,807 [21.1 TB]
12ID-2 /dev/sda 12maj-min 8:0 12vendor Kingston 12model DataTraveler 3.0 12size 7.22 GiB 12block-size
12physical 512 B 12logical 512 B 12type USB 12rev 3.0 12spd 5 Gb/s 12lanes 1 12mode 3.2 gen-1x1 12tech N/A
12serial <filter> 12fw-rev PMAP
12SMART Message Unknown USB bridge. Flash drive/Unsupported enclosure?
12ID-1 / 12raw-size 476.64 GiB 12size 476.64 GiB (100.00%) 12used 12.45 GiB (2.6%) 12fs btrfs
12block-size 4096 B 12dev /dev/nvme0n1p2 12maj-min 259:2
12ID-2 /boot/efi 12raw-size 300 MiB 12size 299.4 MiB (99.80%) 12used 576 KiB (0.2%) 12fs vfat
12block-size 512 B 12dev /dev/nvme0n1p1 12maj-min 259:1
12ID-3 /home 12raw-size 476.64 GiB 12size 476.64 GiB (100.00%) 12used 12.45 GiB (2.6%) 12fs btrfs
12block-size 4096 B 12dev /dev/nvme0n1p2 12maj-min 259:2
12ID-4 /var/log 12raw-size 476.64 GiB 12size 476.64 GiB (100.00%) 12used 12.45 GiB (2.6%) 12fs btrfs
12block-size 4096 B 12dev /dev/nvme0n1p2 12maj-min 259:2
12ID-5 /var/tmp 12raw-size 476.64 GiB 12size 476.64 GiB (100.00%) 12used 12.45 GiB (2.6%) 12fs btrfs
12block-size 4096 B 12dev /dev/nvme0n1p2 12maj-min 259:2
12Kernel 12swappiness 133 (default 60) 12cache-pressure 100 (default) 12zswap no
12ID-1 swap-1 12type zram 12size 15.35 GiB 12used 0 KiB (0.0%) 12priority 100 12comp zstd
12avail lzo,lzo-rle,lz4,lz4hc,842 12max-streams 8 12dev /dev/zram0
12System Temperatures 12cpu 40.0 C 12pch 36.5 C 12mobo N/A
12Fan Speeds (rpm) N/A
12Processes 0 12Uptime 9m 12wakeups 0 12Memory 12total 16 GiB 12available 15.35 GiB 12used 4.13 GiB (26.9%)
12igpu 64 MiB 12Init systemd 12v 254 12default graphical 12tool systemctl 12Compilers 12gcc 13.2.1 12Package
12pm pacman 12pkgs 1262 12libs 365 12tools octopi,paru 12Client 12inxi 3.3.31
Garuda (2.6.19-2):
System install date:     2023-11-18
Last full system update: 2023-11-18
Is partially upgraded:   No
Relevant software:       snapper NetworkManager connman dracut nvidia-dkms
Windows dual boot:       No/Undetected
Running in chroot, ignoring command 'list-units'
Failed units:

Try last working snapshot.

Or install new with free driver. Check forum for dual GPU, I have no clue about.

Change this to AHCI mode in your BIOS.


Holy that fixed it! Thank you a lot! Would you mind telling me why that caused a problem?

1 Like

Unfortunately, I can’t tell you exactly.
I’ve always read about that prerequisite in Linux, but I’ve always had the feeling that in the past, from a certain point on, it worked even with raid mode (just because I didn’t see any issue about it in the forum…).
If so, it could be a kernel regression.
If not, maybe a BIOS (or Windows…) update brought back raid mode?
A quick internet search confirms that Intel raid is a technology not supported by Linux. If you search and read, there should be technical documentation about it (as opposed to quick statements in forums, reddits, etc.).


Got it! Thank you again!!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.