Stuck in Grub rescue

I use garuda dragonized version, when i shut down my system it didn't shut down, so i switched off the power button and after sometime i turned it on, it says:
error:unknown file system
Entering rescue mode...
Grub rescue>

I tried:
ls with each partition but all of them shows unknown file system.

I tried live USB boot to atleast copy my data from the hard drive, but it is not showing up in the file manager.
Please help...

Hi there, welcome.
Sounds wierd, I hope you have a backup strategy in place...
The bad sign is that you don't see your drives from the live USB.
Normally I'd suggest:

  • try to restore a working snapshot from the live USB
  • try a sudo btrfs check from the live USB

But you have few chances, given the above.
Just in case, give a look also at the BIOS, in case something was reset due to that forced power off: fast boot off, secure boot off, SATA mode AHCI, etc.

Good luck!


How can i restore the snapshot, can you please help..
It is not showing the snapshots list..
Can you give me the steps please, i have my college documents and reports, anyhow i have to get those Atleast.
Please help...

If, booting from the live USB, the Garuda Assistant doesn't show any snapshots in the Snapper tab you're out of luck.

There is a high change your partitions got messed up, As filo said. We are sorry.

Sometimes system processes have to be completed before the shutdown, which can take up to 3 minutes.
If the splashscreen is visible, you can press ESC or "Arrow down" to observe the countdown.
As soon as the PC is shut down "forcibly", there is a risk of destroying the system.
If you have not made any backups, you can try to restore your files with "Testdisk" or other programs.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.