Stuck At 79% (configuring the Hardware)

Hi guys today i am install a arch base linux firts time and all the installation setps went well but

installation stuck at 79% configuring the Hardware

Now what to do?

Could you please provide you garuda-inxi from the live USB?
We will also need some usual additional info:
Did you verify the checksum of the iso (although this is unlikely the problem)?
What tool did you use to flash it? I've just seen your other post. Have you tried different tools?
Did you use the proprietary drivers or open source dirvers option at boot? Have you tried the other?


I used ventoy but now i force shutdown my laptop
I wil try it later

In ventoy no boot screen (option for proprietary or open source) shown

If you copy the iso file into the Ventoy USB, you should first see a menu listing the iso's on that USB.
When you select the one you want to use, then it should show you a "normal" GRUB screen with those mentioned options.

1 Like

I done that but not shown the boot screen!!

I also tried browse option to get iso from other partition

First of all, I'd make sure that secure boot and fast boot are disabled in the BIOS.
I'd also try in both UEFI mode and Legacy mode.
Also make sure the USB is the first option in the boot order list or try with Fx (depending on the system) to get to the boot manager, and then select the USB.
Quite frankly Ventoy has always been working fine for me in several machines, so I don't have further suggestions...


I have kaliLinux and windows 11 also that can creates a problem??

How long you wait?
Maybe mhwd need some time,
or M$ "blocks" hardware use for other OS?

Last time.
The template ask about like filo, please answer the questions.
Poking around in the dark frustrates those who want to help.
Also post

lsblk -f

all terminal outputs as text.


Where to type ,in terminal??

Yes, then copy and paste the output here, formatted like this:
pasted text

  Kernel: 5.18.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=garuda misolabel=GARUDA_GNOME_TALON quiet
    systemd.show_status=1 driver=nonfree nouveau.modeset=0 i915.modeset=1
  Desktop: GNOME v: 42.2 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM v: 42.0
    Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: Hewlett-Packard product: HP ProBook 450 G2
    v: A3009DD10303 serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: Hewlett-Packard model: 2248 v: KBC Version 67.24
    serial: <superuser required> UEFI: Hewlett-Packard v: M74 Ver. 01.09
    date: 01/26/2015
  ID-1: BAT0 charge: 34.9 Wh (100.0%) condition: 34.9/34.9 Wh (100.0%)
    volts: 16.8 min: 14.8 model: Hewlett-Packard Primary type: Li-ion
    serial: <filter> status: full
  Info: model: Intel Core i5-4210U bits: 64 type: MT MCP arch: Haswell
    gen: core 4 built: 2013-15 process: Intel 22nm family: 6
    model-id: 0x45 (69) stepping: 1 microcode: 0x1C
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1406 high: 1697 min/max: 800/2700 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1050 2: 1697 3: 1183
    4: 1696 bogomips: 19155
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode;
    SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling
  Type: srbds status: Vulnerable: No microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen7.5 process: Intel 22nm built: 2013 ports:
    active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:0a16 class-ID: 0300
  Device-2: Cheng Uei Precision Industry (Foxlink) HP EliteBook integrated
    HD Webcam
    type: USB driver: uvcvideo bus-ID: 2-7:4 chip-ID: 05c8:0374
    class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
    compositor: gnome-shell driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: eDP-1 model: LG Display 0x0465 built: 2014 res: 1366x768
    hz: 60 dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: 1366x768
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel Haswell-ULT HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:0a0c
    class-ID: 0403
  Device-2: Intel 8 Series HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9c20
    class-ID: 0403
  Sound Server-1: ALSA v: k5.18.3-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 16.0 running: no
  Sound Server-3: PipeWire v: 0.3.52 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 08:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp8s0 state: down mac: <filter>
  Device-2: Qualcomm Atheros AR9462 Wireless Network Adapter
    vendor: AzureWave driver: ath9k v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 09:00.0 chip-ID: 168c:0034 class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-1: IMC Networks type: USB driver: btusb v: 0.8 bus-ID: 2-4:6
    chip-ID: 13d3:3393 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: no
    address: <filter>
  Local Storage: total: 480.41 GiB used: 0 KiB (0.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD5000LPCX-16VHAT1 size: 465.76 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
    rev: 1A02 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Kingston
    model: DataTraveler 2.0 size: 14.65 GiB block-size: physical: 512 B
    logical: 512 B type: N/A serial: <filter> rev: PMAP scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No partition data found.
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 3.7 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 50.0 C pch: 48.0 C mobo: 0.0 C
  Fan Speeds (RPM): N/A
  Processes: 192 Uptime: 2m wakeups: 1 Memory: 3.7 GiB used: 1.27 GiB (34.2%)
  Init: systemd v: 251 default: graphical tool: systemctl Compilers:
  gcc: 12.1.0 Packages: pacman: 1136 lib: 313 Shell: fish v: 3.4.1
  default: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.17
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
warning: database file for 'chaotic-aur' does not exist (use '-Sy' to download)
Garuda (2.6.3-2):
  System install date:     2022-07-06
  Last full system update: 2022-07-06 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       <superuser required>
  Snapshots:               Snapper
  Failed units:            

Btw how can i boot other linux from grub rescue / grub

NAME    FSTYPE FSVER LABEL           UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0   squash 4.0                                                              0   100% /run/miso/sfs/livefs
loop1   squash 4.0                                                              0   100% /run/miso/sfs/mhwdfs
loop2   squash 4.0                                                              0   100% /run/miso/sfs/desktopfs
loop3   squash 4.0                                                              0   100% /run/miso/sfs/rootfs
├─sda1  btrfs                        ae673ac6-880c-4393-acca-c7cccee594bf                
├─sda2  ext4   1.0                   2d05a0f6-5863-47ac-a248-edf9fc3de8ee                
├─sda3  vfat   FAT32 NO_LABEL        5A0C-0396                                           
├─sda4  btrfs                        095dc4c7-ca0d-4fb9-a0df-ca7a8e6241bd                
├─sda5  ntfs                         CEA8AE85A8AE6C21                                    
├─sda6  swap   1                     be610a09-ce79-4237-8edf-95d2199f2315                
└─sda8  vfat   FAT32 boot_repar      CE17-8BFE                                           
├─sdb1  exfat  1.0   Ventoy          5AB1-5808                                           
│ └─ventoy
│       iso966 Jolie GARUDA_GNOME_TALON
│                                    2022-06-14-01-15-44-00                     0   100% /run/miso/bootmnt
└─sdb2  vfat   FAT16 VTOYEFI         61DA-42EA                                           
zram0                                                                                    [SWAP]
McFly: Importing shell history for the first time. This may take a minute or two...done.

The only problem I can see in the specs is here:

The minimum suggested memory is 4GB.
I don't know if the hardware detection is a step/process which requires RAM, so it will either require a lot of time or will even stuck.
Anyway, meanwhile someone confirms this, I think you could continue with the BIOS verifications mentioned above.

1 Like

I already have 4gb ram

A part is dedicated to the graphic card.
The one shown in the inxi should be the available RAM.

1 Like

Okk so lets startt from scratch

But i want boot in my kali for downloading iso from garuda downloader

how can i boot now i have no grub
How can I boot my os from grub rescue or grub cli

This is not related to the live USB. The installation has not completed so I don't think the GRUB was installed by Garuda.
This could be something you changed in the BIOS. Boot order? Have you removed the USB?
In addition to that, you could use efibootmgr from the live USB to check boot order and change it.

1 Like


Booted into kali now i am downloading iso from garuda downloader

I have one question , sould pendrive plugged in while download