Struggling to install Houdini

trying to install houdini on arch garuda linux, and something is very broken.
my proccess(following How do I install Houdini on Linux? | SideFX this guide:

  • download “legacy installer”, extract/
  • sudo ./houdini.install, install 1-5,10
  • cd /opt/hfs20.0, source houdini_setup using bash
  • houdinithrows http:djkato-work:1715: No server running.
  • sudo systemctl start sesinetd, get error Failed to start sesinetd.service: Unit sesinetd.service not found.
  • try to install the service by doing sudo ln -s /opt/hfs20.0/houdini/sbin/sesinetd.service /usr/lib/systemd/system/, sudo systemctl enable sesinetd.service, sudo systemctl start sesinetd.service. Shows no errors but running houdini I still get the same issue.
  • looking at the service file, it’s pointing to some usr/lib directory in ExecStart, so I modified it to point at ExecStart=/opt/hfs20.0/houdini/sbin/sesinetd -D, run service again but same issue.
  • run /opt/hfs20.0/houdini/sbin/sesinetd -D directly, get error id: ‘www-data’: no such user and id: ‘sesinetd’: no such user.
    -give up.

I’m honestly at a loss. I did try if the launcher helps, but there docs for linux are incomplete, and it would install it probably wrong anyways.

any help appreciated.

sesictrl diagnostic:

[code bash]
╭─djkato@djkato in /opt/hfs20.0.506🔒 via  v3.11.5 took 1s
╰─λ sesictrl diagnostic
[http://djkato-work:1715](http://djkato-work:1715/): No server found running. Please start the server before retrying.
[http://djkato-work:1715](http://djkato-work:1715/): No server found running. Please start the server before retrying.
Diagnostic Output:

If you are having licensing problems, please save this information and email it
to [[email protected]](mailto:[email protected]).

### License Administrator output:

Generated on:                           Fri Nov 10 23:48:44 2023
Local host name:                        djkato-work
Local server code:                      b243a808
Local ip address:             
System:                                 Garuda Linux (linux-x86_64-gcc11.2)
Number of servers:                      1
License server name:                    [http://djkato-work:1715](http://djkato-work:1715/) (djkato-work)
Server ip address:                   (could not look up server)
Reported host name:                  (unknown)
Reported host ip address:            (unknown)
License server is running:           No
License Administrator version:          20.0.506
Http NoProxy:                           localhost,
Http Proxy:                               (none)
Can retrieve Yes
Using API Keys:                         No
Can Manage Licenses:                    No
Login Based Account:                    No
Logged In:                              No
Scrub User Names:                       No
Available Entitlements:
No entitlements found. This can be caused by hkey not
updating its entitlements since they have been available.

Installed licenses:
LicID    Platform   Product                        Ver Avail Expiry


### sesictrl print-license output:

- ---- SERVER [http://djkato-work:1715](http://djkato-work:1715/) --------
WARNING: host '[http://djkato-work:1715](http://djkato-work:1715/)' does not have a valid SERVER license.

### hserver -l output:

Hostname:       djkato-work     [Garuda Linux]
Uptime:         0:36:26 [Started: Fri Nov 10 23:12:20 2023]
License Server: [http://djkato-work:1715](http://djkato-work:1715/)
Connected To:   [http://djkato-work:1715](http://djkato-work:1715/)
Server Version: <unknown>
Version:        Houdini20.0.506
ReadAccess (Ipv4):
WriteAccess (Ipv4):
ReadAccess (Ipv6):
WriteAccess (Ipv6):
Using Http: Yes
Enabled IPv6: false
Used Licenses: None

6,864 of 31,234 MB available
CPU Usage:0% load
0 active tasks (16 slots)

### HTTP(s) Backend Info:

library:                     libcurl/7.79.1 (x86_64-pc-linux-gnu)
SSL Version:                 OpenSSL/1.1.1i
Features:                    AsyncDNS HTTPS-proxy IPv6

### licenses file:


- Could not open the licenses file. *


  Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=b8196f39-e08b-4bce-b75d-343098561547 rw rootflags=subvol=@
    quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=9bac1011-b1fa-4c26-85c0-a8dacd8e1df1 loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 info: docker wm: kwin_x11
    vt: 2 dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: PRIME B650-PLUS v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 1636
    date: 07/28/2023
  Info: model: AMD Ryzen 7 7700X bits: 64 type: MT MCP arch: Zen 4 gen: 5
    level: v4 note: check built: 2022+ process: TSMC n5 (5nm) family: 0x19 (25)
    model-id: 0x61 (97) stepping: 2 microcode: 0xA601203
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 8 MiB desc: 8x1024 KiB
    L3: 32 MiB desc: 1x32 MiB
  Speed (MHz): avg: 2585 high: 4799 min/max: 400/5573 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 4131 2: 4507 3: 400
    4: 400 5: 4785 6: 4790 7: 3538 8: 400 9: 400 10: 400 11: 3831 12: 400
    13: 400 14: 4120 15: 4799 16: 4068 bogomips: 143994
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
    driver: amdgpu v: kernel arch: RDNA-1 code: Navi-1x process: TSMC n7 (7nm)
    built: 2019-20 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
    active: DP-3,HDMI-A-1 empty: DP-1,DP-2 bus-ID: 03:00.0 chip-ID: 1002:731f
    class-ID: 0300
  Device-2: AMD Raphael vendor: ASUSTeK driver: amdgpu v: kernel
    arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie:
    gen: 4 speed: 16 GT/s lanes: 16 ports: active: none empty: DP-4,HDMI-A-2
    bus-ID: 0e:00.0 chip-ID: 1002:164e class-ID: 0300 temp: 46.0 C
  Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1185x381mm (46.65x15.00")
    s-diag: 1245mm (49.01")
  Monitor-1: DP-3 mapped: DisplayPort-2 pos: primary,top-left
    model: AOC Q3279WG5B serial: <filter> built: 2017 res: 2560x1440 dpi: 90
    gamma: 1.2 size: 725x428mm (28.54x16.85") diag: 842mm (33.1") ratio: 15:9
    modes: max: 2560x1440 min: 720x400
  Monitor-2: HDMI-A-1 mapped: HDMI-A-0 pos: bottom-r model: BenQ GW2470
    serial: <filter> built: 2016 res: 1920x1080 hz: 60 dpi: 93 gamma: 1.2
    size: 527x296mm (20.75x11.65") diag: 604mm (23.8") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: radeonsi device: 2 drv: swrast gbm: drv: kms_swrast
    surfaceless: drv: radeonsi x11: drv: radeonsi inactive: wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.2.1-arch1.2
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 5700 XT (navi10 LLVM
    16.0.6 DRM 3.54 6.5.9-zen2-1-zen) device-ID: 1002:731f memory: 7.81 GiB
    unified: no
  API: Vulkan v: 1.3.269 layers: 9 device: 0 type: discrete-gpu name: AMD
    Radeon RX 5700 XT (RADV NAVI10) driver: mesa radv v: 23.2.1-arch1.2
    device-ID: 1002:731f surfaces: xcb,xlib device: 1 type: discrete-gpu
    name: AMD Radeon RX 5700 XT driver: amd v: (AMD proprietary shader
    compiler) device-ID: 1002:731f surfaces: xcb,xlib device: 2
    type: integrated-gpu name: AMD Radeon Graphics (RADV RAPHAEL_MENDOCINO)
    driver: mesa radv v: 23.2.1-arch1.2 device-ID: 1002:164e
    surfaces: xcb,xlib device: 3 type: integrated-gpu
    name: AMD Radeon Graphics driver: amd v: (AMD proprietary shader compiler)
    device-ID: 1002:164e surfaces: xcb,xlib device: 4 type: cpu name: llvmpipe
    (LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
    16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
  Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab38
    class-ID: 0403
  Device-2: AMD Rembrandt Radeon High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0e:00.1 chip-ID: 1002:1640 class-ID: 0403
  Device-3: AMD Family 17h/19h HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0e:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Device-4: Native Instruments Komplete Audio 2 driver: snd-usb-audio
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-3:2
    chip-ID: 17cc:1840 class-ID: fe01 serial: <filter>
  API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 0.3.84 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 0a:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
    v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-6:4
    chip-ID: 0a12:0001 class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.0
    lmp-v: 6 status: discoverable: no pairing: no class-ID: 7c0104
  Local Storage: total: 1.82 TiB used: 1.06 TiB (58.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT2000P5PSSD8
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: P7CR403 temp: 48.9 C
    scheme: GPT
  ID-1: / raw-size: 1.79 TiB size: 1.79 TiB (100.00%) used: 1.06 TiB (59.2%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 1.79 TiB size: 1.79 TiB (100.00%)
    used: 1.06 TiB (59.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 1.79 TiB size: 1.79 TiB (100.00%)
    used: 1.06 TiB (59.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 1.79 TiB size: 1.79 TiB (100.00%)
    used: 1.06 TiB (59.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 30.5 GiB used: 18.8 MiB (0.1%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 33.55 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  System Temperatures: cpu: 49.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  GPU: device: amdgpu temp: 46.0 C device: amdgpu temp: 50.0 C mem: 62.0 C
    fan: 1257 watts: 47.00
  Processes: 431 Uptime: 1h 51m wakeups: 0 Memory: total: 32 GiB note: est.
  available: 30.5 GiB used: 11.83 GiB (38.8%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: 1861 pm: pacman pkgs: 1856 libs: 488 tools: octopi,paru,yay
  pm: pkg pkgs: 0 pm: flatpak pkgs: 5 Shell: fish v: 3.6.1 default: Bash
  v: 5.2.15 running-in: konsole inxi: 3.3.31
Garuda (2.6.17-1):
  System install date:     2023-08-17
  Last full system update: 2023-11-08
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:            sesinetd.service 

It would make more sense to get help from the developer. A closed-source bit of pay software is not in the bailiwick of the OS.


And they would probably tell you that Arch (and Arch based distros) is not supported.
Maybe your best chance is that this thread is continued.
An Arch SideFX developer seems interested in creating an AUR package…


I’m not going to lie, I had to look that up. :nerd_face: Nice one!


Bailiwick, i.e. “in your jurisdiction” etc, is a common American and British saying with slightly different meanings, at least among those who would use it specifically. I’m from Western-by-God Kansas, Dodge City, originally, and it was common terminology among adults, usually professionals and business people. More common nowaday usage, at least in the U.S., would be, “the ball is in your court.”

I suspect @Catra may perhaps be more than they appear. But in a nice way. :smiley:

Our language, words, definitions, usage–they are devolving. As educational standards set to the least common denominator become more and more the gold-standard, the more we, society, devolve to the point where, “Ugh, me Bro” is about as erudite as erudite gets.

This does not thrill me. All of my professional life my work required extensive investigation and documentation and much of the verbiage had to be (legally) precise. Millions of dollars may have been at stake. I might be called to court to testify as to my findings, as I have many times. Or hired directly by the court to provide guidance. I might be sued by one or more parties. Or worse, lose my license to practice my profession.

Words matter to me as they should matter to everyone else regardless of age or culture. It is communication.


Are you suggesting that I am a Transformer? :crazy_face:

1 Like

You said it, not me. :rofl:


That is exactly what they replied to me via support.

Side Effects Support


Garuda linux is not supported.
System Requirements | SideFX


makes me sad, I really don’t wanna use a debian based OS.
I googled around a lot and found that thread too, but I’m not getting my hopes up.

I got told that garuda ain’t supported. Wish they at least gave me a hint of what could’ve broken, but alas. They seem to like linux, so I don’t get why there isn’t an aur entry, or (idk if possible) a flatpack\deb package instead of relying on random build shell scripts. Their work is phenomenal, but blender does it just fine

I would assume there must be some kind of way because I found this plugin on AUR: AUR (en) - renderman-for-houdini

No AUR package for just plain Houdini from what I can see though.


Render engines are usually servers - so separate programs with glue between I think. I don’t think this suggests anything, but I fully agree there must be a way. I just don’t know enough about linux to do that job myself :c

lead from another forum post before it got deleted:

Houdini doesn’t use systemd to store the sesinetd file, it uses init.d so before installing houdini you need to create the init.d file in /etc/ where it will store the sesinetd file, then you can start the file but remember, it won’t run as a service, you need to start sesinetd everytime you turn on your system

In that case how about trying distro box? I haven’t quite tried it myself but your situation fits the use case this software is designed for.



It’s an AUR “script to convert .deb packages to Arch Linux packages, focused on accuracy. Do not use it to convert packages that already exist on official repositories or can be built from AUR”

I’m in-process of using it converting a High-def Debian Intel A/V driver & dependencies. Others have also used it. It works, but do your homework. :smiley:


They don’t distribute it as debs as I said, it’s a zip and inside it a random bunch of shell scipts and bin folders :confused:

Most definitely sounds like they should provide support. :frowning:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.