Strange usb error while booting

Hi there, recently I’m experiencing a strange (not fatal) error during boot.
After saying it’s loading linux-zen, a couple of light blue lines appear:

NVRM: loading NVIDIA UNIX etc etc...
TC 2023
usb 3.-2.4: can't set config #1, error -28

The system boots, but what gives? I tried waiting for updates, but it’s been a couple of weeks and it’s not fixed.
Btw, as usual for me ^^, it freezes for a minute instead of going to sleep if try to sleep the system, but I think it’s the same old problem I already try - and failed - to solve with your kind help. :slight_smile:
Oh, and I noticed at the same time the option to hybernate disappeared: since it never worked maybe I could just delete the swap partition? But I guess it’s a separate issue. :wink:

Here’s the inxi:

Kernel: 6.6.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=1930b164-e875-487b-9e15-d08dfb606021 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
ibt=off resume=UUID=290da5e7-6510-4b46-9fa1-14463cba09cf
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: ASRock model: P67 Extreme4 serial: <superuser required>
BIOS: American Megatrends v: P3.10 date: 04/24/2012
Device-1: hidpp_battery_0 model: Logitech G604 Wireless Gaming Mouse
serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: discharging
Info: model: Intel Core i5-2500K bits: 64 type: MCP arch: Sandy Bridge
gen: core 2 level: v2 built: 2010-12 process: Intel 32nm family: 6
model-id: 0x2A (42) stepping: 7 microcode: 0x2F
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 1596 high: 1600 min/max: 1600/3700 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 1595 2: 1600 3: 1596
4: 1596 bogomips: 26340
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: ZOTAC driver: nvidia
v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current
(as of 2023-10; EOL~2026-12-xx) arch: Maxwell code: GMxxx
process: TSMC 28nm built: 2014-2019 pcie: gen: 2 speed: 5 GT/s lanes: 16
ports: active: none off: DP-1,DVI-I-1 empty: DVI-D-1,HDMI-A-1
bus-ID: 01:00.0 chip-ID: 10de:13c2 class-ID: 0300
Display: x11 server: X.Org v: 21.1.10 with: Xwayland v: 23.2.3
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia,nvidia-nvswitch
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 97 s-size: 503x283mm (19.80x11.14")
s-diag: 577mm (22.72")
Monitor-1: DP-1 note: disabled model: Panasonic Panasonic-TV
serial: <filter> built: 2010 res: 1920x1080 dpi: 70 gamma: 1.2
size: 698x392mm (27.48x15.43") modes: max: 1920x1080 min: 640x480
Monitor-2: DVI-I-1 note: disabled pos: primary model: LG (GoldStar) W2363D
serial: <filter> built: 2011 res: 1920x1080 dpi: 96 gamma: 1.2
size: 510x287mm (20.08x11.3") diag: 582mm (22.9") ratio: 16:9 modes:
max: 1920x1080 min: 640x480
API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia x11: drv: nvidia
inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce GTX 970/PCIe/SSE2
memory: 3.91 GiB
API: Vulkan v: 1.3.269 layers: 5 device: 0 type: discrete-gpu
name: NVIDIA GeForce GTX 970 driver: nvidia v: 545.29.06
device-ID: 10de:13c2 surfaces: xcb,xlib
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
vendor: ASRock 6 driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:1c20 class-ID: 0403
Device-2: NVIDIA GM204 High Definition Audio vendor: ZOTAC
driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:0fbb class-ID: 0403
Device-3: Logitech G430 Surround Sound Gaming Headset
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 2-1.2:4 chip-ID: 046d:0a4d class-ID: 0300
Device-4: M-Audio AIR 192 6 driver: snd-usb-audio type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-2.3:3 chip-ID: 0763:410c
class-ID: fe01
API: ALSA v: k6.6.7-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASRock driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
port: b000 bus-ID: 0c:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp12s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-1.6:4
chip-ID: 0a12:0001 class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.0
lmp-v: 6 status: discoverable: no pairing: no class-ID: 7c0104
Local Storage: total: 2.85 TiB used: 610.59 GiB (21.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 3B6Q scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST2000DX001-1NS164
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: CC41 scheme: MBR
ID-3: /dev/sdc maj-min: 8:32 vendor: Crucial model: M4-CT128M4SSD2
size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 070H scheme: MBR
ID-1: / raw-size: 50 GiB size: 46.57 GiB (93.13%) used: 31.55 GiB (67.8%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /home raw-size: 414.91 GiB size: 414.91 GiB (100.00%)
used: 155.64 GiB (37.5%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-3: /var/log raw-size: 50 GiB size: 46.57 GiB (93.13%)
used: 31.55 GiB (67.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/tmp raw-size: 50 GiB size: 46.57 GiB (93.13%)
used: 31.55 GiB (67.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.58 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
ID-2: swap-2 type: partition size: 16.6 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda4 maj-min: 8:4
System Temperatures: cpu: 33.0 C mobo: N/A gpu: nvidia temp: 37 C
Fan Speeds (rpm): N/A gpu: nvidia fan: 31%
Processes: 262 Uptime: 7m wakeups: 0 Memory: total: 16 GiB
available: 15.58 GiB used: 4.63 GiB (29.7%) Init: systemd v: 255
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: pm: pacman pkgs: 1471 libs: 475 tools: octopi,paru Shell: fish
v: 3.6.4 default: Bash v: 5.2.21 running-in: konsole inxi: 3.3.31
Garuda (2.6.21-1):
System install date:     2023-10-26
Last full system update: 2023-12-16
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       <superuser required>
Failed units:


Do you use gadgetfs by any chance?

Hey there, ehm… I don’t even know what gadgetfs is, frankly. :slight_smile:
In the meantime I tried rebooting with LTS kernel and the error remains.

please share the output of cat /var/log/Xorg.0.log | grep "(EE)"
and try updating your system using sudo garuda-update it may be fixed with new update .

1 Like

usb 3.-2.4: can’t set config #1, error -28

Are you perhaps running a USB hub connected to your computer? If so, disconnect it and then reboot and see if the error is still present.


Here it is:

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    11.994] (EE) Failed to load module "nouveau" (module does not exist, 0)
[    11.994] (EE) Failed to load module "nv" (module does not exist, 0)
[    11.996] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    11.997] (EE) Failed to load module "vesa" (module does not exist, 0)
[    12.018] (EE) open /dev/dri/card0: No such file or directory

And, @tbg: I do have an USB hub, restarting without it gets rid of the error (but I still have the cyan “NVRM: loading NVIDIA UNIX etc etc…” that I didn’t have before), but gets rid of my bluetooth dongle and other things as well… :-/

The “nouveau” drivers are loading and failing, Given that you’re using the proprietary NVIDIA drivers you don’t need them any more , so run sudo rm /etc/X11/xorg.conf.d/*nouveau*
then → sudo nvidia-xconfig sudo systemctl restart display-manager
after rebooting after this process, share cat /var/log/Xorg.0.log | grep "(EE)" ,

edit : that has nothing to do with the issue but it can prevent issues in the future, if its not a problem just dont touch it ,sorry for the unrelated response .

1 Like

Perhaps you should search the message that you posted regarding your USB error. You should be able to locate information about that error. I think it means that one of your USB devices is not capable of attaining the fastest USB 3 speed for some reason. That could be because of a kernel regression or a change in firmware that had a negative impact.

I would definitely test some more kernel versions, and make sure your bios is up to date as well. You could also try downgrading the linix-firmware package if it was updated at the same time this issue began.


as @tbg said, Try disconnecting all unnecessary USB devices and see if the error persists. Also, try different USB ports to identify if it’s specific to one port.

1 Like

Thanks @Straight and @tbg, I’ll do some more searches. Finger crossed!

Found this on my search that contains also other links.
Looks like it is related to hub/controller not having enough bandwidth for a device. Seems these kind of errors have been kicking around for some time by looking at some bug trackers.
For now, I would just be sure you can do all you can on your side to make sure your USB devices can work the best they can by not loading up too many high bandwidth devices on a USB hub or controller.

(I would normally also recommend a BIOS update if it was applicable, but it looks like that motherboard’s only other version is a beta version. It only states “Improve memory compatibility” so I don’t think it would be helpful… and I would only recommend beta BIOS if something critical isn’t working right)


Thank you @Kayo! Yeah, my mobo is very, very old and I think years ago I installted the latest BIOS to solve a RAM problem. Always a very risky proposition, updating BIOS, even when it’s necessary…

1 Like

You are welcome. Hopefully there isn’t any big noticeable issues to this error for you. This error seems to vary in its degree of severity.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.