Strange issue. When installing program with terminal it changes my audio device to "loopback"

This is a fresh install of Garuda and I’m just setting things up. For some reason when I install a program from the terminal it switches my audio device from “speaker” to “analog Loopback” very strange thing.
I would appreciate any suggestions. Thanks!

System:
Kernel: 6.9.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c95f89af-9619-4b85-8bfb-c28ea9f14de9 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.1.0 tk: Qt v: N/A info: frameworks v: 6.3.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Convertible System: ASUSTeK product: Zenbook UP6502ZD_Q539ZD v: 1.0
serial: <superuser required>
Mobo: ASUSTeK model: UP6502ZD v: 1.0 serial: <superuser required>
uuid: <superuser required> UEFI: American Megatrends LLC. v: UP6502ZD.312
date: 11/28/2023
Battery:
ID-1: BAT0 charge: 64.7 Wh (100.0%) condition: 64.7/96.0 Wh (67.4%)
volts: 12.9 min: 11.7 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
status: full cycles: 64
Device-1: hid-0018:04F3:2F09.0001-battery model: ELAN9008:00 04F3:2F09
serial: N/A charge: N/A status: N/A
CPU:
Info: model: 12th Gen Intel Core i7-12700H bits: 64 type: MST AMCP
arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
microcode: 0x433
Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 1724 high: 4611 min/max: 400/4600:4700:3500 scaling:
driver: intel_pstate governor: performance cores: 1: 400 2: 601 3: 400
4: 400 5: 4133 6: 400 7: 4611 8: 1114 9: 2801 10: 400 11: 2500 12: 400
13: 3372 14: 3500 15: 3502 16: 3500 17: 400 18: 1251 19: 400 20: 400
bogomips: 107520
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel Alder Lake-P GT2 [Iris Xe Graphics] vendor: ASUSTeK
driver: i915 v: kernel alternate: xe arch: Gen-12.2 process: Intel 10nm
built: 2021-22+ ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2
bus-ID: 0000:00:02.0 chip-ID: 8086:46a6 class-ID: 0300
Device-2: Intel DG2 [Arc A370M] vendor: ASUSTeK driver: i915 v: kernel
alternate: xe arch: Gen-12.7 code: Alchemist process: TSMC n6 (7nm)
built: 2022+ bus-ID: 0000:04:00.0 chip-ID: 8086:5693 class-ID: 0380
Device-3: IMC Networks USB2.0 HD UVC WebCam driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-9:4 chip-ID: 13d3:5497
class-ID: fe01 serial: <filter>
Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_wayland driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915,i915 display-ID: 0
Monitor-1: eDP-1 res: 1646x926 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
device: 1 drv: iris device: 2 drv: swrast gbm: drv: iris surfaceless:
drv: iris wayland: drv: iris x11: drv: iris
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.1.2-arch1.1
glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (ADL GT2)
device-ID: 8086:46a6 memory: 7.47 GiB unified: yes display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 9 device: 0 type: integrated-gpu name: Intel
Graphics (ADL GT2) driver: mesa intel v: 24.1.2-arch1.1
device-ID: 8086:46a6 surfaces: xcb,xlib,wayland device: 1
type: discrete-gpu name: Intel Arc A370M Graphics (DG2) driver: mesa intel
v: 24.1.2-arch1.1 device-ID: 8086:5693 surfaces: xcb,xlib,wayland
device: 2 type: cpu name: llvmpipe (LLVM 17.0.6 256 bits)
driver: mesa llvmpipe v: 24.1.2-arch1.1 (LLVM 17.0.6)
device-ID: 10005:0000 surfaces: xcb,xlib,wayland
Audio:
Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: ASUSTeK
driver: sof-audio-pci-intel-tgl alternate: snd_hda_intel, snd_soc_avs,
snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3 chip-ID: 8086:51c8
class-ID: 0401
API: ALSA v: k6.9.6-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: alsactl,alsamixer,amixer
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 0000:00:14.3 chip-ID: 8086:51f0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8153 Gigabit Ethernet Adapter driver: r8152 type: USB
rev: 3.0 speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 2-2.2:5
chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>
IF: enp0s13f0u2u2 state: down mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Bluetooth:
Device-1: Intel AX211 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:6 chip-ID: 8087:0033
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 5.3
lmp-v: 12 status: discoverable: no pairing: no class-ID: 6c0000
RAID:
Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
Drives:
Local Storage: total: 2.87 TiB used: 342.22 GiB (11.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: HFM001TD3JX013N
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 41000C20 temp: 46.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 model: N/A size: 117.19 GiB block-size:
physical: 512 B logical: 512 B type: USB rev: 3.2 spd: 5 Gb/s lanes: 1
mode: 3.2 gen-1x1 tech: N/A serial: <filter> fw-rev: 3.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-3: /dev/sdb maj-min: 8:16 vendor: Toshiba model: MQ01UBB200
size: 1.82 TiB block-size: physical: 512 B logical: 512 B type: USB rev: 2.1
spd: 480 Mb/s lanes: 1 mode: 2.0 tech: HDD rpm: 5400 serial: <filter>
fw-rev: 5438 scheme: GPT
Partition:
ID-1: / raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 84.6 GiB (8.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 84.6 GiB (8.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 84.6 GiB (8.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 84.6 GiB (8.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.3 GiB used: 4.07 GiB (26.6%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 20
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 64.0 C mobo: N/A
Fan Speeds (rpm): N/A
Info:
Memory: total: 16 GiB note: est. available: 15.3 GiB used: 7.86 GiB (51.4%)
Processes: 483 Power: uptime: 21h 40m states: freeze,mem,disk
suspend: s2idle avail: deep wakeups: 6 hibernate: platform avail: shutdown,
reboot, suspend, test_resume image: 6.11 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 256 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 2202 libs: 607 tools: gnome-software, octopi,
pamac, paru pm: flatpak pkgs: 0 Compilers: clang: 17.0.6 gcc: 14.1.1
alt: 13 Shell: garuda-inxi default: fish v: 3.7.1 running-in: konsole
inxi: 3.3.35
Garuda (2.6.26-1):
System install date:     2024-06-23
Last full system update: 2024-06-24 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:```

My date

date
Di 25. Jun 07:23:30 CEST 2024

Use garuda-update in konsole and reboot, it’s KDE :wink: and try out X11 too.

Thank you! Excellent Job creating the best Linux Distro ever BTW!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.