“Stop Charging At:” Value Keeps Resetting to 100%


In my Advanced Power Settings, under "Stop charging at", I have to adjust this value to 60% every time I start my computer up (also when resuming from Hibernate as well).

It resets to 100% every time, which is a bit annoying.

Any assistance on how I can fix this issue? I tried to use chatgpt to help but unfortunately I was not able to take care of it myself.

Thank you.

## obaak@F15

OS: Garuda Linux x86_64
Host: ASUS TUF Dash F15 FX517ZC_FX517ZC 1.0
Kernel: 6.3.8-zen1-1-zen
Uptime: 3 mins
Battery: 60% [Not charging]

Packages: 2055 (pacman)[stable]
Shell: fish 3.6.1
Terminal: konsole 23.4.2

CPU: 12th Gen Intel(R) Core(TM) i7-12650H (16) @ 4.6 G
GPU: Intel UHD Graphics
GPU: NVIDIA GeForce RTX 3050 Mobile
Memory: 3.64 GiB / 15.25 GiB (23%)

╭─obaak@F15 in ~/Downloads took 5s
╰─λ garuda-inxi
Kernel: 6.3.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c44844d4-3c97-4f50-a8da-fce62bde5202 rw rootflags=subvol=@
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=1ec2b04f-ddd5-4077-a756-79bef62a9a9a loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: ASUSTeK product: ASUS TUF Dash F15 FX517ZC_FX517ZC
v: 1.0 serial: <superuser required>
Mobo: ASUSTeK model: FX517ZC v: 1.0 serial: <superuser required>
UEFI: American Megatrends LLC. v: FX517ZC.315 date: 06/17/2022
ID-1: BAT1 charge: 44.5 Wh (60.1%) condition: 74.0/75.8 Wh (97.5%)
volts: 15.7 min: 15.9 model: ASUS A32-K55 type: Li-ion serial: N/A
status: not charging
Info: model: 12th Gen Intel Core i7-12650H bits: 64 type: MST AMCP
arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
microcode: 0x42A
Topology: cpus: 1x cores: 10 mt: 6 tpc: 2 st: 4 threads: 16 smt: enabled
cache: L1: 864 KiB desc: d-4x32 KiB, 6x48 KiB; i-6x32 KiB, 4x64 KiB
L2: 9.5 MiB desc: 6x1.2 MiB, 1x2 MiB L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 1559 high: 2995 min/max: 400/4600:4700:3500 scaling:
driver: intel_pstate governor: powersave cores: 1: 1017 2: 1000 3: 932
4: 1050 5: 1028 6: 1699 7: 900 8: 1000 9: 867 10: 1103 11: 2831 12: 2995
13: 2300 14: 2007 15: 2187 16: 2038 bogomips: 86016
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Alder Lake-P GT1 [UHD Graphics] vendor: ASUSTeK driver: i915
v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+ ports:
active: eDP-1 empty: DP-1,DP-2 bus-ID: 0000:00:02.0 chip-ID: 8086:46a3
class-ID: 0300
Device-2: NVIDIA GA107M [GeForce RTX 3050 Mobile] vendor: ASUSTeK
driver: nvidia v: 535.54.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
status: current (as of 2023-05) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-22 bus-ID: 0000:01:00.0
chip-ID: 10de:25a2 class-ID: 0300
Device-3: Sonix USB2.0 HD UVC WebCam driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-7:6 chip-ID: 322e:202c
class-ID: 0e02
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.65x15.00")
s-diag: 777mm (30.58")
Monitor-1: eDP-1 model: BOE Display 0x0a07 built: 2021 res: 2560x1440
hz: 165 dpi: 189 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: 2560x1440
API: OpenGL v: 4.6 Mesa 23.1.2 renderer: Mesa Intel Graphics (ADL GT2)
direct-render: Yes
Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
bus-ID: 0000:00:1f.3 chip-ID: 8086:51c8 class-ID: 0403
Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 0000:01:00.1 chip-ID: 10de:2291 class-ID: 0403
Device-3: ASUSTek C-Media Audio driver: hid-generic,snd-usb-audio,usbhid
type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-9:7
chip-ID: 0b05:6206 class-ID: 0300
API: ALSA v: k6.3.8-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 0.3.71 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 0000:00:14.3 chip-ID: 8086:51f0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Intel Ethernet I219-LM vendor: ASUSTeK driver: e1000e v: kernel
port: N/A bus-ID: 0000:00:1f.6 chip-ID: 8086:1a1e class-ID: 0200
IF: eno2 state: down mac: <filter>
Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:10 chip-ID: 8087:0026
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
Local Storage: total: 476.94 GiB used: 236.76 GiB (49.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNU512GZ
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 002C temp: 45.9 C scheme: GPT
ID-1: / raw-size: 459.87 GiB size: 459.87 GiB (100.00%)
used: 236.76 GiB (51.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 459.87 GiB size: 459.87 GiB (100.00%)
used: 236.76 GiB (51.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 459.87 GiB size: 459.87 GiB (100.00%)
used: 236.76 GiB (51.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 459.87 GiB size: 459.87 GiB (100.00%)
used: 236.76 GiB (51.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.25 GiB used: 4.24 GiB (27.8%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 16.78 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
System Temperatures: cpu: 81.0 C mobo: N/A
Fan Speeds (RPM): cpu: 3300
Processes: 406 Uptime: 59m wakeups: 1 Memory: available: 15.25 GiB
used: 11 GiB (72.1%) Init: systemd v: 253 default: graphical tool: systemctl
Compilers: gcc: 13.1.1 Packages: pm: pacman pkgs: 2055 libs: 578
tools: octopi,pamac,paru Shell: fish v: 3.6.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.27
Garuda (2.6.16-1):
System install date:     2023-06-18
Last full system update: 2023-06-21
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

Maybe you can help what the app name is?
Or is it under KDE Systemsettings?

If its not a Garuda App you must open an issue on GitHub/GitLab.

Or you just write a little script which start at boot/hibernate.


Check if this helps:
If not, check also if there is a setting in the BIOS for this.


It looks like this is a bug affecting certain Asus laptops: 450551 – Battery charge limit is not preserved after reboot on many laptops that support charge limits; need to write it on every boot

Until it gets fixed, I think this is probably the most reasonable workaround:

Or, someone else in the thread was able to regain some functionality using TLP:

Peter2022-11-04 21:51:03 UTC

I have found sort of a solution by using a program called tlp. There is a gui interface for it called tlpui. It fixes the problem, sort of, but it allows your battery to charge past where you set it when you boot/restart. Not quite perfect, but it’s better than frying your battery. Peter


Not solved but the solution :slight_smile: , I mark it .

So far

1 Like

It's called "Advanced Power Settings -- System Settings", not sure what else it is called, I access it by right clicking the battery Icon from the tray, clicking "Configure Energy Saving", then going to the "Advanced Power Settings" tab

Thank you I just ran asusctl -c 60, I hope this sets it automatically now. I appreciate you

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.