Steam won't launch for one user

Hi, I’ve got a bit of an unusual issue with Steam. My girlfriend and I share a computer with Garuda on and we each have our own user/login and launch our own steam accounts within our logins. I’m the Admin user she is just a standard user.

All has been working without issue for ages but suddenly in the last couple of days she cannot open steam whereas I can. On her login it begins to open with a blue swirl going around the steam logo but after a short time closes then almost immediately opens up the same screen again and repeats seemingly forever.

I’ve tried both native and runtime steam and also tried uninstalling then reinstalling steam but neither has helped.

Can’t fathom why it has suddenly stopped on her login but remains fine on mine. Oh also she can launch recent games from the steam system tray icon so it seems like steam is maybe open though it doesn’t appear so and won’t allow her to view her library or anything. Plus the window keep opening and closing trying to start is a pain.

Thanks in advance for any assistance you can provide.

Kernel: 6.8.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=747818cb-1f85-4570-b7ec-79d505c500ba rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 6.0.2 tk: Qt v: N/A info: frameworks v: 6.0.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: ROG STRIX Z390-F GAMING v: Rev 1.xx
serial: <superuser required> part-nu: ASUS_MB_CNL uuid: <superuser required>
UEFI: American Megatrends v: 1802 date: 12/01/2020
Info: model: Intel Core i9-9900K bits: 64 type: MT MCP arch: Coffee Lake
gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 0xD (13) microcode: 0xFC
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 800 min/max: 800/5000 scaling: driver: intel_pstate
governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800
8: 800 9: 800 10: 800 11: 800 12: 800 13: 800 14: 800 15: 800 16: 800
bogomips: 115200
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities: <filter>
Device-1: AMD Navi 31 [Radeon RX 7900 XT/7900 XTX/7900M]
vendor: Sapphire PULSE driver: amdgpu v: kernel arch: RDNA-3 code: Navi-3x
process: TSMC n5 (5nm) built: 2022+ pcie: gen: 4 speed: 16 GT/s lanes: 16
ports: active: HDMI-A-1 empty: DP-1, DP-2, HDMI-A-2, Writeback-1
bus-ID: 03:00.0 chip-ID: 1002:744c class-ID: 0300
Display: wayland server: v: with: Xwayland v: 23.2.4
compositor: kwin_wayland driver: X: loaded: amdgpu
unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
gpu: amdgpu display-ID: 0
Monitor-1: HDMI-A-1 res: 1920x1080 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast surfaceless: drv: radeonsi wayland: drv: radeonsi x11:
drv: radeonsi inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.3-arch1.2
glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 7900 XTX (radeonsi
navi31 LLVM 17.0.6 DRM 3.57 6.8.1-zen1-1-zen) device-ID: 1002:744c
memory: 23.44 GiB unified: no display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 13 device: 0 type: discrete-gpu name: AMD
Radeon RX 7900 XTX (RADV NAVI31) driver: mesa radv v: 24.0.3-arch1.2
device-ID: 1002:744c surfaces: xcb,xlib,wayland device: 1 type: cpu
name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe
v: 24.0.3-arch1.2 (LLVM 17.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:a348 class-ID: 0403
Device-2: AMD Navi 31 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab30
class-ID: 0403
API: ALSA v: k6.8.1-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: alsactl,alsamixer,amixer
Server-1: PipeWire v: 1.0.4 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15bc class-ID: 0200
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Info: services: NetworkManager,systemd-timesyncd
Device-1: Broadcom BCM20702A0 Bluetooth 4.0 driver: btusb v: 0.8 type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-6.1:6
chip-ID: 0a5c:21e8 class-ID: fe01 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.0
lmp-v: 6 status: discoverable: no pairing: no class-ID: 6c0104
Local Storage: total: 931.51 GiB used: 830.74 GiB (89.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 2B2QEXM7 temp: 32.9 C scheme: GPT
ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 830.74 GiB (89.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 830.74 GiB (89.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 830.74 GiB (89.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 830.74 GiB (89.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 31.26 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
System Temperatures: cpu: 30.0 C mobo: N/A gpu: amdgpu temp: 38.0 C
mem: 48.0 C
Fan Speeds (rpm): cpu: 0 gpu: amdgpu fan: 0
Memory: total: 32 GiB available: 31.26 GiB used: 4.11 GiB (13.2%)
Processes: 343 Power: uptime: 14m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 12.48 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 1892 libs: 533 tools: octopi,paru Compilers:
clang: 17.0.6 gcc: 13.2.1 Shell: garuda-inxi default: Bash v: 5.2.26
running-in: konsole inxi: 3.3.33
Garuda (2.6.23-1):
System install date:     2023-04-22
Last full system update: 2024-03-27 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

Try creating a new user, and see if the third user is able to open the games.


Another idea, clear the caches:

Make sure your system is updated and restarted afterwards.

1 Like

Hi, that works thank you very much. The new user can open Steam which is great but ideally I’d still like to resolve this on her old account if anyone has the know how as it’s already set up to her liking.

Hi, unfortunately clearing the cache, updating and rebooting didn’t resolve the issue. Thank you for trying though.

Maybe that is the issue. You have mentioned other accounts can be launched with no issues. I presume there is a buggy option/slider in the settings.
Play with the settings (enable and disable options), maybe try the “Beta” version, if you are adventurous.
I am not sure this is Garuda issue, but I might be mistaken.


I didn’t even know there was a beta version of Garuda but probably not something I’d try anyway. I’d likely mess up my own account too. Haha.

I asked her and she’s sure she’s changed nothing recently anyway. All she’s done is play stardew valley and a tiny bit of browsing the web via Chrome. Not tweaked any settings for ages.

It’s really puzzling but I guess I’ll transfer all her files and saves and stuff over when I have the time. Hopefully I won’t end up transferring whatever caused the issue in the first place.

You misunderstood, I meant Beta version of Steam:

Though, otherwise, I am out of ideas on how to solve this. Maybe the profile got corrupted. I suggest doing some extra tests on your own, maybe contacting Valve, if the profile is not working on other systems as well.


Ah I see sorry, the issue is that she can’t open steam on her garuda login, at least the old one. She can open it on her new login so her steam profile/account seems to be okay.

Unfortunately can’t try changing any settings within steam or trying the beta as she can’t open it to access the settings. I don’t think even changing settings on her new login would change anything on the old as I believe the settings are individual to each steam client as I’m pretty sure I have different settings on different systems like my PC is opted into the beta but my steam deck isn’t.

It’s such a random issue and it’s bugging me that I can’t for the life of me think of anything that could have caused it.

Did you already try clearing the steam directory in ~/.steam ? From what I know a lot of stuff is cached here, like runtimes and game data.


Thanks for that, I did consider that but was concerned about losing her saved games.

On checking though, most of what she plays uses cloud saves so I gave it a go and unfortunately still the same issue.

When looking for other steam directories I found that also deleting ~/.local/share/Steam did the job. Looked like it was the same stuff as in ~/.steam so maybe one was a symlink of the other? Not something I know much about but anyway Steam now opens on her original Garuda login so thank you kindly to all involved.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.