Steam Remote Play Anywhere Stutters and Will Not Display Stream

Hello, I’m trying to stream Steam games from my Windows 10 Desktop to my laptop running Garuda Linux. Steam successfully starts the streaming session, but the display flickers constantly and does not show the game.

The desktop runs the games fine, and I have streamed from it to other devices with no issues before. When I try to stream to this laptop running Garuda, the stream starts, but the display continually flickers and only shows the generic Steam background instead of the actual game. The “bad connection” red icon shows up as well. Game audio comes through clearly, and when I move the cursor on the laptop, I can see the cursor on the host machine moving as expected. Only the display is not functioning correctly.

I tried plugging the laptop ethernet into the same router as the host machine to check for latency issues, but the issue persisted. The issue occurs when trying to stream any steam games to Garuda Linux.

I have Windows 10 dual-boot on this laptop, and Remote Play Anywhere will stream just fine when I boot into Windows 10, so the issue seems to limited to running Garuda.

This laptop has an integrated Intel gpu and a dedicated Nvidia gpu. It appears the stream is running on the integrated gpu, and I have been unable to make it run on the dedicated gpu to test that out.

I found this GitHub issue which sounds close the problem I’m having, however my Nvidia settings don’t have the AllowFlipping option so the solution in the link does not work for me.

I’m hoping the community can assist me. Thank you

My garuda-inxi:

Kernel: 6.6.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=f6de50df-1b53-4507-a69d-8201ec25043a rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: LENOVO product: 20HJS7DG00 v: ThinkPad P51
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: LENOVO model: 20HJS7DG00 v: SDK0Q40112 WIN
serial: <superuser required> UEFI: LENOVO v: N1UET86W (1.60 )
date: 11/30/2022
ID-1: BAT0 charge: 67.2 Wh (93.7%) condition: 71.7/90.0 Wh (79.7%)
power: 13.8 W volts: 12.8 min: 11.2 model: SMP 00NY493 type: Li-poly
serial: <filter> status: charging cycles: 974
Info: model: Intel Xeon E3-1505M v6 bits: 64 type: MT MCP arch: Kaby Lake
level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 9 microcode: 0xF4
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 3420 high: 4000 min/max: 800/4000 scaling:
driver: intel_pstate governor: powersave cores: 1: 3641 2: 3751 3: 3714
4: 3745 5: 4000 6: 3792 7: 800 8: 3919 bogomips: 48000
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel HD Graphics P630 vendor: Lenovo driver: i915 v: kernel
arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1
empty: none bus-ID: 00:02.0 chip-ID: 8086:591d class-ID: 0300
Device-2: NVIDIA GM206GLM [Quadro M2200 Mobile] vendor: Lenovo
driver: nvidia v: 545.29.02 alternate: nouveau,nvidia_drm non-free: 545.xx+
status: current (as of 2023-10; EOL~2026-12-xx) arch: Maxwell code: GMxxx
process: TSMC 28nm built: 2014-2019 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1436
class-ID: 0302
Device-3: Chicony Integrated Camera driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-8:2 chip-ID: 04f2:b5ab
class-ID: 0e02
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 507x285mm (19.96x11.22")
s-diag: 582mm (22.9")
Monitor-1: eDP-1 model: AU Optronics 0x21eb built: 2016 res: 1920x1080
hz: 60 dpi: 141 gamma: 1.2 size: 345x194mm (13.58x7.64") diag: 396mm (15.6")
ratio: 16:9 modes: 3840x2160
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 1 drv: iris device: 3 drv: swrast gbm: drv: nvidia
surfaceless: drv: nvidia x11: drv: iris inactive: wayland,device-2
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics P630 (KBL
GT2) device-ID: 8086:591d memory: 30.46 GiB unified: yes
API: Vulkan v: 1.3.269 layers: 14 device: 0 type: integrated-gpu
name: Intel HD Graphics P630 (KBL GT2) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:591d surfaces: xcb,xlib device: 1 type: discrete-gpu
name: Quadro M2200 driver: nvidia v: 545.29.02 device-ID: 10de:1436
surfaces: xcb,xlib device: 2 type: cpu name: llvmpipe (LLVM 16.0.6 256
bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM 16.0.6)
device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel CM238 HD Audio vendor: Lenovo driver: snd_hda_intel
v: kernel alternate: snd_soc_avs bus-ID: 00:1f.3 chip-ID: 8086:a171
class-ID: 0403
Device-2: NVIDIA GM206 High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1
chip-ID: 10de:0fba class-ID: 0403
API: ALSA v: k6.6.2-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.85 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Ethernet I219-LM vendor: Lenovo driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15e3 class-ID: 0200
IF: enp0s31f6 state: down mac: <filter>
Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:24fd
class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
Local Storage: total: 953.87 GiB used: 73.73 GiB (7.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 model: PCIe SSD size: 953.87 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
tech: SSD serial: <filter> fw-rev: H230331a temp: 37.9 C scheme: GPT
ID-1: / raw-size: 224 GiB size: 224 GiB (100.00%) used: 73.7 GiB (32.9%)
fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 25.8 MiB (26.9%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 224 GiB size: 224 GiB (100.00%)
used: 73.7 GiB (32.9%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 224 GiB size: 224 GiB (100.00%)
used: 73.7 GiB (32.9%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 224 GiB size: 224 GiB (100.00%)
used: 73.7 GiB (32.9%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 31.19 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
System Temperatures: cpu: 49.0 C pch: 45.0 C mobo: N/A
Fan Speeds (rpm): fan-1: 2321 fan-2: 2327
Processes: 270 Uptime: 35m wakeups: 0 Memory: total: 32 GiB
available: 31.19 GiB used: 3.9 GiB (12.5%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 2025 libs: 576 tools: octopi,paru Shell: fish v: 3.6.1
default: Bash v: 5.2.15 running-in: konsole inxi: 3.3.31
Garuda (2.6.19-2):
System install date:     2023-09-17
Last full system update: 2023-11-21
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

You don’t have to run steam on the dGPU but launch the games as explained


Hi thanks for this. I entered prime-run %command% into the launch options for one of my steam games but it did not have an effect.

Since the game is being streamed and is running on the host machine, I don’t think the game launch parameters on the client machine are invoked. I think I would need a way to have the stream process started with prime-run. Do you know how to do that? The process appears to be named streaming_clien based on intel-gpu-top.

For posterity, I located the issue and have a temporary fix. The laptop is not decoding the video information correctly. The error is: CVAAPIAccelX11: vaPutSurface() failed: invalid parameter

I fixed it by disabling hardware encoding and decoding in the steam remote play options on my laptop (client device).

I believe I will make a new forum post for this error as it may affect other programs as well.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.