Steam Play won't enable GE

Hello Garuda users.
Having some issues getting steam to switch over to Proton-GE. (Specifically for Madden 23 if anyone is interested) It'll switch to 7.0.4 no problem, however trying to use GE or DOSbox will just leave Steam Play disabled after restart. I ran Madden 23 previously with little issue this way before and don't believe I've tinkered with anything since? All I know is it freezes after startup menu, and I believe this steam issue to be the culprit.

~~~
Kernel: 5.18.15-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
parameters: BOOT_IMAGE=/timeshift-btrfs/snapshots/2022-08-02_18-35-00/@/boot/vmlinuz-linux-zen
root=UUID=0a9d5b83-0a65-4d66-9dd9-fcf07bb02591 quiet quiet splash
rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
rootflags=defaults,noatime,compress=zstd,discard=async,ssd,subvol=timeshift-btrfs/snapshots/2022-08-02_18-35-00/@
Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: ROG STRIX B550-A GAMING v: Rev X.0x
serial: <superuser required> BIOS: American Megatrends v: 2423
date: 08/09/2021
CPU:
Info: model: AMD Ryzen 7 5800X bits: 64 type: MT MCP arch: Zen 3 gen: 4
built: 2021-22 process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x21 (33)
stepping: 2 microcode: 0xA201204
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 3615 high: 3800 min/max: 2200/4850 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3653 2: 3598
3: 3585 4: 3594 5: 3597 6: 3597 7: 3643 8: 3595 9: 3597 10: 3597 11: 3598
12: 3410 13: 3800 14: 3600 15: 3596 16: 3785 bogomips: 121599
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GA106 [GeForce RTX 3060 Lite Hash Rate] vendor: ZOTAC
driver: nvidia v: 515.57 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-07) arch: Ampere code: GAxxx process: TSMC n7
(7nm) built: 2020-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 4 link-max:
gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 08:00.0 chip-ID: 10de:2504
class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 80 s-size: 609x343mm (23.98x13.50")
s-diag: 699mm (27.52")
Monitor-1: DP-0 res: 1920x1080 hz: 60 dpi: 82
size: 598x336mm (23.54x13.23") diag: 686mm (27.01") modes: N/A
OpenGL: renderer: NVIDIA GeForce RTX 3060/PCIe/SSE2 v: 4.6.0 NVIDIA
515.57 direct render: Yes
Audio:
Device-1: NVIDIA GA106 High Definition Audio vendor: ZOTAC
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 4
link-max: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 08:00.1
chip-ID: 10de:228e class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0a:00.4 chip-ID: 1022:1487 class-ID: 0403
Sound Server-1: ALSA v: k5.18.15-zen1-2-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel pcie:
gen: 2 speed: 5 GT/s lanes: 1 port: N/A bus-ID: 07:00.0 chip-ID: 8086:15f3
class-ID: 0200
IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 3.18 TiB used: 458.49 GiB (14.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: WD BLACK
SN770 500GB size: 465.76 GiB block-size: physical: 512 B logical: 512 B
speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter> rev: 731030WD
temp: 35.9 C scheme: MBR
ID-2: /dev/nvme1n1 maj-min: 259:2 vendor: Western Digital model: WD BLACK
SN750 SE NVMe 1TB size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 711130WD temp: 30.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM008-2FR102
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: 0001 scheme: GPT
Partition:
ID-1: / raw-size: 465.76 GiB size: 465.76 GiB (100.00%) used: 298.88 GiB
(64.2%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-2: /home raw-size: 465.76 GiB size: 465.76 GiB (100.00%) used: 298.88
GiB (64.2%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /var/log raw-size: 465.76 GiB size: 465.76 GiB (100.00%) used: 298.88
GiB (64.2%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
ID-4: /var/tmp raw-size: 465.76 GiB size: 465.76 GiB (100.00%) used: 298.88
GiB (64.2%) fs: btrfs dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.23 GiB used: 56 MiB (0.2%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 45.4 C mobo: N/A gpu: nvidia temp: 44 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
Processes: 342 Uptime: 3h 9m wakeups: 0 Memory: 31.23 GiB used: 3.64 GiB
(11.7%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.1.1 Packages: pacman: 1891 lib: 543 Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.20
Garuda (2.6.5-1):
System install date:     2022-08-02
Last full system update: 2022-08-02
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Timeshift
Failed units:            bluetooth-autoconnect.service
~~~

Not exactly sure what the specific question here is exactly, but if you are looking to run Madden 23, people have reported Proton 7.0-4 works where-as Experimental (and most likely some others) might not. You might also have to set launch options: PROTON_NO_D3D12=1 %command% . Info taken from here : https://www.protondb.com/app/1760250

As updates go on, you will find you will have to try different versions for different games. Pretty much how things go for Linux Gaming for the time being. Searching for what kind of game you want to run on https://www.protondb.com/ will help you get games running.

1 Like

Sorry, should of made it more clear. The question is why won't steam enable Steam Play on GE-Custom? Whenever I go to set that as "run other titles with." it'll restart but then won't have it actually enabled when I check, and reverts back to DOSbox.

And yes that's actually my post from when the game first came out. Not sure if there was an update, but that's how I ran it in the past.

Under settings>Steam Play, do you have Enable Steam Play for Supported titles checked? For other titles I usually set it for Proton Experimental and then set per game what other Proton versions I would want.
If it is still not remembering settings, I would bring the issue up to Valve, as it is most likely a bug.

Oh... looks like you are booted to a snapshot. You need to restore it and then reboot. That might be your issue to why settings aren't saving.

1 Like

I have both enabled yes, "for Supported titles" remains checked off however "for all other" is what always gets unchecked, thanks for the advice, i'll take that route.

That was just me trying to jump back a couple days to when it did work. Same issue after clearing that up.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.