Steam, new steam library folder must be on a filesystem mounted with execute permissions

Steam, new steam library folder must be on a filesystem mounted with execute permissions.
I get that error message if i try to add a new library folder to steam.
I have exec permissions:
image
it still creates a empty "steamapps" folder, but nothing more.
PS: my drive is mounted at /mnt/storage and my steam folder is /mnt/storage/steamstorage

You can verify by checking e.g.

mount | grep storage

I'm going to guess that this is an NTFS drive. If it is, be aware that things might not work correctly (especially Linux-native applications like Proton).

You can read about the fstab options needed here: https://wiki.archlinux.org/title/NTFS-3G#Linux_compatible_permissions

2 Likes

Its BTRFS filesystem. And when i type that command this is the output:

/dev/sda1 on /mnt/storage type btrfs (rw,nosuid,nodev,noexec,noatime,compress=zstd:3,space_cache,subvolid=5,subvol=/,user=z3r0ut,x-gvfs-show)

And now i probably see why it isnt working. it says "noexec" how can i change that?

PS: this is the line for the drive in fstab:

/dev/disk/by-uuid/2fd97598-095f-4470-b966-2c3b8324ce0b /mnt/storage auto nosuid,exec,noatime,rw,user,compress=zstd,x-gvfs-show 0 0

As you can see, "exec" is there, not "noexec"

That format looks weird... if you're using a by-uuid path then you can just use UUID=, and it's probably worth setting the filesystem rather than relying on auto.

If you don't want it to auto-mount (given the user option) then you should look at https://wiki.archlinux.org/title/Fstab#Automount_with_systemd.

Actually, it will be worth reviewing that page in its entirety so that you end up with a better understanding of mounting devices using an fstab.

3 Likes

i didnt know what the user option was, i want it to auto mount. I changed it to this:

UUID=2fd97598-095f-4470-b966-2c3b8324ce0b /mnt/storage btrfs nosuid,exec,noatime,rw,compress=zstd,x-gvfs-show 0 0

And now it works as i want it to work. Thank you.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.