Steam - mangohud stopped working

Mangohud on steam stopped working, on lutris working fine
I think that's with latest update to steam with new overlay and look, any one has an idea how to fix it for steam?

I have heard of this issue. There have been a few people here posting about it. I don't know of any workout around of yet, except I did read that if you install steam and mangohud via flatpak, users report it working. Not the best option, imo, but might give it a try if you really need it.

Might need to track this.


well i do not need it, but it was a good indicator how my graphics card working, strangest thing is after steam update, game torchlight inifite feels very slow, like there would be some lag on game, but fps is stable 60, didn't had that before

About installing flatpak, not sure if i want to mess with flatpak, i would rather like to reinstall package and don't mess to much with garuda system

I have jumped on garuda gaming dragonized, from linux mint which i couldn't stabilize for gaming, always there was some strange lag on games, like example which i posted above, or mint was broken after reboot

Sounds like you have several issues going on. Regarding the game itself, you might try different proton versions in steam or research your particular game with lag on and see if a particular proton version or command is needed to run it.

However, you are saying you have lag in games using two different distros? That might mean a hardware issue, driver issue, etc. You would need to open up a separate help thread posting your specs following the Garuda requirements.


Issue is that i was playing on same proton-ge version as before steam update, and now lags occur on same setup

Im just saying that i jumped to garuda because its best for me to play games, today i did huge package update on garuda
And after that steam probably got to higher version

Could be a steam issue or now that proton version doesn't work with that particular steam version. Have you tried Proton experimental or downloaded another version of proton?


Ill try other proton-ge version, path of exile is working fine, even better than before, will check on higher proton version for torchlight

Still need to find out how to fix mangohud

I gave you mangohud's issue reports link above, I suggest you look for answers there. Also, did you do a search on this forum? There seems to be a fix here, it this is your issue, might work.


I was googling around, didnt search specifically forum
He is mentioning about bore kernel, im using zen, will check on older zen version


i remember now, i have read that topic, but he was saying that he have reinstalled completely that package, i have reinstalled mangohud and installed glu, nothing works

Then I would point back to the bug reports on mangohud's git page.


yes, i did that, thank you

1 Like

found this:

latest git version of mangohud has fixed the issue.

I used lib32-mangohud-git from AUR to get mangohud working again.


hm, if i put lib32-mangohud-git cannot be found
i have installed lib32-mangohud, but no changes still not working

im noob to arch, first time working on that desktop env, so not sure how to get that package with -git actually

for any other noob like me on arch, AUR packages installation instruction

thank you @pathogen that have worked

You didn't need to download yay we already have paru in garuda. Plus, mangohud-git is in chaotic-aur as well. So, simply using paru commands like this instead of yay works too,

paru -S mangohud-git

would pull mangohud-git from chaotic-aur and you wouldn't have to worry about compiling it. However if for some reason chaotic-aur isn't working you can try the aur version as well however, that would mean your AUR helper would pull build tools to compile mangohud-git and would show you the PKGBUILD file contents so you can verify that nothing suspicious is happening.

paru -S aur/mangohud-git

To download from aur instead of chaotic-aur


Thank you, i do not know yet about these tools, matbe i will uninstall yay then

But i like more arch based diatros than debian

No need you can simply keep both. They have same commands anyway. Just mentioned that here in case someone looks at this thread in future they know that garuda's got them covered even with aur helpers.



# Replace some more things with better alternatives

[ ! -x /usr/bin/yay ] && [ -x /usr/bin/paru ] && alias yay='paru'

Type yay and you use magically paru :smiley: