Steam issue: Assertion failed: !status && "vkCreateGraphicsPipelines"

System:
  Kernel: 6.9.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=70298202-3941-4097-b3f6-9e9ab18d10bf rw rootflags=subvol=@
    quiet resume=UUID=2a710883-dad9-4c61-a48e-9712c540943e loglevel=3 ibt=off
  Desktop: Hyprland v: 0.41.2-27-gb03f41ef with: waybar tools:
    avail: swayidle,swaylock vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX X570-I GAMING v: Rev X.0x
    serial: <superuser required> part-nu: SKU uuid: <superuser required>
    UEFI: American Megatrends v: 4601 date: 02/02/2023
CPU:
  Info: model: AMD Ryzen 7 5800X3D bits: 64 type: MT MCP arch: Zen 3+ gen: 4
    level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
    model-id: 0x21 (33) stepping: 2 microcode: 0xA20120A
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 96 MiB desc: 1x96 MiB
  Speed (MHz): avg: 3486 high: 3600 min/max: 2200/4549 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 3400 2: 3400
    3: 3599 4: 3400 5: 3598 6: 3400 7: 3400 8: 3594 9: 3598 10: 3598 11: 3400
    12: 3400 13: 3400 14: 3400 15: 3594 16: 3600 bogomips: 108806
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
Graphics:
  Device-1: AMD Navi 31 [Radeon RX 7900 XT/7900 XTX/7900M]
    vendor: Sapphire PULSE driver: amdgpu v: kernel arch: RDNA-3 code: Navi-3x
    process: TSMC n5 (5nm) built: 2022+ pcie: gen: 4 speed: 16 GT/s lanes: 16
    ports: active: DP-1,HDMI-A-1 empty: DP-2,HDMI-A-2,Writeback-1
    bus-ID: 0c:00.0 chip-ID: 1002:744c class-ID: 0300
  Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0
    compositor: Hyprland v: 0.41.2-27-gb03f41ef driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: 1
  Monitor-1: DP-1 model: AOC U34G2G4R3 serial: <filter> built: 2020
    res: 3440x1440 hz: 144 dpi: 110 gamma: 1.2 scale: 1
    size: 797x334mm (31.38x13.15") diag: 864mm (34") modes: max: 3440x1440
    min: 720x400
  Monitor-2: HDMI-A-1 model: AOC 2460G5 serial: <filter> built: 2018
    res: 1920x1080 hz: 60 dpi: 92 gamma: 1.2 scale: 1
    size: 531x299mm (20.91x11.77") diag: 609mm (24") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi wayland: drv: radeonsi x11:
    drv: radeonsi inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.1.3-arch1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 7900 XT (radeonsi
    navi31 LLVM 18.1.8 DRM 3.57 6.9.8-zen1-1-zen) device-ID: 1002:744c
    memory: 19.53 GiB unified: no
  API: Vulkan v: 1.3.279 layers: 10 device: 0 type: discrete-gpu
    name: AMD Radeon RX 7900 XT driver: amd v: (LLPC) device-ID: 1002:744c
    surfaces: xcb,xlib,wayland device: 1 type: discrete-gpu name: AMD Radeon
    RX 7900 XT (RADV NAVI31) driver: mesa radv v: 24.1.3-arch1.1
    device-ID: 1002:744c surfaces: xcb,xlib,wayland device: 2 type: cpu
    name: llvmpipe (LLVM 18.1.8 256 bits) driver: mesa llvmpipe
    v: 24.1.3-arch1.1 (LLVM 18.1.8) device-ID: 10005:0000
    surfaces: xcb,xlib,wayland
Audio:
  Device-1: AMD Navi 31 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0c:00.1 chip-ID: 1002:ab30
    class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0e:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: SteelSeries ApS GameDAC driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-3.2:11
    chip-ID: 1038:1283 class-ID: 0300 serial: <filter>
  API: ALSA v: k6.9.8-zen1-1-zen status: kernel-api with: aoss
    type: oss-emulator tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.2.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 05:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp5s0 state: down mac: <filter>
  Device-2: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 06:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Bluetooth:
  Device-1: SINO WEALTH RK Bluetooth Keyboar driver: hid-generic,usbhid
    type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-1.4:4
    chip-ID: 258a:0059 class-ID: 0300
  Device-2: ASUSTek Broadcom BCM20702A0 Bluetooth driver: btusb v: 0.8
    type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-2.1.1:9
    chip-ID: 0b05:17cb class-ID: fe01 serial: <filter>
  Report: ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.0 lmp-v: 6
    status: discoverable: yes pairing: yes class-ID: 6c0104
Drives:
  Local Storage: total: 3.87 TiB used: 1.83 TiB (47.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix
    model: HFM256GDHTNG-8310A size: 238.47 GiB block-size: physical: 512 B
    logical: 512 B speed: 15.8 Gb/s lanes: 2 tech: SSD serial: <filter>
    fw-rev: 80070C00 temp: 53.9 C scheme: MBR
  ID-2: /dev/nvme1n1 maj-min: 259:2 vendor: Samsung
    model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 2B2QEXM7 temp: 46.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 2TB
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 2B6Q scheme: GPT
  ID-4: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT1000MX500SSD1
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 033 scheme: GPT
Partition:
  ID-1: / raw-size: 862.24 GiB size: 862.24 GiB (100.00%)
    used: 251.99 GiB (29.2%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:4
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:3
  ID-3: /home raw-size: 862.24 GiB size: 862.24 GiB (100.00%)
    used: 251.99 GiB (29.2%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:4
  ID-4: /var/log raw-size: 862.24 GiB size: 862.24 GiB (100.00%)
    used: 251.99 GiB (29.2%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:4
  ID-5: /var/tmp raw-size: 862.24 GiB size: 862.24 GiB (100.00%)
    used: 251.99 GiB (29.2%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:4
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 62.71 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 68.97 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme1n1p3 maj-min: 259:5
Sensors:
  System Temperatures: cpu: 50.0 C mobo: 47.0 C gpu: amdgpu temp: 57.0 C
    mem: 62.0 C
  Fan Speeds (rpm): fan-1: 1034 fan-2: 1869 fan-5: 994 fan-7: 0 gpu: amdgpu
    fan: 0
Info:
  Memory: total: 64 GiB note: est. available: 62.71 GiB used: 7.72 GiB (12.3%)
  Processes: 481 Power: uptime: 6m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 25.07 GiB services: upowerd Init: systemd
    v: 256 default: graphical tool: systemctl
  Packages: 2439 pm: pacman pkgs: 2411 libs: 577 tools: pacseek,paru
    pm: flatpak pkgs: 28 Compilers: clang: 18.1.8 gcc: 14.1.1 alt: 12
    Shell: garuda-inxi default: fish v: 3.7.1 running-in: alacritty
    inxi: 3.3.35
Garuda (2.6.26-1):
  System install date:     2024-07-04
  Last full system update: 2024-07-11
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:

Heyho, maybe someone here has an idea. I know full-well this isn’t an issue of Garuda but the internet is so fragmented and i know there are a lot of knowledgeable people around here.

I am on hyprland, AMD GPU and i just updated my whole system.

Before that update i could play Apex Legends via Steam, no issues. Now it won’t start. Starting steam via terminal and looking for the logs i can see the error from the title:
Assertion failed: !status && "vkCreateGraphicsPipelines", file ../src-wine/dlls/winevulkan/loader_thunks.c, line 2934

If i use a BTRFS snapshot and go to before the update, it works again. Looking through the internet for that exact issue always points in different directions and none of them seem to apply to me… maybe someone has an idea?

I tested nearly all available proton versions from official ones and Glorious Eggroll.

Other games work perfectly fine though.

ofc i search for days and don’t find anything.

But right after i post here i find a working solution.

I don’t quite understand it but launching steam with this:

VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/radeon_icd.x86_64.json /usr/bin/steam

makes it work flawless.