Steam, how to reinstall proton?

I broke my Proton installation of proton 5.0 and now i get the error "Compatibility tool configuration failed"
I tried: Reinstalling Steam, verifing proton 5.10 (it said 9 failed and then reacquiered them), uninstalling proton 5.0 but this error happend: "an unexpected error occurred while uninstalling this application" i have deleted the Proton 5.0 folder.
Nothing helped.

System:
Kernel: 5.16.3-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=040abae5-a66a-4e4e-96eb-be857e61b87b rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: B450M PRO-VDH MAX (MS-7A38) v: 8.0
serial: <superuser required> UEFI-[Legacy]: American Megatrends v: B.40
date: 11/07/2019
CPU:
Info: model: AMD Ryzen 5 3600X bits: 64 type: MT MCP arch: Zen 2
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701013
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 4130 high: 4350 min/max: 2200/4409 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 4328 2: 4142
3: 4167 4: 4281 5: 4280 6: 4350 7: 4212 8: 4033 9: 3755 10: 3647 11: 4115
12: 4257 bogomips: 91202
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
vendor: Tul driver: amdgpu v: kernel bus-ID: 2b:00.0 chip-ID: 1002:731f
class-ID: 0300
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1185x381mm (46.7x15.0")
s-diag: 1245mm (49")
Monitor-1: DisplayPort-0 res: 1920x1080 hz: 60 dpi: 102
size: 476x268mm (18.7x10.6") diag: 546mm (21.5")
Monitor-2: HDMI-A-0 res: 2560x1440 hz: 60 dpi: 109
size: 597x336mm (23.5x13.2") diag: 685mm (27")
OpenGL: renderer: AMD Radeon RX 5600 XT (NAVI10 DRM 3.44.0
5.16.3-zen1-1-zen LLVM 13.0.0)
v: 4.6 Mesa 21.3.5 direct render: Yes
Audio:
Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel
bus-ID: 2b:00.1 chip-ID: 1002:ab38 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel bus-ID: 2d:00.4 chip-ID: 1022:1487
class-ID: 0403
Device-3: C-Media CM108 Audio Controller type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-3:4 chip-ID: 0d8c:013c
class-ID: 0300
Sound Server-1: ALSA v: k5.16.3-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.44 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel port: f000 bus-ID: 25:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp37s0 state: down mac: <filter>
Device-2: Realtek RTL8811AU 802.11a/b/g/n/ac WLAN Adapter type: USB
driver: rtl88XXau bus-ID: 1-3:2 chip-ID: 0bda:a811 class-ID: 0000
serial: <filter>
IF: wlp3s0f0u3 state: up mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
IF-ID-2: ipv6leakintrf0 state: unknown speed: N/A duplex: N/A
mac: <filter>
IF-ID-3: proton0 state: unknown speed: 10 Mbps duplex: full mac: N/A
IF-ID-4: pvpnksintrf0 state: unknown speed: N/A duplex: N/A mac: <filter>
Drives:
Local Storage: total: 3.18 TiB used: 537.53 GiB (16.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: DT01ACA300
size: 2.73 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: ABB0 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 750 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 1B6Q scheme: MBR
Partition:
ID-1: / raw-size: 465.76 GiB size: 465.76 GiB (100.00%)
used: 121.12 GiB (26.0%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
ID-2: /home raw-size: 465.76 GiB size: 465.76 GiB (100.00%)
used: 121.12 GiB (26.0%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
ID-3: /var/log raw-size: 465.76 GiB size: 465.76 GiB (100.00%)
used: 121.12 GiB (26.0%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
ID-4: /var/tmp raw-size: 465.76 GiB size: 465.76 GiB (100.00%)
used: 121.12 GiB (26.0%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.63 GiB used: 1.56 GiB (9.9%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 58.0 C
mem: 60.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:
Processes: 415 Uptime: 14h 25m wakeups: 0 Memory: 15.63 GiB
used: 5.54 GiB (35.5%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 2126 lib: 478 Shell: fish
v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.12
Garuda:
System install date:     2022-01-14
Last full system update: 2022-01-31
Is partially upgraded:   No
Using TLP:               No
Windows dual boot:       <superuser required>
Snapshots:               Snapper```

If somehow you still need an old version similar to that version (I have never had to use an older version of proton for my games), I don't see Steam offering that specific version anymore when I look in their tool listings, so I assume they dropped support for that. Would explain why you can't grab any files for it anymore. The closest version I see to 5.10 is 5.13

If 5.13 somehow doesn't work for whatever game your are running, Try the latest version of Proton (6.3 at the time of writing), the Experimental version, or Proton GE.

... 1. I need that specific version, if not i wouldnt ask for that.
2. 5.0 is still available. All available versions are:
3.7-8
3.16-9
4.2-9
4.11-13
5.0-10 (the one i have the problem with.)
5.13-6
6.3-8
Proton Experimental
Proton GE

5.0 ... ok (sorry you said 5.1 before so you got me confused). I will poke around for more info on that to see if anybody else is having issues with getting that version downloaded from Steam.

Oh yeah sorry, i just saw my mistake. And no, my problem is not that i cant download it. My problem is that i cant delete it so that i can redownload it.

Ok, I see now. It looks like you had to fix the Proton 5.0 with a validation of files, and even though it did find errors and downloaded what it was missing, you have errors still with launching a game with it, correct? Most likely the Proton version is fixed from that validation, but the game's interaction with the said Proton version is messed up because of that corruption.

Sometimes when I experience similar issues to these (a proton version changing or breaking), I would either have to switch the game's proton to some other version temporarily (and running the game once), and then switching back to real proton version I want to run it with and trying it again. If that fails, sometimes I need to reinstall a game.

What game are you trying to run with that proton version, by the way? I might be able to find other things that might help.

Edit: noticed you said you deleted the 5.0 folder, and that you reinstalled Steam even. You might have to reboot your system so Steam can see your folder changes (just noticed your uptime is 14 hours)

Edit 2: if you are trying to get Planetary Annihilation: TITANS to run (like your other thread), Proton 6.3 should work using Steam (Runtime) and using PROTON_USE_WINED3D=1 %command% as the launch option from what I have seen from reports on people trying to run this game. Seems the native version of this game and the ways to run it with proton both have issues, so your mileage my vary.

1 Like

Just for reference, Proton prefixes for games live under the steamapps/compatdata/ directory within a subdirectory matching the game UID.

2 Likes