Steam games not launching or no connectivity

Hello again,

I have a new problem now. Most of the games I have tried to run on Steam either don’t launch or complain about having no connection to Steam. The one game I’ve tried that seems to work perfectly thus far is Armello. The rundown basically goes like this:

  • Yu-Gi-Oh Duel Links Launches but immediately complains about having no connection to the Steam server.
  • Sea of Theives complains of a “LlamaBeard” connection error.
  • Deep Rock Galactic launches but immediately complains of being unable to connect to Steam.
  • Armello, as mentioned, is the sole known game that launches and runs just fine. This may have to do with being a native Linux game but doesn’t explain the issues with TF2.
  • Team Fortress 2 simply refuses to launch altogether.
  • Digimon Story Cyber Sleuth also refuses to launch.

TF2 and Armello are both running their native Linux versions as far as I can tell. All other games are running through Proton.

I thought that following the instructions linked below would help me out but it just stopped my internet from working and I wound up just reverting to a previous snapshot.

Here is the obligatory garuda-inxi output:

Kernel: 6.6.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=0c56ec49-20ad-4aa0-a88b-55b47e733bc9 rw rootflags=subvol=@
quiet rd.luks.uuid=d79b9435-2941-4ab1-b7b1-6436232809f7
resume=/dev/mapper/luks-49c27010-0fe7-452f-b43e-2b305ff69240 loglevel=3
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_wayland vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: ASRock model: 970M Pro3 serial: <superuser required>
UEFI-[Legacy]: American Megatrends v: P1.50 date: 01/11/2016
Info: model: AMD FX-4350 bits: 64 type: MT MCP arch: Piledriver level: v2
built: 2012-13 process: GF 32nm family: 0x15 (21) model-id: 2 stepping: 0
microcode: 0x6000852
Topology: cpus: 1x cores: 4 smt: enabled cache: L1: 192 KiB
desc: d-4x16 KiB; i-2x64 KiB L2: 4 MiB desc: 2x2 MiB L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 2492 high: 3592 min/max: 1400/4200 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1397 2: 1397
3: 3585 4: 3592 bogomips: 33526
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: AMD Baffin [Radeon RX 460/560D / Pro
450/455/460/555/555X/560/560X] vendor: Tul / PowerColor driver: amdgpu
v: kernel arch: GCN-4 code: Arctic Islands process: GF 14nm built: 2016-20
pcie: gen: 2 speed: 5 GT/s lanes: 8 link-max: gen: 3 speed: 8 GT/s ports:
active: HDMI-A-1 empty: DP-1,DVI-D-1 bus-ID: 01:00.0 chip-ID: 1002:67ef
class-ID: 0300 temp: 58.0 C
Display: wayland server: v: with: Xwayland v: 23.2.2
compositor: kwin_wayland driver: X: loaded: amdgpu
unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
gpu: amdgpu display-ID: 0
Monitor-1: HDMI-A-1 res: 1920x1080 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast surfaceless: drv: radeonsi wayland: drv: radeonsi x11:
drv: radeonsi inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 560 Series (polaris11
LLVM 16.0.6 DRM 3.54 6.6.3-zen1-1-zen) device-ID: 1002:67ef
memory: 3.91 GiB unified: no display-ID: :1.0
API: Vulkan v: 1.3.269 layers: 13 device: 0 type: discrete-gpu name: AMD
Radeon RX 560 Series (RADV POLARIS11) driver: mesa radv v: 23.2.1-arch1.2
device-ID: 1002:67ef surfaces: xcb,xlib,wayland device: 1 type: cpu
name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Device-1: AMD SBx00 Azalia vendor: ASRock driver: snd_hda_intel v: kernel
bus-ID: 00:14.2 chip-ID: 1002:4383 class-ID: 0403
Device-2: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / 560/560X]
vendor: Tul / PowerColor driver: snd_hda_intel v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 8 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1
chip-ID: 1002:aae0 class-ID: 0403
API: ALSA v: k6.6.3-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Broadcom BCM4360 802.11ac Wireless Network Adapter driver: wl
v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1
bus-ID: 04:00.0 chip-ID: 14e4:43a0 class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASRock driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
port: d000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp5s0 state: down mac: <filter>
Device-1: TP-Link UB500 Adapter driver: btusb v: 0.8 type: USB rev: 1.1
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-4:3 chip-ID: 2357:0604
class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 5.1 lmp-v: 10
status: discoverable: no pairing: no
Local Storage: total: 931.51 GiB used: 193.16 GiB (20.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 3B6Q scheme: MBR
ID-1: / raw-size: 922.71 GiB size: 922.71 GiB (100.00%)
used: 193.16 GiB (20.9%) fs: btrfs dev: /dev/dm-1 maj-min: 254:1
mapped: luks-d79b9435-2941-4ab1-b7b1-6436232809f7
ID-2: /home raw-size: 922.71 GiB size: 922.71 GiB (100.00%)
used: 193.16 GiB (20.9%) fs: btrfs dev: /dev/dm-1 maj-min: 254:1
mapped: luks-d79b9435-2941-4ab1-b7b1-6436232809f7
ID-3: /var/log raw-size: 922.71 GiB size: 922.71 GiB (100.00%)
used: 193.16 GiB (20.9%) fs: btrfs dev: /dev/dm-1 maj-min: 254:1
mapped: luks-d79b9435-2941-4ab1-b7b1-6436232809f7
ID-4: /var/tmp raw-size: 922.71 GiB size: 922.71 GiB (100.00%)
used: 193.16 GiB (20.9%) fs: btrfs dev: /dev/dm-1 maj-min: 254:1
mapped: luks-d79b9435-2941-4ab1-b7b1-6436232809f7
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/dm-0 maj-min: 254:0
mapped: luks-49c27010-0fe7-452f-b43e-2b305ff69240
ID-2: swap-2 type: zram size: 7.73 GiB used: 1.61 GiB (20.8%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4
dev: /dev/zram0
System Temperatures: cpu: 20.0 C mobo: N/A gpu: amdgpu temp: 59.0 C
Fan Speeds (rpm): N/A gpu: amdgpu fan: 553
Processes: 304 Uptime: 2h 16m wakeups: 1 Memory: total: 8 GiB
available: 7.73 GiB used: 4.37 GiB (56.5%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: pm: pacman pkgs: 1913 libs: 507 tools: octopi,paru,yay Shell: fish
v: 3.6.1 running-in: konsole inxi: 3.3.31
Garuda (2.6.19-2):
System install date:     2023-11-27
Last full system update: 2023-11-30
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       <superuser required>
Failed units:

I’ve also attached some game screenshots if they are of any use.


Does sound like it could be a DNS issue for most of your issues. Using Garuda Assistant, go to the Settings tab and you can easily change to a different DNS. Try something like Cloudflare.

(I am going to focus on connectivity here since we normally do one issue per thread and that sounds like your main issue. Once that is cleared up and other games aren’t launching still, I would check for information on running those games.)


No dice. Problem still persists even after changing DNS. I even tried doing a full restart afterwords.

After a bit of searching, I believe the problem has something to do with /etc/resolv.conf but I’m hitting a bit of a snag trying to figure it out. I looked at the directions on here: openresolv - ArchWiki
The problem is that if I run resolvconf -u like the page suggests, I get the following message:

find-the-command: “resolveconf” is not found locally, searching in repositories…
find-the-command: command not found: “resolveconf”

This would suggest to me that openresolv isn’t installed, but if I search for it on Octopi, it shows up as already being installed. If I run paru openresolv in the terminal, I get this output:

3 aur/openresolv-git 3.12.0.r5.g24d2882-1 [+1 ~0.00]
The DNS management framework
2 core/systemd-resolvconf 254.6-2 [3.15 KiB 0 B]
systemd resolvconf replacement (for use with systemd-resolved)
1 extra/openresolv 3.13.2-1 [0 B 62.30 KiB] [Installed]
resolv.conf management framework (resolvconf)

This suggests to me that it is actually installed in some capacity but isn’t entirely recognized as being there. That’s basically where I’m at as of writing this. Any further suggestions would be more than welcome.

It’s resolvconf, not resolveconf.
Please consider that /etc/resolv.conf might have the immutable flag set currently, if you changed the DNS with the Garuda Assistant tool.
If so

sudo chattr -i /etc/resolv.conf

Back it up before changing that file.


After following those instructions, I was able to run sudo resolvconf -u but it only seemed to break my DNS entirely so I changed /etc/resolv.conf back to the way it was.

I found this page on the steam forums: Steam DNS issues resolved (for me) :: Steam for Linux General Discussions which seems to suggest that installing nscd could fix the issue, but nscd was removed in glibc 2.38 according to the Arch wiki, which still leaves me in a bit of a pickle.

Apparently, this entire time I had neglected to toggle a setting in Steam. In particular this one that says “Enable Steam Play for all other titles”:

The crazy thing is that I thought that I had enabled it earlier. I have a theory that it had something to do with the fact that I had enabled it on Steam Native and I was trying to run my games on Steam Runtime. Or I could just be loopy. In any case, problem solved.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.