Sta3_uprising Mod for Sins of a Solar Empire: Rebellion crashes after 7 minutes of game time

OS: Garuda Linux Kernel: 5.16.9-zen1-1-zen Uptime: 13 hours, 30 mins
Packages: 1790 (pacman) Shell: bash DE: Plasma 5.24.1 WM: KWin
CPU: AMD Ryzen 9 5950X (32) @ 3.4GHz GPU: NVIDIA GeForce RTX 3090
Memory: 7.57GiB / 62.77GiB

Recently I installed Garuda Linux, in general, I am very impressed with it. Most of my Pc games work in this operating system, mods for games is another story. Take for example Sins of Solar Empire Rebellion, base game works excellent, Sta3_uprising mod for the game runs fine for five minutes and 40 seconds and then exits out to the desktop. A lot of kudos to the people who work on wine, Proton, Proton Ge, maybe with the Steam deck Linux will be more mainstream. I am not too concerned about getting this issue fixed because this mod works fine in Windows.

Things I tried, the non-modded version of the game works fine with various Proton and Proton GE versions, and no launch line options are necessary. Modded with no launch line options using different various Proton and Proton Ge version game crashes between 5.4 minutes to 8 minutes of game time. I tried to use PROTON_FORCE_LARGE_ADDRESS_AWARE %command% in the launch line, this didn’t work. The most stable version I found is Proton-6.5-GE-1 and launch line PROTON_USE_WINED3D=1 %command% game looks up between 1 hour and 4 hours of game time and usually proceeds by missing graphics in tech tree research options. The newer version of Proton and Proton with launch line PROTON_USE_WINED3D=1 %command% looks up in about 9 minutes of game time.

Welcome

Can you provide your

garuda-inxi

3 Likes

https://www.protondb.com/app/204880

Looks like its a known issue with that mod. (looks like other mods don't work great even with using PROTON_USE_WINED3D=1 %command% )

4 Likes

System:
Kernel: 5.16.9-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=bb080f9e-5f75-434f-9977-192be882d22e rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=de476516-9f92-4ea5-9926-36239bbfb1a0 loglevel=3
Desktop: KDE Plasma 5.24.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: ROG CROSSHAIR VIII DARK HERO v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 3601
date: 05/26/2021
CPU:
Info: model: AMD Ryzen 9 5950X bits: 64 type: MT MCP arch: Zen 3
family: 0x19 (25) model-id: 0x21 (33) stepping: 0 microcode: 0xA201016
Topology: cpus: 1x cores: 16 tpc: 2 threads: 32 smt: enabled cache:
L1: 1024 KiB desc: d-16x32 KiB; i-16x32 KiB L2: 8 MiB desc: 16x512 KiB
L3: 64 MiB desc: 2x32 MiB
Speed (MHz): avg: 3653 high: 4054 min/max: 2200/5083 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3597 2: 3599
3: 3597 4: 3594 5: 3598 6: 3600 7: 3598 8: 3599 9: 3767 10: 3619 11: 3637
12: 3624 13: 3776 14: 3627 15: 4054 16: 3717 17: 3599 18: 3600 19: 3590
20: 3597 21: 3594 22: 3598 23: 3597 24: 3598 25: 3592 26: 3744 27: 3765
28: 3727 29: 3638 30: 3649 31: 3733 32: 3699 bogomips: 217615
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
IBRS_FW, STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GA102 [GeForce RTX 3090] vendor: ZOTAC driver: nvidia
v: 510.54 alternate: nouveau,nvidia_drm bus-ID: 0b:00.0 chip-ID: 10de:2204
class-ID: 0300
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 4480x1440 s-dpi: 92 s-size: 1237x393mm (48.7x15.5")
s-diag: 1298mm (51.1")
Monitor-1: DP-2 res: 1920x1080 dpi: 92 size: 531x298mm (20.9x11.7")
diag: 609mm (24")
Monitor-2: DP-4 res: 2560x1440 dpi: 93 size: 697x392mm (27.4x15.4")
diag: 800mm (31.5")
OpenGL: renderer: NVIDIA GeForce RTX 3090/PCIe/SSE2
v: 4.6.0 NVIDIA 510.54 direct render: Yes
Audio:
Device-1: NVIDIA GA102 High Definition Audio vendor: ZOTAC
driver: snd_hda_intel v: kernel bus-ID: 0b:00.1 chip-ID: 10de:1aef
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 0d:00.4 chip-ID: 1022:1487
class-ID: 0403
Sound Server-1: ALSA v: k5.16.9-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.45 running: yes
Network:
Device-1: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
port: e000 bus-ID: 05:00.0 chip-ID: 10ec:8125 class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb
v: kernel port: d000 bus-ID: 06:00.0 chip-ID: 8086:1539 class-ID: 0200
IF: enp6s0 state: down mac: <filter>
Device-3: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 07:00.0
chip-ID: 8086:2723 class-ID: 0280
IF: wlp7s0 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-6:3 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 20.94 TiB used: 1.48 TiB (7.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Sabrent model: Rocket 4.0 2TB
size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 type: SSD serial: <filter> rev: RKT401.2 temp: 43.9 C
scheme: MBR
ID-2: /dev/nvme1n1 maj-min: 259:2 vendor: Sabrent model: Rocket 4.0 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B
speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter> rev: RKT401.3
temp: 40.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: SanDisk model: SD8SB8U1T001122
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 0000 scheme: GPT
ID-4: /dev/sdb maj-min: 8:16 vendor: SanDisk model: SSD PLUS 2000GB
size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 04RL scheme: GPT
ID-5: /dev/sdc maj-min: 8:32 vendor: Western Digital
model: WD10EZEX-22MFCA0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
rev: 1A01 scheme: GPT
ID-6: /dev/sdd maj-min: 8:48 type: USB vendor: Seagate
model: ST16000NM001G-2KK103 size: 14.55 TiB block-size: physical: 4096 B
logical: 512 B type: HDD rpm: 7200 serial: <filter> scheme: GPT
Partition:
ID-1: / raw-size: 1.75 TiB size: 1.75 TiB (100.00%)
used: 719.04 GiB (40.1%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 1.75 TiB size: 1.75 TiB (100.00%)
used: 719.04 GiB (40.1%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-4: /var/log raw-size: 1.75 TiB size: 1.75 TiB (100.00%)
used: 719.04 GiB (40.1%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
ID-5: /var/tmp raw-size: 1.75 TiB size: 1.75 TiB (100.00%)
used: 719.04 GiB (40.1%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 62.77 GiB used: 5 MiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 69.05 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sdb3 maj-min: 8:19
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 30 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
Processes: 557 Uptime: 2h 36m wakeups: 0 Memory: 62.77 GiB
used: 8.42 GiB (13.4%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: pacman: 1790 lib: 507 Shell: garuda-inxi
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.12
Garuda (2.5.4-2):
System install date:     2022-02-16
Last full system update: 2022-02-16
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

this looked like it worked, thanks