Spotify has stopped working after updating earlier this week


Kernel: 6.2.11-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c21661a4-ab5c-4d08-9fe1-bf19290e339b rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=c0edd778-9e64-4946-9bb0-e8701323a791 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: TUF GAMING B550-PLUS v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 2006
date: 03/20/2021
ID-1: hidpp_battery_0 charge: 96% condition: N/A volts: 4.1 min: N/A
model: Logitech G502 LIGHTSPEED Wireless Gaming Mouse type: N/A
serial: <filter> status: discharging
Info: model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
model-id: 0x21 (33) stepping: 0 microcode: 0xA201009
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 4198 high: 4203 min/max: 2200/5533 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 4200 2: 4200
3: 4199 4: 4200 5: 4203 6: 4197 7: 4195 8: 4196 9: 4200 10: 4197 11: 4196
12: 4199 bogomips: 100799
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M/6850M XT]
vendor: Micro-Star MSI driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: DP-1,DP-2 empty: DP-3,HDMI-A-1 bus-ID: 0a:00.0
chip-ID: 1002:73df class-ID: 0300
Device-2: Jieli USB PHY 2.0 type: USB driver: snd-usb-audio,uvcvideo
bus-ID: 1-9:7 chip-ID: 1224:2a25 class-ID: 0102
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1185x381mm (46.65x15.00")
s-diag: 1245mm (49.01")
Monitor-1: DP-1 mapped: DisplayPort-0 pos: primary,top-right
model: Acer VG271U serial: <filter> built: 2021 res: 2560x1440 dpi: 109
gamma: 1.2 size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9
modes: max: 2560x1440 min: 720x400
Monitor-2: DP-2 mapped: DisplayPort-1 pos: bottom-l
model: Idek Iiyama PL2530H serial: <filter> built: 2018 res: 1920x1080
dpi: 90 gamma: 1.2 size: 544x303mm (21.42x11.93") diag: 623mm (24.5")
ratio: 16:9 modes: max: 1920x1080 min: 720x400
API: OpenGL v: 4.6 Mesa 23.0.2 renderer: AMD Radeon RX 6700 XT (navi22
LLVM 15.0.7 DRM 3.49 6.2.11-zen1-1-zen) direct-render: Yes
Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
bus-ID: 1-9:7 gen: 4 chip-ID: 1224:2a25 speed: 16 GT/s class-ID: 0102
lanes: 16 bus-ID: 0a:00.1 chip-ID: 1002:ab28 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0c:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Jieli USB PHY 2.0 type: USB driver: snd-usb-audio,uvcvideo
Device-4: Focusrite-Novation Scarlett 4i4 USB type: USB
driver: snd-usb-audio bus-ID: 3-1:2 chip-ID: 1235:8212 class-ID: 0103
serial: <filter>
API: ALSA v: k6.2.11-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.69 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: f000 bus-ID: 07:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Local Storage: total: 3.41 TiB used: 841.11 GiB (24.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 250GB
size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 type: SSD serial: <filter> rev: 2B2QGXA7 temp: 38.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: Samsung model: SSD 970 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 type: SSD serial: <filter> rev: 2B2QEXE7 temp: 35.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 2B6Q scheme: GPT
ID-4: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST2000DM008-2UB102
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: 0001 scheme: GPT
ID-1: / raw-size: 208.59 GiB size: 208.59 GiB (100.00%)
used: 34.22 GiB (16.4%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 806.88 GiB (86.6%) fs: btrfs dev: /dev/nvme1n1p1 maj-min: 259:5
ID-4: /var/log raw-size: 208.59 GiB size: 208.59 GiB (100.00%)
used: 34.22 GiB (16.4%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
ID-5: /var/tmp raw-size: 208.59 GiB size: 208.59 GiB (100.00%)
used: 34.22 GiB (16.4%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 24 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: swap-2 type: zram size: 15.52 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 36.1 C mobo: N/A gpu: amdgpu temp: 55.0 C
mem: 52.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Processes: 381 Uptime: 59m wakeups: 8 Memory: 15.52 GiB
used: 5.06 GiB (32.6%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1498
libs: 442 tools: octopi,paru Shell: fish v: 3.6.1 running-in: konsole
inxi: 3.3.26
Garuda (2.6.16-1):
System install date:     2023-01-06
Last full system update: 2023-04-20 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       No/Undetected
Failed units:

A few days ago (maybe Monday), I've updated my system, and after rebooting the next day, Spotify (from chaotic-aur rep) has stopped working. When starting it in the console, I'm getting the following output:

spotify: /usr/lib/ no version information available (required by spotify)
/opt/spotify/spotify: /usr/lib/ no version information available (required by /opt/spotify/spotify)
/opt/spotify/spotify: /usr/lib/ no version information available (required by /opt/spotify/spotify)
[libprotobuf ERROR /var/lib/spotify/buildagent/teamcity/work/dci-wd/web-platform/client-web/desktop/shell/core/vendor/protobuf3/src/google/protobuf/] String field 'spotify.event_sender.proto.DroppedEvents.DroppedEventsBySequenceIdEntry.key' contains invalid UTF-8 data when parsing a protocol buffer. Use the 'bytes' type if you intend to send raw bytes.
libc++abi: terminating with uncaught exception of type std::invalid_argument: stoul: no conversion
fish: Job 1, 'spotify' terminated by signal SIGABRT (Abort)

Since Arch (and derivatives) are rolling distros, I've assumed that this was one of the quirks, and a fix would come within a few hours, a day at most. But nope.

I've been using the cloud version of Spotify in the meantime, but that is simply sub optimal. So today I've started looking for a fix. I've been stuck on the libcurl-gnutls errors for some time, but I've found out that it's an old issue, and probably a red herring as someone somewhere has suggested. I couldn't find anything related with a query based on the libprotobuf error. And the C++ stuff only returned a result with a post on Spotify's forum, made a week ago by a Debian user with a similar (if not the same problem). Unfortunately no one (but me) has replied there yet.

So I've come to the conclusion that this isn't a "that update" issue, but rather a "that update + my config" issue (if that makes sense). So a future update solving this is unlikely (I think). And I myself am a mere C# programmer that uses linux daily for about a year, and my understanding of this beautiful system is yet underwhelming. So I've come here for help.

Hi there, welcome to the forum.
Maybe try building it yourself with a helper:

paru spotify

See also:

Disregard. You'll probably encounter the same problems in the latest AUR comment:
and in-fact it was flagged out-of-date:

Maybe the reason could be that there is a new version upstream?
Checking into the source section of the PKGBUILD, I see that now it should point instead to:
released yesterday.
But this sounds very very unlikely to me...


ncspot is working well. :grin:

1 Like

Snap has a newer version of Spotify "", which works. Not sure if it is because of the version itself, or just that Snap does things differently or something, but anyway.

Today I've looked for some solutions, but couldn't find anything, so I've asked ChatGPT. He came up with stuff I already did, like reinstalling the packages and dependencies. But after 2 prompts of "any more ideas", he came up with something bizarre. He said to uninstall Spotify from pacman, install yay (from RHEL distro's), and try with that pac-man...

I am not wondering whether this is possible, but just trying to figure out why anybody would want to do that. I mean, like if there is some software that's available "there" but not "here", which, 1: is unlikely; 2: there probably is some GitHub repo you can build it from manually, which would be faster, I think.

Anyway, this response reminded me of the existence of snap, which I am not very fond of, because I had lots of issues with it when starting out with linux, but tried it out anyway. And guess what, it worked!

You may be thinking of yum, the precursor to dnf ("dandified yum").

yay is a popular AUR helper. In addition to handling AUR package management, yay can be used for Pacman package management as well. In this case, it was a perfectly reasonable suggestion.

Garuda Linux includes paru by default, which is a rewrite of yay (written in Rust instead of Go). So no need to install yay--in fact, by default yay is aliased to paru.

Although sickeningly bloated, one advantage of Snaps is they have all of their dependencies, libraries, etc right in the sandbox with them so they are reasonably reliable and a bit less prone to breaking on the back of an update. Flatpak has this advantage as well.

You can always circle back and test the "normal" app in a week or two to see if it gets fixed, then remove the Snap infrastructure if it is no longer needed.