Specific wifi network not working

I am a newbie and i recently (3 to4 day) installed garuda ,while installation i connected to my university wifi which was working perfectly fine.
After finish and updating, the university wifi got disconnected, but when i connect to my hotspot it is connecting fine , it is also working under usb tethering .

the wifi is not connecting specifically to the university wifi after the update

can somebody please tell me why is this problem occuring.


**Kernel**: 6.4.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=91af0b39-ea8c-4c70-88e6-bf47795d06a8 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3

**Desktop**: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Dell product: Vostro 3400 v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Dell model: 0GGCMJ v: A01 serial: <superuser required> UEFI: Dell
v: 1.19.0 date: 09/06/2022
ID-1: BAT0 charge: 23.1 Wh (70.0%) condition: 33.0/42.0 Wh (78.6%)
volts: 11.5 min: 11.4 model: BYD DELL 1VX1H14 type: Li-poly serial: <filter>
status: discharging
Info: model: 11th Gen Intel Core i5-1135G7 bits: 64 type: MT MCP
arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
process: Intel 10nm family: 6 model-id: 0x8C (140) stepping: 1
microcode: 0xAA
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB L3: 8 MiB
desc: 1x8 MiB
Speed (MHz): avg: 1452 high: 2400 min/max: 400/4200 scaling:
driver: intel_pstate governor: powersave cores: 1: 2400 2: 1200 3: 1206
4: 1116 5: 1086 6: 2400 7: 1200 8: 1015 bogomips: 38707
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Dell
driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 0000:00:02.0
chip-ID: 8086:9a49 class-ID: 0300
Device-2: Microdia Integrated_Webcam_HD driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-6:2 chip-ID: 0c45:671e
class-ID: 0e02
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: AU Optronics 0x453d built: 2018 res: 1920x1080
hz: 60 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
ratio: 16:9 modes: 1920x1080
API: OpenGL v: 4.6 Mesa 23.1.4 renderer: Mesa Intel Xe Graphics (TGL GT2)
direct-render: Yes
Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Dell
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
bus-ID: 0000:00:1f.3 chip-ID: 8086:a0c8 class-ID: 0403
API: ALSA v: k6.4.6-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.75 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 0000:00:14.3
chip-ID: 8086:a0f0 class-ID: 0280
IF: wlp0s20f3 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Dell driver: r8169 v: kernel port: 3000 bus-ID: 0000:01:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp1s0 state: down mac: <filter>
IF-ID-1: enp0s20f0u2 state: unknown speed: -1 duplex: half mac: <filter>
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) driver: btusb
v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:3
chip-ID: 8087:0aaa class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Device-2: Samsung Galaxy series misc. (tethering mode) driver: rndis_host
v: kernel type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0
bus-ID: 1-2:11 chip-ID: 04e8:6863 class-ID: 0a00 serial: <filter>
Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev: class-ID: 0104
Local Storage: total: 1.14 TiB used: 21.95 GiB (1.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: KDI model: OM3PDP3-AD NVMe 256GB
size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 10100002 temp: 47.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ04ABF100
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 5400 serial: <filter> fw-rev: 02 scheme: GPT
ID-1: / raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
used: 21.95 GiB (9.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 732 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
used: 21.95 GiB (9.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
used: 21.95 GiB (9.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
used: 21.95 GiB (9.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.49 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 58.0 C mobo: 49.0 C
Fan Speeds (RPM): cpu: 3013
Processes: 285 Uptime: 1h 3m wakeups: 3848 Memory: total: 8 GiB note: est.
available: 7.49 GiB used: 4.29 GiB (57.2%) Init: systemd v: 253
default: graphical tool: systemctl Compilers: gcc: 13.1.1 Packages:
pm: pacman pkgs: 1861 libs: 551 tools: octopi,pamac,paru Shell: fish
v: 3.6.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.28

Please, follow the template and post garuda-inxi.
And reboot or update.

  Kernel: 6.4.7-zen1-2-zen

Does your university by any chance make use of the eduroam roaming service?
I guess not, otherwise it shouldn't have worked before, but just in case it does, look here:


No, my University does not use eduroam.
i tried rfkill it showed me unblocked.
another thing i forgot to add was that after typing the password it will try to reconnect and again ask for password in a pop up.[Also my friend use manjaro for him also it the same before update it was working fine after the update he also has the same problem like me ].
Could you kindly assist me? I'm more than willing to provide any necessary information.

Try restoring a snapshot from before the update to confirm it is an issue related to this update.

Try also installing the LTS kernel, which is on a different kernel release and will have a different version of drivers for your network card.


I created a snapshot named " before update"
After the update the wifi problem started ,so when i rolled back to "before update " the wifi was working fine

The most likely culprit for the network breaking on an update would be the kernel. A couple very simple things you can do off the top of my head:

  1. Stick with the system that has been restored, and hold off on taking an update for a couple weeks. As long as you don't need to install any new packages in the meanwhile, there is nothing wrong with putting off your update for two or three weeks. After the kernel has been updated, check again to see if the issue has been resolved.

  2. Try your luck with the LTS kernel, which runs a different kernel version and has different drivers, modules, etc built in to it. This may be a better option if you need to take down the update for any reason, including installing new packages.

To install the LTS kernel, first take the update:


Then install the kernel and headers:

sudo pacman -S linux-lts linux-lts-headers

When your system is booting up, you can select an alternate kernel from the advanced options in the Grub menu.


I download the LTS kernal, but still the wifi is not connecting.

So i should roll-back to "before-update" and wait till 3 or 4 weeks

Just downloading the kernel is not enough--you need to reboot, and specifically boot with the LTS kernel by selecting it in the advanced boot options in the Grub menu.

If you update and boot with the LTS kernel and it doesn't work, it's possible another package (besides the kernel) is to blame. :thinking:


In the above message i downloaded and rebooted into lts.

The following command will output a list of packages that were updated on your system recently that can affect networking:

cat /var/log/pacman.log | grep -i "d systemd (\|ed linux\|mware\|twork\|dkms ins\|a-nm\|nm-c\|ufw\|dhc\|dns\|wpa\|vnc\|ifplugd\|regdb" | grep -v "head\|nvidia"  | tail -n 30

Please post the output returned.

You could try systemically downgrading each package on the list to determine which package upgrade was responsible for your network breakage.


[2023-08-07T23:42:14+0530] [ALPM-SCRIPTLET] networkmanager-qt 5.105.0-1
[2023-08-07T23:42:14+0530] [ALPM-SCRIPTLET] networkmanager-strongswan 1.6.0-1
[2023-08-07T23:42:14+0530] [ALPM-SCRIPTLET] networkmanager-support 1-6
[2023-08-07T23:42:14+0530] [ALPM-SCRIPTLET] networkmanager-vpnc 1.2.8-3
[2023-08-07T23:42:14+0530] [ALPM-SCRIPTLET] nm-cloud-setup 1.42.6-1
[2023-08-07T23:42:14+0530] [ALPM-SCRIPTLET] nss-mdns 0.15.1-1
[2023-08-07T23:42:14+0530] [ALPM-SCRIPTLET] plasma-nm 5.27.4-1
[2023-08-07T23:42:14+0530] [ALPM-SCRIPTLET] qemu-system-x86-firmware 8.0.0-1
[2023-08-07T23:42:14+0530] [ALPM-SCRIPTLET] sof-firmware 2.2.4-1
[2023-08-07T23:42:14+0530] [ALPM-SCRIPTLET] wireless-regdb 2023.02.13-1
[2023-08-07T23:42:14+0530] [ALPM-SCRIPTLET] wpa_supplicant 2:2.10-8
[2023-08-08T20:54:20+0530] [ALPM] upgraded systemd (253.3-3 -> 254-1)
[2023-08-08T20:54:22+0530] [ALPM] upgraded glib-networking (1:2.76.0-1 -> 1:2.76.1-1)
[2023-08-08T20:54:27+0530] [ALPM] upgraded kdnssd (5.105.0-1 -> 5.108.0-1)
[2023-08-08T20:54:48+0530] [ALPM] upgraded lib32-glib-networking (2.76.0-1 -> 2.76.1-1)
[2023-08-08T20:54:50+0530] [ALPM] upgraded linux-firmware-whence (20230404.2e92a49f-1 -> 20230625.ee91452d-5)
[2023-08-08T20:54:51+0530] [ALPM] upgraded linux-firmware (20230404.2e92a49f-1 -> 20230625.ee91452d-5)
[2023-08-08T20:54:51+0530] [ALPM] upgraded linux-wifi-hotspot (4.4.0-1.1 -> 4.5.0-1)
[2023-08-08T20:54:52+0530] [ALPM] upgraded linux-zen (6.2.13.zen1-1 -> 6.4.8.zen1-1)
[2023-08-08T20:54:56+0530] [ALPM] upgraded networkmanager-openconnect (1.2.8-2 -> 1.2.10-1)
[2023-08-08T20:54:56+0530] [ALPM] upgraded networkmanager-openvpn (1.10.2-1 -> 1.10.2-3)
[2023-08-08T20:54:56+0530] [ALPM] upgraded networkmanager-qt (5.105.0-1 -> 5.108.0-1)
[2023-08-08T20:55:04+0530] [ALPM] upgraded plasma-nm (5.27.4-1 -> 5.27.7-1)
[2023-08-08T20:55:08+0530] [ALPM] upgraded qemu-system-x86-firmware (8.0.0-1 -> 8.0.3-1)
[2023-08-08T20:55:11+0530] [ALPM] upgraded sof-firmware (2.2.4-1 -> 2.2.6-1)
[2023-08-08T20:55:13+0530] [ALPM] upgraded wireless-regdb (2023.02.13-1 -> 2023.05.03-1)
[2023-08-08T20:55:44+0530] [ALPM-SCRIPTLET] Adding boot menu entry for UEFI Firmware Settings ...
[2023-08-08T20:55:45+0530] [ALPM-SCRIPTLET] Adding boot menu entry for UEFI Firmware Settings ...
[2023-08-08T20:57:09+0530] [ALPM] installed linux-lts (6.1.43-1)
[2023-08-08T20:57:30+0530] [ALPM-SCRIPTLET] Adding boot menu entry for UEFI Firmware Settin

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.