Speakers not playing audio until I select "play all audio via this device"

I have been facing this issue since I installed garuda. If I play video on any application like browser or media player, it will run, but I am not able to hear the audio.

The only way to hear the audio is to click "play all audio using this device" in the audio devices section on the option "line out"

Once I pause the video for like 5 seconds, then I'll have to do it again to hear the audio

Essentially, I am tired of navigating and clicking that button every minute to hear some audio.

System:
Kernel: 5.19.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=64a567bd-23f6-43f2-bc2f-c579c56d78de rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Gigabyte product: A320M-H v: N/A
serial: <superuser required>
Mobo: Gigabyte model: A320M-H-CF v: x.x serial: <superuser required>
UEFI: American Megatrends v: F50 date: 11/28/2019
CPU:
Info: model: AMD Ryzen 3 3200G with Radeon Vega Graphics bits: 64 type: MCP
arch: Zen/Zen+ note: check gen: 1 built: 2019 process: GF 12nm
family: 0x17 (23) model-id: 0x18 (24) stepping: 1 microcode: 0x8108109
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 384 KiB
desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
desc: 1x4 MiB
Speed (MHz): avg: 1610 high: 2293 min/max: 1400/3600 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1253 2: 1494
3: 2293 4: 1400 bogomips: 28746
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT disabled
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
disabled, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GK208B [GeForce GT 710] vendor: ZOTAC driver: nouveau
v: kernel non-free: series: 470.xx+ status: legacy-active (EOL~2023/24)
arch: Fermi 2 code: GF119/GK208 process: TSMC 28nm built: 2010-16 pcie:
gen: 2 speed: 5 GT/s lanes: 8 ports: active: HDMI-A-1
empty: DVI-D-1,VGA-1 bus-ID: 01:00.0 chip-ID: 10de:128b class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: nouveau unloaded: modesetting
alternate: fbdev,nv,vesa gpu: nouveau display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: HDMI-A-1 mapped: HDMI-1 model: Dell D1918H serial: <filter>
built: 2020 res: 1366x768 hz: 60 dpi: 85 gamma: 1.2
size: 410x230mm (16.14x9.06") diag: 470mm (18.5") ratio: 16:9 modes:
max: 1366x768 min: 720x400
OpenGL: renderer: NV106 v: 4.3 Mesa 22.1.6 direct render: Yes
Audio:
Device-1: NVIDIA GK208 HDMI/DP Audio vendor: ZOTAC driver: snd_hda_intel
v: kernel bus-ID: 1-5:3 pcie: chip-ID: 31b2:0011 class-ID: 0300 gen: 2
serial: <filter> speed: 5 GT/s lanes: 8 bus-ID: 01:00.1
chip-ID: 10de:0e0f class-ID: 0403
Device-2: AMD Family 17h/19h HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 08:00.6 chip-ID: 1022:15e3 class-ID: 0403
Device-3: DCMT USB Condenser Microphone type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound Server-1: ALSA v: k5.19.2-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: e000 bus-ID: 07:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp7s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 931.51 GiB used: 46.53 GiB (5.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10EZEX-22MFCA0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
rev: 1A01 scheme: GPT
Partition:
ID-1: / raw-size: 243.89 GiB size: 243.89 GiB (100.00%) used: 46.5 GiB
(19.1%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
ID-2: /boot/efi raw-size: 99 MiB size: 95 MiB (95.96%) used: 27.6 MiB
(29.1%) fs: vfat dev: /dev/sda2 maj-min: 8:2
ID-3: /home raw-size: 243.89 GiB size: 243.89 GiB (100.00%) used: 46.5
GiB (19.1%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
ID-4: /var/log raw-size: 243.89 GiB size: 243.89 GiB (100.00%) used: 46.5
GiB (19.1%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
ID-5: /var/tmp raw-size: 243.89 GiB size: 243.89 GiB (100.00%) used: 46.5
GiB (19.1%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.7 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 39.5 C mobo: N/A gpu: nouveau temp: 38.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 233 Uptime: 3m wakeups: 0 Memory: 7.7 GiB used: 2.26 GiB (29.3%)
Init: systemd v: 251 default: graphical tool: systemctl Compilers:
gcc: 12.1.1 clang: 14.0.6 Packages: pacman: 1415 lib: 352 Shell: fish
v: 3.5.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.20
Garuda (2.6.6-1):
System install date:     2022-07-12
Last full system update: 2022-08-21
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service

I will not get tired after the template requested

garuda-inxi

to ask :slight_smile:


Hello Garuda users.

Please read the following template before requesting assistance:

Please post the terminal/konsole input and output as text (no pictures) from the the following command:

garuda-inxi

Refusing to post the output of the required "garuda-inxi" on a help request will likely result in you not receiving any help from the Garuda team. A failure to provide your system specs may also result in your thread being closed without notice, (as without this information providing assistance is often next to impossible).

Before opening a new help request, please search the Arch and Garuda Wiki's, and read any relevant sections related to your issue. Also, thoroughly search any error messages in the forum's search engine and on the web. For in depth information on how to search for answers to Linux issues effectively read the tips on the Garuda Wiki:

Please report in detail everything you have already attempted to solve your problem.

3 Likes

I have updated it. Sorry about that.

2 Likes

@ajmalmohad I had a similar issue a couple days ago with issues of sound not working on the internet. I personally used garuda assistant and clicked system componentts to change from pipewire to pulseaudio... or whatever sound app works for you. I hope this helps.

1 Like

Do you have EasyEffects installed and enabled? I had the exact same issue you did where no audio will play until I select "play all audio via this device".

I made an interesting discovery this morning where I thought to myself 'could it be that EasyEffects is causing issues again?'

So I disabled EasyEffects, all audio plays again as normal.

2 Likes

It appears something is going on with EasyEffects. Setting it as the default source has no effect on increasing/decreasing the volume any longer. This started a few days ago for me.

1 Like

This worked for me. Been having this issue since yesterday when I was playing around with KDE Connect.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.