Speakers/Audio not working?

So I recently downloaded Garuda Linux on my Laptop (Lenovo Flexpad 5i and it was originally on chrome OS), and the sounds doesn't work on my laptop's speakers. I've been playing around with the sound/audio options in the settings, but no luck. Tried both the output options. I'll leave images on the sound settings too since I have no idea on what to try next.

System:
Kernel: 5.19.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=de434a85-4453-4493-9058-01aaecdf53cc rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Console: pty pts/1 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Laptop System: Google product: Akemi v: rev4 serial: <filter>
Chassis: type: 9 serial: N/A
Mobo: Google model: Akemi v: rev4 serial: <filter> UEFI: coreboot
v: MrChromebox-4.14 date: 07/25/2021
Battery:
ID-1: BAT0 charge: 37.6 Wh (78.5%) condition: 47.9/51.1 Wh (93.6%)
volts: 8.4 min: 7.7 model: SMP L19M4PG type: Li-ion serial: <filter>
status: charging cycles: 33
CPU:
Info: model: Intel Core i5-10210U bits: 64 type: MT MCP
arch: Comet/Whiskey Lake note: check gen: core 10 built: 2018
process: Intel 14nm family: 6 model-id: 0x8E (142) stepping: 0xC (12)
microcode: 0xF0
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 1450 high: 2100 min/max: 400/4200 scaling:
driver: intel_pstate governor: powersave ext-clock: 100 MHz cores: 1: 800
2: 2100 3: 2100 4: 2100 5: 800 6: 800 7: 2100 8: 800 bogomips: 33599
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: Enhanced IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: SW sequence
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel CometLake-U GT2 [UHD Graphics] driver: i915 v: kernel
arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1
empty: DP-1,DP-2 bus-ID: 00:02.0 chip-ID: 8086:9b41 class-ID: 0300
Device-2: Acer Integrated Camera type: USB driver: uvcvideo bus-ID: 1-7:4
chip-ID: 5986:212e class-ID: 0e02
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: intel unloaded: modesetting
alternate: fbdev,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP1 model: InfoVision Optronics/Kunshan 0x8544
built: 2019 res: 1920x1080 hz: 60 dpi: 168 gamma: 1.2
size: 290x170mm (11.42x6.69") diag: 337mm (13.3") ratio: 16:9
modes: 1920x1080
OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 22.1.7
direct render: Yes
Audio:
Device-1: Intel Comet Lake PCH-LP cAVS driver: sof-audio-pci-intel-cnl
alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:02c8 class-ID: 0401
Sound Server-1: ALSA v: k5.19.4-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:02f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-10:5 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 119.24 GiB used: 15.91 GiB (13.3%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZALQ128HBHQ-000L2 size: 119.24 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: AL2QFXV7 temp: 31.9 C scheme: GPT
SMART: yes health: PASSED on: 32 hrs cycles: 144 read-units: 6,402,411
[3.27 TB] written-units: 7,611,348 [3.89 TB]
Partition:
ID-1: / raw-size: 118.95 GiB size: 118.95 GiB (100.00%) used: 15.91 GiB
(13.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 592 KiB
(0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 118.95 GiB size: 118.95 GiB (100.00%) used: 15.91
GiB (13.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-4: /var/log raw-size: 118.95 GiB size: 118.95 GiB (100.00%) used: 15.91
GiB (13.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-5: /var/tmp raw-size: 118.95 GiB size: 118.95 GiB (100.00%) used: 15.91
GiB (13.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.64 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 42.0 C pch: 42.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 283 Uptime: 11m wakeups: 336 Memory: 7.64 GiB used: 2.72 GiB
(35.6%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: 1658 pacman: 1653 lib: 384 flatpak: 5
Shell: garuda-inxi (sudo) default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.20
Garuda (2.6.6-1):
System install date:     2022-08-22
Last full system update: 2022-08-27
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            systemd-networkd-wait-online.service
1 Like

I had the same problem with my laptop the other day and I went to garuda assistant and changed from pipewire to pulse audio. I hope changing your sound app helps it worked for me.

1 Like

How did you do that?

1 Like

the exact way is clicking on garuda welcome and then cclicking garuda assistant and then clicking system components

Clicked it, tried again. I think I replaced pipewire with Pulse, can't tell. But still no dice :confused: .

if pulse audio doesnt work i would try the other sound supports there.

1 Like

Which ones should I try first and how do I do each one?