Source games say Limited Glyph support and errors with UTF-8 Locale

Hello im having a problem in source games on steam in garuda Linux, on launching it says limited glyph support and some Locale errors. sorry im new here so i dont know whats wrong with it but ive seen this in XFCE and KDE versions etc of Garuda.

Here is the error

SetLocale('en_US.UTF-8') failed and a few arguments sorry i cant post a ss because im a new user

here is my Output of my system from the garuda-inxi command

System:
Kernel: 5.16.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=f6683b10-19e4-4e59-813a-a15119acaca3 rw [email protected]
splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
mitigations=off
Desktop: KDE Plasma 5.24.0 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Dell product: Precision Tower 5810 v: N/A
serial: <filter> Chassis: type: 7 serial: <filter>
Mobo: Dell model: 0K240Y v: A01 serial: <filter> UEFI-[Legacy]: Dell
v: A34 date: 10/19/2020
CPU:
Info: model: Intel Xeon E5-1650 v3 socket: LGA2011-3 bits: 64 type: MT MCP
arch: Haswell family: 6 model-id: 0x3F (63) stepping: 2 microcode: 0x49
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 15 MiB desc: 1x15 MiB
Speed (MHz): avg: 2075 high: 3238 min/max: 1200/3800
base/boost: 3500/4000 scaling: driver: intel_cpufreq governor: performance
volts: 1.8 V ext-clock: 100 MHz cores: 1: 1590 2: 2253 3: 1496 4: 1796
5: 2047 6: 3063 7: 3017 8: 1592 9: 1744 10: 1279 11: 1794 12: 3238
bogomips: 83811
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: vulnerable
Type: mds status: Vulnerable; SMT vulnerable
Type: meltdown status: Vulnerable
Type: spec_store_bypass status: Vulnerable
Type: spectre_v1 status: Vulnerable: __user pointer sanitization and
usercopy barriers only; no swapgs barriers
Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GK104GL [Quadro K4200] driver: nvidia v: 470.103.01
alternate: nouveau,nvidia_drm bus-ID: 03:00.0 chip-ID: 10de:11b4
class-ID: 0300
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: nvidia unloaded: modesetting,nouveau alternate: fbdev,nv,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1680x1050 s-dpi: 90 s-size: 474x303mm (18.7x11.9")
s-diag: 563mm (22.1")
Monitor-1: DVI-I-1 res: 1680x1050 hz: 60 dpi: 98
size: 434x270mm (17.1x10.6") diag: 511mm (20.1")
OpenGL: renderer: Quadro K4200/PCIe/SSE2 v: 4.6.0 NVIDIA 470.103.01
direct render: Yes
Audio:
Device-1: Intel C610/X99 series HD Audio vendor: Dell driver: snd_hda_intel
v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8d20 class-ID: 0403
Device-2: NVIDIA GK104 HDMI Audio driver: snd_hda_intel v: kernel
bus-ID: 03:00.1 chip-ID: 10de:0e0a class-ID: 0403
Device-3: C-Media USB Audio Device type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-6:2 chip-ID: 0d8c:0012
class-ID: 0300
Sound Server-1: ALSA v: k5.16.8-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.45 running: yes
Network:
Device-1: Intel Ethernet I217-LM vendor: Dell driver: e1000e v: kernel
port: f020 bus-ID: 00:19.0 chip-ID: 8086:153a class-ID: 0200
IF: enp0s25 state: up speed: 100 Mbps duplex: full mac: <filter>
Device-2: Ralink RT5370 Wireless Adapter type: USB driver: rt2800usb
bus-ID: 3-7:3 chip-ID: 148f:5370 class-ID: 0000 serial: <filter>
IF: wlp0s20u7 state: down mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Drives:
Local Storage: total: 471.36 GiB used: 20.39 GiB (4.3%)
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 250GB
family: based SSDs size: 232.89 GiB block-size: physical: 512 B
logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: SSD serial: <filter>
rev: 2B6Q temp: 21 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 284d 12h cycles: 696
written: 8.43 TiB
ID-2: /dev/sdb maj-min: 8:16 vendor: SK Hynix model: SH920 2.5 7MM 256GB
size: 238.47 GiB block-size: physical: 512 B logical: 512 B sata: 3.1
speed: 6.0 Gb/s type: SSD serial: <filter> rev: CL00 temp: 24 C
scheme: MBR
SMART: yes state: enabled health: PASSED on: 252d 6h cycles: 740
read: 11.2 MiB written: 2.5 MiB
Partition:
ID-1: / raw-size: 238.47 GiB size: 238.47 GiB (100.00%)
used: 20.39 GiB (8.6%) fs: btrfs block-size: 4096 B dev: /dev/sdb1
maj-min: 8:17
ID-2: /home raw-size: 238.47 GiB size: 238.47 GiB (100.00%)
used: 20.39 GiB (8.6%) fs: btrfs block-size: 4096 B dev: /dev/sdb1
maj-min: 8:17
ID-3: /var/log raw-size: 238.47 GiB size: 238.47 GiB (100.00%)
used: 20.39 GiB (8.6%) fs: btrfs block-size: 4096 B dev: /dev/sdb1
maj-min: 8:17
ID-4: /var/tmp raw-size: 238.47 GiB size: 238.47 GiB (100.00%)
used: 20.39 GiB (8.6%) fs: btrfs block-size: 4096 B dev: /dev/sdb1
maj-min: 8:17
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.27 GiB used: 256 KiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 42.0 C mobo: N/A sodimm: SODIMM C gpu: nvidia
temp: 37 C
Fan Speeds (RPM): cpu: 1012 gpu: nvidia fan: 30%
Info:
Processes: 335 Uptime: 46m wakeups: 0 Memory: 31.27 GiB
used: 3.86 GiB (12.4%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.1 Packages: pacman: 1976 lib: 540 Shell: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.12
Garuda (2.5.4-2):
System install date:     2022-02-10
Last full system update: 2022-02-11
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            home-guest.mount bluetooth-autoconnect.service systemd-guest-user.service systemd-n
etworkd-wait-online.service

hopefully there is a fix thanks as i really like Garuda

It is not a KDE problem, did you search for the error in Web?

We use three ~ in first and last line from terminal output.

Welcome to the forum :slight_smile:

1 Like

Thanks glad to be here
i checked the error in the Web and some sites didnt cover it so i had to find crumbs of information about it i tried it but still in source games like Sven-Coop i get that error when i start the game but if i press ok game runs without errors and silky smooth but im concerned if its something with the localization because this isnt the first time 4 months ago i tried Garuda XFCE and it had the same issue in source games with that warning im coming from Manjaro in there i didnt had that error at all but it was a clunky distro and i really liked Garuda development and idea and thought id give it a try on it and my experience its satisfying till now so ill have to see more
anyways about the error i tried to generate locale see the conf file etc etc its either some bad configuration or i did not do the steps to fix it correctly

The ArchWiki has this about Locale:

https://wiki.archlinux.org/title/locale

And actually uses en_US.UTF-8 as the example.

It also seems inline for the fix about this for SteamOS and the same error in this YouTube video starting at 1:19:

While that is based on a different distro, the locale instructions should be the same. Also after editing and generating the locale don't forget to logout and/or reboot.

1 Like

Alright when i get home i would give it a try

Alright so i did those steps as well but found out in locale.gen there wasnt any writing of languages there so i just write it there the UTF8 and i did locale-gen with the output of:

Generating locales...
en_US.UTF-8... done
Generation complete.

when i do the command locale -a i get these:

C
en_US.utf8
POSIX

but after Reboot the problem still persists as showing a long error code for the LC locales and the failed statement maybe i need to dig more into it? any ideas as ive noticed this only on Garuda Linux. The os runs perfect its just this annoying error coming through in Source based games.

now i did some research and found a package named
"glibc-locales-2.33-1-x86_64.pkg.tar.tar"
It wasnt in the Pamac and i couldnt find it on any repositories anyways i downloaded the file and installed it via terminal everything went good in installation and after reboot i try the game and it just simply launches black screen for a mere millisecond and closes seems like its crashing but my other games which are not based on Source engine are not crashing at all only this looking into the problem again lets see what i find out as im new to this :smiley:

My locale.gen was all comments for available locales and then the Calamares installer entry for en_US.UTF-8. Your output looks correct for locale -a, or at least, what mine reports too. All indications are that it was accomplished, but as you pointed out the game still doesn't like it.

Just to make sure, what is in your locale.conf file now? It should look similar to this:

λ cat /etc/locale.conf 
LANG=en_US.UTF-8
LC_ADDRESS=en_US.UTF-8
LC_IDENTIFICATION=en_US.UTF-8
LC_MEASUREMENT=en_US.UTF-8
LC_MONETARY=en_US.UTF-8
LC_NAME=en_US.UTF-8
LC_NUMERIC=en_US.UTF-8
LC_PAPER=en_US.UTF-8
LC_TELEPHONE=en_US.UTF-8
LC_TIME=en_US.UTF-8

You can get that output either by doing cat /etc/locale.conf or locale, should be the same for both. This is just a confirmation, making sure locales are there.

Can't provide much input on glibc-locales file, though would caution going outside repos provided. Besides being unsupported, it can have disastrous effects on your install. Even when someone higher up the food chain suggests this you want to give them the side eye... :thinking:

hello this is my output

λ locale
LANG=C
LC_CTYPE=en_US.UTF-8
LC_NUMERIC=C
LC_TIME=C
LC_COLLATE=en_US.UTF-8
LC_MONETARY=C
LC_MESSAGES=en_US.UTF-8
LC_PAPER=en_US.UTF-8
LC_NAME=en_US.UTF-8
LC_ADDRESS=en_US.UTF-8
LC_TELEPHONE=en_US.UTF-8
LC_MEASUREMENT=C
LC_IDENTIFICATION=en_US.UTF-8
LC_ALL=

Maybe try to give a look at this one... looks similar.
I'm not a gamer, so cannot help much further, but I thought you could give it a try.

just for information other games runs fine this happends with the particular Sven Coop builded by Source games in valve