Sound not working on fresh install

KDE says sound is playing but I hear nothing. There's a clear issue with pipewire. I've seen forum posts on the arch forums mentioning this issue but nobody has any clear answers.

╭─[email protected] in ~ took 10s
╰─λ pipewire
[E][02905.331442] mod.protocol-native | [module-protocol-:  708 lock_socket()] server 0x555c31f322a0: unable to lock lockfile '/run/user/1000/pipewire-0.lock': Resource temporarily unavailable (maybe another daemon is running)          

[E][02905.331522] pw.conf      | [          conf.c:  560 load_module()] 0x555c31f180b0: could not load mandatory module "libpipewire-module-protocol-native": Resource temporarily unavailable                               
[E][02905.331568] default      | [      pipewire.c:  125 main()] failed to create context: Resource temporarily unavailable

╭─[email protected]osh in ~ took 4ms
[🔴] × systemctl status --user pipewire
● pipewire.service - PipeWire Multimedia Service
Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; vendor preset: enabled)
Active: active (running) since Wed 2022-06-01 13:07:04 CDT; 54min ago
TriggeredBy: ● pipewire.socket
Main PID: 2959 (pipewire)
Tasks: 2 (limit: 38350)
Memory: 23.3M
CPU: 1.608s
CGroup: /user.slice/user-1000.slice/[email protected]/session.slice/pipewire.service
└─2959 /usr/bin/pipewire

Jun 01 13:07:04 josh-pc systemd[2463]: Started PipeWire Multimedia Service.

╭─[email protected] in ~ took 5ms
╰─λ garuda-inxi
System:
Kernel: 5.18.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=2be657fe-74e9-4620-8025-fbda60febab1 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: ROG STRIX B460-H GAMING v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 1601
date: 11/27/2020
CPU:
Info: model: Intel Core i5-10600K bits: 64 type: MT MCP arch: Comet Lake
family: 6 model-id: 0xA5 (165) stepping: 5 microcode: 0xF0
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 4317 high: 4500 min/max: 800/4800 scaling:
driver: intel_pstate governor: powersave cores: 1: 4342 2: 4500 3: 3350
4: 4096 5: 4500 6: 4500 7: 4500 8: 4042 9: 4477 10: 4500 11: 4500
12: 4500 bogomips: 98397
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M]
vendor: ASUSTeK driver: amdgpu v: kernel pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: DP-2,DP-3,HDMI-A-1 empty: DP-1 bus-ID: 03:00.0
chip-ID: 1002:73df class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 7040x1534 s-dpi: 96 s-size: 1862x405mm (73.31x15.94")
s-diag: 1906mm (75.02")
Monitor-1: DP-2 mapped: DisplayPort-1 pos: primary,top-right
model: Dell S3219D serial: <filter> built: 2018 res: 2560x1440 hz: 60
dpi: 92 gamma: 1.2 size: 708x399mm (27.87x15.71") diag: 813mm (32")
ratio: 16:9 modes: max: 2560x1440 min: 720x400
Monitor-2: DP-3 mapped: DisplayPort-2 pos: bottom-l model: Dell S3219D
serial: <filter> built: 2018 res: 2560x1440 hz: 60 dpi: 92 gamma: 1.2
size: 708x399mm (27.87x15.71") diag: 813mm (32") ratio: 16:9 modes:
max: 2560x1440 min: 720x400
Monitor-3: HDMI-A-1 mapped: HDMI-A-0 pos: bottom-c model: VG278
serial: <filter> built: 2021 res: 1920x1080 dpi: 82 gamma: 1.2
size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
OpenGL: renderer: AMD Radeon RX 6700 XT (navy_flounder LLVM 13.0.1 DRM
3.46 5.18.1-zen1-1-zen)
v: 4.6 Mesa 22.1.0 direct render: Yes
Audio:
Device-1: Intel Comet Lake PCH-V cAVS vendor: ASUSTeK driver: snd_hda_intel
v: kernel alternate: snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:a3f0 class-ID: 0403
Device-2: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab28
class-ID: 0403
Device-3: SteelSeries ApS Arctis 5 type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-3:3 chip-ID: 1038:12aa
class-ID: 0300 serial: <filter>
Device-4: JMTek LLC. LCS USB Audio type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-4:6 chip-ID: 0c76:2018
class-ID: 0300 serial: <filter>
Sound Server-1: ALSA v: k5.18.1-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.0 running: no
Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
port: N/A bus-ID: 00:1f.6 chip-ID: 8086:0d55 class-ID: 0200
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
RAID:
Hardware-1: Intel Device driver: ahci v: 3.0 port: 4020 bus-ID: 00:17.0
chip-ID: 8086:a386 rev: class-ID: 0104
Drives:
Local Storage: total: 2.96 TiB used: 783.39 GiB (25.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WDS100T3X0C-00SJG0 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 111110WD temp: 40.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 840 PRO Series
size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 5B0Q scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD10EURX-63C57Y0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 1A01 scheme: MBR
ID-4: /dev/sdc maj-min: 8:32 type: USB vendor: Western Digital
model: WD My Passport 0741 size: 931.48 GiB block-size: physical: 512 B
logical: 512 B type: N/A serial: <filter> rev: 1022 scheme: GPT
Partition:
ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 26.64 GiB (2.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 26.64 GiB (2.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 26.64 GiB (2.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 26.64 GiB (2.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.26 GiB used: 4.5 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 27.8 C mobo: N/A gpu: amdgpu temp: 58.0 C
mem: 56.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:
Processes: 345 Uptime: 56m wakeups: 0 Memory: 31.26 GiB
used: 5.75 GiB (18.4%) Init: systemd v: 251 tool: systemctl Compilers:
gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1798 lib: 512 Shell: fish
v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.16
Garuda (2.6.3-2):
System install date:     2022-06-01
Last full system update: 2022-06-01 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service

First thing after install and update is reboot.

System install date:     2022-06-01
Last full system update: 2022-06-01 ↻
3 Likes

Didn't work. I had this same problem before the fresh install too hence why I wiped everything.

Did you search about the log errors in internet?

2 Likes

Yes all the answers basically said "I fudged around and eventually it worked". I've fudged around for like a day at this point before deciding to reinstall. Either that or they edited a config file that doesn't exist on my machine.

If pipewire is indicating that you are playing sound do you have it set to output to the correct device , i'e speakers/headphones front audio output rear audio / hdmi monitor?

3 Likes

It it outputting to my Steel series headset

have you tested the headset on another device to check your headphones are not at fault?
does the mic work?

3 Likes

Yes I did try headphones. The mic never worked at any point (even back on my Windows machine) but I don't use it.

It sounds like your hardware it needs to be replaced/headphones?
I think you may have answered your own question :smiley:

Oh sorry I meant other headphones didn't work as well. I never tried getting the mic to work on my main headset.

Ok from what you have described so far pipewire is showing that is displaying audio output?
I would suggest that it is then :smiley:
have you connected speaker to the audio output to check whether pipewire is at fault?
What have you tried to diagnosed that pipewire is at fault?

2 Likes

My laptop shows pretty much the exact same output on these, and my sound is working perfectly--both the native speakers and headphones. I wouldn't read into this too much; "pipewire" isn't really intended to provide useful output when run on the command line with no arguments.

When you connect headphones though a normal headphone jack, the computer assumes you want to play audio through them and typically sets it up for you. With a USB headset, this is not necessarily so; you may have to implicitly say you want them to play audio.

What software is telling you this? Also, what software is playing your media?

If you want to confirm your suspicion that PipeWire is the source of your problem, open up Garuda Assistant, switch to Pulse for your audio server, and take a reboot.

3 Likes

is there a guide on how to do this? Both my headsets aren't working on Popos either so I think I just got really unlucky with my hardware.

KDE's audio manager on the default panel.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.