Sound issue on my new garuda installation

Hello! I am new to Garuda and arch distro in general and i really like the design of garuda so decided to switch from ubuntu. I solved most of my problems except the sound which i dont seem to figure out by myself and would appreciate some help!
Basically, no matter what configurations i try, or switching to pulse audio or alsa, it just doesn't seem to work. Should i give up?
I already checked almost all the previous sound issue post but none of them seem to help. I kind of broke it once when i installed pulse audio and there was a conflict and then i couldn't play any video or audio on browser so i re-installed. This time i installed alsa-support and tried to mess around in the audio settings itself but nothing seems to work. Hopefully you guys have a solution.

[email protected] in /etc/modprobe.d🔒 took 6m32s
╰─λ garuda-inxi
System:
Kernel: 6.2.11-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=7d0bbbac-f023-4e98-9b3f-d4a33ee38a61 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: ASUSTeK product: Zenbook UM5302TA_UM5302TA v: 1.0
serial: <superuser required>
Mobo: ASUSTeK model: UM5302TA v: 1.0 serial: <superuser required>
UEFI: American Megatrends LLC. v: UM5302TA.309 date: 07/19/2022
Battery:
ID-1: BATT charge: 57.7 Wh (99.1%) condition: 58.2/67.1 Wh (86.8%)
volts: 15.9 min: 15.9 model: ASUSTeK UM5302 type: Li-ion serial: <filter>
status: discharging cycles: 116
Device-1: hid-0018:04F3:2F2B.0002-battery model: ELAN9008:00 04F3:2F2B
serial: N/A charge: N/A status: N/A
CPU:
Info: model: AMD Ryzen 5 6600U with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 3+ gen: 4 level: v3 note: check built: 2022 process: TSMC n6 (7nm)
family: 0x19 (25) model-id: 0x44 (68) stepping: 1 microcode: 0xA404101
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 2160 high: 3844 min/max: 1600/4582 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 1397 2: 3844
3: 1387 4: 2422 5: 1367 6: 2900 7: 1907 8: 2900 9: 1395 10: 2900 11: 1476
12: 2029 bogomips: 69467
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Rembrandt [Radeon 680M] vendor: ASUSTeK driver: amdgpu
v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22
pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: eDP-1 empty: DP-1,
DP-2, DP-3, DP-4, DP-5, DP-6, DP-7 bus-ID: 03:00.0 chip-ID: 1002:1681
class-ID: 0300 temp: 52.0 C
Device-2: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
bus-ID: 5-1:2 chip-ID: 13d3:5463 class-ID: fe01 serial: <filter>
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 2880x1800 s-dpi: 96 s-size: 762x476mm (30.00x18.74")
s-diag: 898mm (35.37")
Monitor-1: eDP-1 mapped: eDP model: Samsung 0x4172 built: 2021
res: 2880x1800 hz: 60 dpi: 253 gamma: 1.2 size: 289x186mm (11.38x7.32")
diag: 344mm (13.5") ratio: 16:10 modes: max: 2880x1800 min: 640x480
API: OpenGL v: 4.6 Mesa 23.0.2 renderer: AMD Radeon Graphics (rembrandt
LLVM 15.0.7 DRM 3.49 6.2.11-zen1-1-zen) direct-render: Yes
Audio:
Device-1: AMD Rembrandt Radeon High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 03:00.1 chip-ID: 1002:1640 class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: ASUSTeK
driver: snd_pci_acp6x v: kernel alternate: snd_pci_acp3x, snd_rn_pci_acp3x,
snd_pci_acp5x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
snd_sof_amd_renoir, snd_sof_amd_rembrandt pcie: gen: 4 speed: 16 GT/s
lanes: 16 bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.2.11-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: alsamixer,amixer
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 0.3.69 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
vendor: Foxconn driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
lanes: 1 bus-ID: 01:00.0 chip-ID: 14c3:0616 class-ID: 0280
IF: wlp1s0 state: up mac: <filter>
Bluetooth:
Device-1: Foxconn / Hon Hai Wireless_Device type: USB driver: btusb v: 0.8
bus-ID: 3-3:2 chip-ID: 0489:e0e2 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 476.94 GiB used: 14.79 GiB (3.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: 3400 MTFDKBA512TFH
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 type: SSD serial: <filter> rev: P7MA002 temp: 40.9 C scheme: GPT
Partition:
ID-1: / raw-size: 200.48 GiB size: 200.48 GiB (100.00%)
used: 14.76 GiB (7.4%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
used: 30 MiB (11.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 200.48 GiB size: 200.48 GiB (100.00%)
used: 14.76 GiB (7.4%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
ID-4: /var/log raw-size: 200.48 GiB size: 200.48 GiB (100.00%)
used: 14.76 GiB (7.4%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
ID-5: /var/tmp raw-size: 200.48 GiB size: 200.48 GiB (100.00%)
used: 14.76 GiB (7.4%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 13.8 GiB used: 1024 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 53.2 C mobo: N/A gpu: amdgpu temp: 49.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 314 Uptime: 28m wakeups: 61875 Memory: 13.8 GiB
used: 4.75 GiB (34.4%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1822
libs: 523 tools: octopi,pamac,paru Shell: fish v: 3.6.1 default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.26
Garuda (2.6.16-1):
System install date:     2023-04-19
Last full system update: 2023-04-19
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Thanks in advance!

Seems an asus problem

1 Like

You need to update your BIOS to make that laptop's sound to work.

Needs a recent bios to work (needs ASUS BIOS version ≥ 311, the inxi shows version 309). Should now work with no patches after kernel 6.0.9

--
Notes:
after looking for a module to fix it, I found info on the AUR that lead me here with the infromation about the laptop: GitHub - latin-1/um5302ta
Most things should now work with the latest BIOS and a recent kernel.
However, please take note of this from that page:
S3 Sleep (deep sleep) (not recommended) S3 sleep may be unstable and cause freezing.

5 Likes

hey! Thanks a lot for quick response. Turns out bios was the problem and now it works flawlessly!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.