Sony Vaio VPCSB25FB Stamina/Speed switch functionality

Greetings. I am unsure where to post this exactly. So apologies if this is the incorrect place.

I have installed Garuda with the XFCE environment recently on this Vaio VPCSB25FB and after some minor keyring updating I got everything updated and up and running.

One thing I did notice however is that the Stamina/Speed soft-switch does not seem to do anything (Supposedly it switches between Intel iGPU and the discrete Radeon GPU for battery saving purposes). The BIOS provides no option to enable/disable one or the other.

I checked Garuda Settings Manager > Hardware Configuration and both GPUs were detected and had drivers, garuda-inxi also reports both GPUs properly. However Steam only reports the Intel iGPU and reports ‘Two Logical GPUs’.

I will be trying to use PRIME as per this wiki article here ( Switching between integrated and dedicated graphics | Garuda Linux wiki ) for some light gaming. But it does not appear to cover using it on applications outside of Steam.

I was curious to know if there was a way to get the switch working the way it was intended again, instead of relying on the prime method listed there. Or if any other Vaio users found a workaround of some kind. I have seen a few topics in the Arch and Ubunutu forums about it, but they are targeted at other models of Vaio with a similar (but not identical) system.

Thanks, and sorry for the long winded ramble like post.

What’s the problem with not posting garuda-inxi?
It contains additional, useful information about the status of your system.

Did you search in forum?

:warning: Missing information requested in the template may result in not receiving assistance

Make sure you have done the following before you post:

Issue still unresolved? Then:

  • ONE issue per topic.
  • Describe your issue in detail. The more we know, the better we can help
  • Show us the results of your searches, and what you’ve tried
  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)
  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

Without garuda-inxi this request will be moved to 412 Precondition Failed

  Kernel: 6.6.18-1-lts arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=07102260-d186-4244-8155-3ebb9df4c975 rw rootflags=subvol=@
    quiet resume=UUID=ccf4d3e8-4f2a-4e64-a03a-0e6dc752ceb4 loglevel=3 ibt=off
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 wm: xfwm4 v: 4.18.0
    with: xfce4-panel tools: xfce4-screensaver avail: xautolock vt: 7
    dm: LightDM v: 1.32.0 Distro: Garuda base: Arch Linux
  Type: Laptop System: Sony product: VPCSB25FB v: C700600X
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Sony model: VAIO serial: <superuser required>
    uuid: <superuser required> BIOS: INSYDE v: R1031H4 date: 04/25/2011
  Info: model: Intel Core i5-2410M bits: 64 type: MT MCP arch: Sandy Bridge
    gen: core 2 level: v2 built: 2010-12 process: Intel 32nm family: 6
    model-id: 0x2A (42) stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1336 high: 2900 min/max: 800/2900 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 2900 2: 798 3: 848
    4: 800 bogomips: 18364
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Vulnerabilities: <filter>
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    vendor: Sony driver: i915 v: kernel arch: Gen-6 code: Sandybridge
    process: Intel 32nm built: 2011 ports: active: LVDS-1 empty: DP-1, DP-2,
    HDMI-A-1, HDMI-A-2, VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0116
    class-ID: 0300
  Device-2: AMD Seymour [Radeon HD 6400M/7400M Series] vendor: Sony
    driver: radeon v: kernel alternate: amdgpu arch: TeraScale-2 code: Evergreen
    process: TSMC 32-40nm built: 2009-15 pcie: gen: 2 speed: 5 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 1002:6760 class-ID: 0300 temp: 41.0 C
  Device-3: Chicony USB2.0 Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-1.3:4 chip-ID: 04f2:b26d
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.11 compositor: xfwm4 v: 4.18.0 driver:
    X: loaded: modesetting,radeon alternate: fbdev,intel,vesa dri: crocus,r600
    gpu: i915 display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: LVDS-1 res: 1366x768 hz: 60 size: N/A modes: 1366x768
  API: Vulkan v: 1.3.276 layers: 9 device: 0 type: cpu name: llvmpipe (LLVM
    16.0.6 256 bits) driver: mesa llvmpipe v: 24.0.1-arch1.1 (LLVM 16.0.6)
    device-ID: 10005:0000 surfaces: xcb,xlib
  API: OpenGL Message: Unable to show GL data. glxinfo is missing.
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: Sony 6 driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1c20 class-ID: 0403
  API: ALSA v: k6.6.18-1-lts status: kernel-api tools: N/A
  Server-1: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Centrino Wireless-N 1000 [Condor Peak] driver: iwlwifi
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0
    chip-ID: 8086:0083 class-ID: 0280
  IF: wlp2s0 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Sony RTL8111/8168/8411 driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 05:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp5s0 state: down mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
  Device-1: Foxconn / Hon Hai T77H114 BCM2070 [Single-Chip Bluetooth 2.1 +
    EDR Adapter] driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-1.6:5 chip-ID: 0489:e00f class-ID: fe01
    serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 2.1
    lmp-v: 4 status: discoverable: no pairing: no class-ID: 6c010c
  Local Storage: total: 465.76 GiB used: 11.28 GiB (2.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Hitachi model: HTS545050B9SA00
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 1.5 Gb/s
    tech: HDD rpm: 5400 serial: <filter> fw-rev: C60X scheme: MBR
  ID-1: / raw-size: 457.52 GiB size: 457.52 GiB (100.00%)
    used: 11.28 GiB (2.5%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-2: /home raw-size: 457.52 GiB size: 457.52 GiB (100.00%)
    used: 11.28 GiB (2.5%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-3: /var/log raw-size: 457.52 GiB size: 457.52 GiB (100.00%)
    used: 11.28 GiB (2.5%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-4: /var/tmp raw-size: 457.52 GiB size: 457.52 GiB (100.00%)
    used: 11.28 GiB (2.5%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 3.74 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 8.24 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda2 maj-min: 8:2
  System Temperatures: cpu: 48.0 C mobo: N/A gpu: radeon temp: 41.5 C
  Fan Speeds (rpm): N/A
  Memory: total: 4 GiB available: 3.74 GiB used: 1.04 GiB (27.6%)
  Processes: 221 Power: uptime: 3m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 1.49 GiB services: upowerd,xfce4-power-manager
    Init: systemd v: 255 default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1329 libs: 441 tools: pamac,paru Compilers:
    gcc: 13.2.1 Shell: garuda-inxi default: Bash v: 5.2.26
    running-in: xfce4-terminal inxi: 3.3.33
Garuda (2.6.23-1):
  System install date:     2024-02-26
  Last full system update: 2024-02-27
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       <superuser required>
  Failed units:            

If you use open source drivers for the AMD dGPU, probably you could use DRI_PRIME=1


Thank you. I will be taking a look at PRIME today after work and see how it does.

The main thing I was wondering however, is if there was a known way to re enable the physical switch, or if it was one of those things sadly locked behind Windows only drivers from Sony.

something here Getting graphics switch key to work on Sony Vaio VGN-Z46GD? / Laptop Issues / Arch Linux Forums (different model but likely /sys/devices/platform/sony-laptop/gfx_switch_status or something similar applies to yours)


It does indeed have that directory and file. However the contents of gfx_switch_status dont seem to correlate with the physical state of the switch. (IE the switch is set to speed, and the file says stamina at the moment. And it has been like that after reboot as well.)

I have seen that post in the Arch forum, but since it was repeatedly stated that help should not be looked there for Garuda, I glazed over it.

So, look at PRIME, and investigate this post further is going to my to-do list for today. Thank you for looking into it.

1 Like

Prime is now set and functioning correctly. So, at least I have that functionality on specific applications. Thank you for suggesting that one.

I have also fiddled around with the files in /sys/devices/platform/sony-laptop and will be making a few scripts to get keyboard backlight control back and a few other things on the side that Vaio Center did in Win7. Should be good for practice.

The quest for re-enabling the physical switch continues however. If no new ideas pop up, I’ll let the thread auto-lock and maybe ask in 6 months again in case anyone figures out something similar before I do (if that is not against the rules).

Unfortunately, I think this problem (HW switch) is definitely out of Garuda’s reach (unless there is a user with the same or similar model as yours, but I don’t think so, searching in in the forum).
In my opinion, the only way forward is to search the internet.
At a quick search, at least a couple of threads in other forums said that the HW switch doesn’t work at all linux and used equivalents of “our” prime for their distros. Eg.

Or you could work on something (maybe!) similar, like:


The ACPI script is definitely going to get tried after work, that’s for sure. At least it would give me an example to see how the scripts are written and make some variants for practice.

As for HDMI out, I would have to test it on this model to see if it behaves the same. It is not essential for my purposes, but investigating it and finding a possible workaround (if there is an issue with this model at all), would a nice thing to have. You never know when your boss randomly wants something hooked up to the projector at the last minute and you are the only one with a laptop in the room.

Anyway, you have been of great help, and gave me something to keep me busy for a while. I will mark it as solved and make another thread if I have more specific questions later.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.