Some of the tools in Garuda Assistant are not working

2 of the tools: Remove Orphans and Refresh Keyrings are not working, both producing the same error:

error: you cannot perform this operation unless you are root.
Press enter to exit

Errors produced on start of the tool without asking me for a password. I am using Garuda Dragonized with KDE 5.26 on Asus ROG STRIX with AMD Ryzen 7 CPU running kernel 5.19.13.

If there is any way I can fix the issue, please let me know.

Works over here!

Is this consistently happening?


Works here too. Is polkit-kde-agent installed?

1 Like

Looks like your system isn't up to date if you are running that kernel version. ( Just assuming here because no garuda-inxi provided and I am just going off zen kernel versions). Might be a bug with that version of Garuda Assistant. Update with garuda-update and try again after a restart.

(Of course if updating didn't work then I would check on what BluishHumility mentioned. You are going to need to make sure polkit-kde-agent is installed)


Try reinstalling those two.
Worked for me when garuda-settings-manager stopped working for me a while back.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.