Some of my local apps can't get an internet connection

╭─vorsv@vorsv in ~ via  v21 took 4ms
╰─λ garuda-inxi
System:
Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=eb3e5cab-408f-41aa-86b9-6b5e3c79bbde rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
ibt=off
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: HP product: HP EliteBook 830 G5 v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: HP model: 83B3 v: KBC Version 04.6E.00 serial: <superuser required>
UEFI: HP v: Q78 Ver. 01.25.00 date: 06/16/2023
Battery:
ID-1: BAT0 charge: 21.0 Wh (73.2%) condition: 28.7/50.2 Wh (57.1%)
volts: 10.7 min: 11.6 model: Hewlett-Packard Primary type: Li-ion
serial: <filter> status: discharging cycles: 640
CPU:
Info: model: Intel Core i5-8350U, bits: 64 type: MT MCP arch: Coffee Lake
gen: core 8 level: v3 note: check built: 2017 process: Intel 14nm family: 6
model-id: 0x8E (142) stepping: 0xA (10) microcode: 0xF4
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB; desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB, desc: 4x256 KiB
L3: 6 MiB, desc: 1x6 MiB
Speed (MHz): avg: 1598 high: 2438 min/max: 400/3600 scaling:
driver: intel_pstate governor: powersave cores: 1: 2420; 2: 400; 3: 1893
4: 400; 5: 2438; 6: 1846 7: 1682 8: 1706 bogomips: 30399
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915
v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
active: eDP-1; empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:5917 class-ID: 0300
Device-2: Cheng Uei Precision Industry (Foxlink) HP HD Camera
driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0
bus-ID: 1-9:5 chip-ID: 05c8:0808 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
composer: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: InfoVision Optronics/Kunshan 0x0536 built: 2019
res: 1920x1080 hz: 60 dpi: 166 gamma: 1.2 size: 294x165mm (11.57x6.5")
diag: 337mm (13.3") ratio: 16:9 modes: 1920x1080
API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
device: 1 drv: swrast surfaceless; 1 drv: iris x11; 1 drv: iris
inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics 620 (KBL)
GT2) device-ID: 8086:5917 memory: 30.48 GiB unified: yes
API: Vulkan v: 1.3.269 layers: 13 device: 0 type: integrated-gpu
name: Intel UHD Graphics 620 (KBL GT2) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:5917 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 16.0.6, 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM)
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_soc_avs
bus-ID: 00:1f.3 chipID: 8086:9d71 class: 0403
API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.84 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Ethernet I219-LM vendor: Hewlett-Packard driver: e1000e
v: kernel port: N/A busID: 00:1f.6 chipID: 8086:15d7 class: 0200
IF: enp0s31f6 state: down mac: <filter>
Device-2: Intel Wireless 8265/ 8275 driver: iwlwifi v: kernel pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 01:00.0 chip-ID: 8086:24fd
class-ID: 0280
IF: wlp1s0 state: up mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 busID: 1-7:4 chip-ID: 8087:0a2b
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 4.2; lmp-v: 8
status: discoverable: no pairing: no
Drives:
Local Storage: total: 931.51 GiB; used: 386.83 GiB (41.5%)
SMART Message: Unable to run smartctl. Root privileges are required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: SN560E
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: AO009E4O temp: 36.9 C
scheme: GPT
Partition:
ID-1: raw-size: 488.28 GiB size: 488.28 GiB (100.00%)
used: 386.79 GiB (79.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:2
ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%)
used: 39.7 MiB (8.0%) fs: vfat dev: /dev/nvme0n1p6 maj-min: 259:3
ID-3: /home raw-size: 488.28 GiB size: 488.28 GiB (100.00%)
used: 386.79 GiB (79.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:2
ID-4: /var/log raw-size: 488.28 GiB size: 488.28 GiB (100.00%)
used: 386.79 GiB (79.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:2
ID-5: /var/tmp raw-size: 488.28 GiB size: 488.28 GiB (100.00%)
used: 386.79 GiB (79.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default: 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 31.21 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 52.0 C, pch: 49.0 C, mobo: N/A
Fan Speeds (rpm): N/A
Info:
Processes: 257 Uptime: 23m wakeups: 0 Memory: total: 32 GiB
available: 31.21 GiB; used: 20.04 GiB (64.2%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: 2181 pm: dpkg pkgs: 3 pm: pacman pkgs: 2178 libs: 583
tools: gnome-software,octopi,paru Shell: fish v: 3.6.1 default: Bash
v: 5.2.15 running-in: konsole inxi: 3.3.31
Garuda (2.6.17-1):
System install date:     2023-08-01
Last full system update: 2023-11-08
Is partially upgraded: Yes
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

some of my local application can’t access the internet, like Konsole (I tried pinging many ips nothing worked except 127.0.0.1 ( obiviously )) then my minecraft launcher (tlauncher) , FTB app

apps that can access internet - chrome ,modrith ,discord

i tried restarting the laptop,hotspot
i tried usb tethering too still same issue

Did you ever change proxy or DNS settings, or suspect some application (e.g. a VPN) may have done so?

no i did not change any setting i only installed tlauncher last but that worked fine yesterday from moring i did not access internet but when i tried i could not

Your system is in a partial upgrade status and outdated.
You should try to fix this with

garuda-update

If WiFi works inconsistently, try with Ethernet or maybe mobile phone tethering.
Ops, I see now hotspot is not working. Maybe USB tethering.

2 Likes

Sir I am trying it will let you know soon but how garuda-update can access internet

Have you tried pinging using the domain name instead of using the IP address?

1 Like
(795/795) checking keys in keyring                                 [------------------------------------] 100%
(795/795) checking package integrity                               [------------------------------------] 100%
(795/795) loading package files                                    [------------------------------------] 100%
(795/795) checking for file conflicts                              [------------------------------------] 100%
error: failed to commit transaction (conflicting files)
deskreen: /usr/share/icons/hicolor/256x256/apps/deskreen.png exists in filesystem
Errors occurred, no packages were upgraded.

shall i delete the mentioned file

garuda-update -- --overwrite /usr/share/icons/hicolor/256x256/apps/deskreen.png
3 Likes

Sorry, no, i haven’t. But now i did and it works, but still the ip doesn’t work?

what does this mean?

trying this will let you nkow sir,

Your problem is likely with your DNS setup.

The first thing to try is changing your DNS server address.

2 Likes

how shall it be done it is in my moblie or ?

Please post:

cat etc/resolv.conf

Make a backup of /etc/resolv.conf and remove any file write protection (if enabled):

sudo cp /etc/resolv.conf /etc/resolv.conf.bak && sudo chattr -i /etc/resolv.conf

Then, run the following command to auto-generate an /etc/resolv.conf file with Google as the DNS server:

echo -e "nameserver 8.8.8.8\nsearch 8.8.4.4" | sudo tee /etc/resolv.conf

To restore /etc/resolv.conf to its original state issue the following command:

sudo cp /etc/resolv.conf.bak /etc/resolv.conf 

You could also test Cloudflare as the DNS server if you’d prefer:

echo -e "nameserver 1.1.1.1\nsearch 1.0.0.1" | sudo tee /etc/resolv.conf

I won’t know which server you are currently using until you post the contents of your current etc/resolv.conf file.


3 Likes
╭─vorsv@vorsv in ~ via  v21 as 🧙 took 36ms
✦2  ╰─λ cat /etc/resolv.conf.bak
File: /etc/resolv.conf.bak
# Generated by NetworkManager
nameserver 192.168.9.233
nameserver 2409:40f4:9:c30a::c0

╭─vorsv@vorsv in ~ via  v21 as 🧙 took 31ms
✦2  ╰─λ

Ya, you’ll definitely want to test either/ both of the servers I suggested on my last post.

2 Likes

Yeah I did now I am replying from my phone

It seems the it has some connectivity issues I thought you were typing for so long​:rofl:

Should I restart my laptop?

Sure thing.

1 Like

Sorry I am back it seems still the same

Have you tried rebooting your router?
If pinging domain names is working but pinging ip addresses is not, maybe you have a routing problem as opposed to a DNS one.

2 Likes

It is mobile hotspot in mobile to the same issue