[SOLVED] VSync stuck at 75 fps instead of 144 fps

Hello

I have a primary 144 hz monitor I use for gaming and a second one that has 75 hz.
Every time I want to use VSync in any game, my fps get stuck at 75 fps instead of 144 fps.
This problem does not occur on Windows 10 while using VSync where the fps remain capped at 144 fps.

Updating graphics drivers did not resolve the problem.
I use KDE Plasma, zen kernel and I'm on Garuda Linux Dragonized.

Please help

Send garuda-inxi please

1 Like

Also, give a look at this thread.
This might be a limitation.
There are some workarounds that you could try, anyway.

2 Likes

Hallelujah, we don't like terminal output as images.
Neither from new nor "old" users of the forum.

Look at them, what I'm about to change your post.

1 Like

I have found a solution for this problem!

Put ~/.config/kwinrc in Konsole
Add MaxFPS=144 to the [Compositing] section.
Restart your computer

Sources:

Thank you filo!

I go to the trouble of formatting it and you can't think of anything better than deleting it?

Why did you delete it?
Because it was not a garuda-inxi?

inxi -Faz?

inxi -Faz

System:
Kernel: 5.18.0-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=9d68907e-a8b5-412d-bc79-433b049a2425 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: MSI model: B250M PRO-VD (MS-7A74) v: 1.0
serial: <superuser required> UEFI: American Megatrends v: 1.C0
date: 06/28/2018
CPU:
Info: model: Intel Core i5-7400 bits: 64 type: MCP arch: Kaby Lake
family: 6 model-id: 0x9E (158) stepping: 9 microcode: 0xF0
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 3263 high: 3440 min/max: 800/3500 scaling:
driver: intel_pstate governor: performance cores: 1: 3440 2: 3419 3: 3280
4: 2915 bogomips: 24000
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: disabled, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU116 [GeForce GTX 1660 Ti] vendor: Micro-Star MSI
driver: nvidia v: 515.43.04 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-05) arch: Turing pcie: gen: 3 speed: 8 GT/s
lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:2182 class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 3200x1080 s-dpi: 92 s-size: 883x301mm (34.76x11.85")
s-diag: 933mm (36.73")
Monitor-1: DP-4 pos: primary,top-right res: 1920x1080 dpi: 92
size: 531x299mm (20.91x11.77") diag: 609mm (23.99") modes: N/A
Monitor-2: HDMI-0 pos: bottom-l res: 1280x1024 dpi: 86
size: 380x300mm (14.96x11.81") diag: 484mm (19.06") modes: N/A
OpenGL: renderer: NVIDIA GeForce GTX 1660 Ti/PCIe/SSE2

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.