Solved - TASKBAR and Dock missing

Hello
Please advise.
After the last crash, I reinstalled from updated kernel and has been running almost flawlessly for the last 15 days.
Yesterday I left the computer for about 3 hours. When I came back, I could not login.
I restarted and when Garuda opened, the desktop was different, there was no taskbar or dock. I only had some right-click menu.
I restarted again with the same results.
I restarted and used the advanced options and booted with a failsafe option. Same result .
I restarted and went into the snapshots and tried 3 option even going back to the 10th Aug.
Every time I got the same result - no task bar and no dock. The system is still booting quickly but I cannot access programs etc.
I have tried looking in the forums, but cannot find anything similar.
I am currently using a live disk version.
Thanks

System:    Kernel: 5.13.5-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=garuda  
misolabel=GARUDA_DR460NIZED_SOARING_ quiet systemd.show_status=1 driver=nonfree
nouveau.modeset=0 i915.modeset=1 radeon.modeset=1
Console: tty pts/0 wm: kwin_x11 DM: SDDM Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Desktop Mobo: N/A model: N/A serial: N/A UEFI: American Megatrends v: 5.12  
date: 11/10/2018  
CPU:       Info: Quad Core model: Intel Core i5-8350U socket: BGA1356 (U3E1) note: check bits: 64  
type: MT MCP arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: A (10)  
microcode: EA cache: L1: 256 KiB L2: 6 MiB L3: 6 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 30399  
Speed: 3601 MHz min/max: 400/3600 MHz base/boost: 1600/8300 volts: 0.7 V ext-clock: 100 MHz  
Core speeds (MHz): 1: 3601 2: 3600 3: 3601 4: 3568 5: 3256 6: 3600 7: 3600 8: 3600  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable  
Type: mds mitigation: Clear CPU buffers; SMT vulnerable  
Type: meltdown mitigation: PTI  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2  
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling  
Type: srbds mitigation: Microcode  
Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable  
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:5917  
class-ID: 0300  
Device-2: Logitech Webcam C310 type: USB driver: snd-usb-audio,uvcvideo bus-ID: 1-6:5  
chip-ID: 046d:081b class-ID: 0102 serial: <filter>  
Display: server: X.Org 1.20.12 compositor: kwin_x11 driver: loaded: intel unloaded: modesetting  
alternate: fbdev,vesa display-ID: :0 screens: 1  
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")  
Monitor-1: HDMI1 res: 1920x1080 hz: 60 dpi: 70 size: 700x390mm (27.6x15.4") diag: 801mm (31.5")  
OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.1.5 direct render: Yes  
Audio:     Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel v: kernel  
alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403  
Device-2: Intel USB PnP Sound Device type: USB driver: hid-generic,snd-usb-audio,usbhid  
bus-ID: 1-1.2:4 chip-ID: 8086:0808 class-ID: 0300  
Device-3: Logitech Webcam C310 type: USB driver: snd-usb-audio,uvcvideo bus-ID: 1-6:5  
chip-ID: 046d:081b class-ID: 0102 serial: <filter>  
Sound Server-1: ALSA v: k5.13.5-zen1-1-zen running: yes  
Sound Server-2: JACK v: 1.9.19 running: no  
Sound Server-3: PulseAudio v: 15.0 running: no  
Sound Server-4: PipeWire v: 0.3.32 running: yes  
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 v: kernel  
port: e000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200  
IF: enp1s0 state: up speed: 1000 Mbps duplex: full mac: <filter>  
Device-2: Qualcomm Atheros AR9462 Wireless Network Adapter vendor: Lite-On driver: ath9k  
v: kernel port: e000 bus-ID: 02:00.0 chip-ID: 168c:0034 class-ID: 0280  
IF: wlp2s0 state: down mac: <filter>  
Device-3: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 bus-ID: 2-1.1:4  
chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>  
IF: enp0s20f0u1u1 state: down mac: <filter>  
Bluetooth: Device-1: Toshiba Atheros AR3012 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-9:9  
chip-ID: 0930:021c class-ID: e001  
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 2.97 TiB used: 0 KiB (0.0%)
ID-1: /dev/sda maj-min: 8:0 vendor: Indilinx model: IND-S3MP 256G size: 238.47 GiB block-size:
physical: 512 B logical: 512 B sata: 3.2 speed: 6.0 Gb/s type: SSD serial: <filter> rev: B1T2
temp: 36 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 1y 83d 23h cycles: 761 read: 2.8 MiB
written: 4.7 MiB Pre-Fail: reallocated sector: 100 threshold: 50
ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Seagate model: Backup+ SL size: 931.51 GiB
block-size: physical: 512 B logical: 512 B type: N/A serial: <filter> rev: 0143 scheme: MBR
SMART Message: A mandatory SMART command failed. Various possible causes.
ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Western Digital model: WD Elements 10B8
drive model: WD20NMVW-11EDZS2 family: Elements / My Passport (USB, AF) size: 1.82 TiB
block-size: physical: 4096 B logical: 512 B sata: 3.0 speed: 3.0 Gb/s type: HDD rpm: 5200
serial: <filter> drive serial: <filter> rev: 1012 drive rev: 01.01A01 temp: 32 C scheme: MBR
SMART: yes state: enabled health: PASSED on: 3y 95d 9h cycles: 2178
ID-4: /dev/sdd maj-min: 8:48 type: USB vendor: SanDisk model: Cruzer Blade size: 7.36 GiB
block-size: physical: 512 B logical: 512 B type: N/A serial: <filter> rev: 1.27 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.56 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 34.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 217 Uptime: 14m wakeups: 0 Memory: 7.56 GiB used: 4.05 GiB (53.5%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1157 lib: 290
Shell: fish (sudo) v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

Hello.

Before you open a new help request, read relevant sections of the Arch and Garuda wiki. Thoroughly search your issue and any error messages in the forum and on the web.

Report everything you have already attempted to solve your problem.
Post your terminal in- and output from:

inxi -Faz

Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

If you can open from application menu the Garuda assistant, try with button to reset to default settings

Thanks for reply.
I cannot open any menu. I only have a right-click menu.
nothing else.
Thanks

alt-space opens krunner, type garuda-assistant

1 Like

Make sure latte-dock is running.
Open terminal using one of the default shortcut. For me it was
ctrl + alt + t and run the command
latte-dock see if that fixes it

This sort of works but as soon as I close the terminal, everything closes. When I open firefox, its saying it needs updating. There is a message saying that the application Chromium has requested a new wallet for sensitive data. Im not even using Chromium unless Firedragon is based on Chromium. It still has not reset my desktop - Folders are on the left when I had put them on the right. I had Firefox in the Dock, now its missing.
All the firefox browser shortcuts are missing, and its asking me to sign in - which will mean that zoom has to be reconfigured -
And when I close the terminal, all applications close and Im back to a dead desktop.
Any other options that I might try??

hey music...Kkkk I had same problem also.

I am a newbe to arch linux so take my advice for what it is.

right click desktop and klick add widget,
add one menu widget and go out of edidt mode.
open menu and find garuda assistant..open the part where you can reset your config
close log out/restart and your should be back to normal.

hope it helps you..all the best from Brasil

2 Likes

:clap: :clap: :clap: :+1: :call_me_hand:
That put everything back without using terminal.
Obrigada, Gracias!!

2 Likes

If it is now SOLVED, then mark the proper post as the SOLUTION, please. :slight_smile:

3 Likes

Never seen that before in forums. Nice. Thanks Guys for your time.
I had to reset some settings back to original but im up and running.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.