[SOLVED] Steam looses controller at game launch

garuda-inxi:

System:
Kernel: 5.18.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=fb900bcb-7cce-4c3b-b47d-112e99edb19b rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 wm: kwin_x11 vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: HP product: HP Pavilion Gaming Laptop 17-cd1xxx
v: Type1ProductConfigId serial: <superuser required> Chassis: type: 10
serial: <superuser required>
Mobo: HP model: 8745 v: 03.45 serial: <superuser required> UEFI: Insyde
v: F.35 date: 04/07/2022
Battery:
ID-1: BAT1 charge: 47.1 Wh (100.0%) condition: 47.1/52.5 Wh (89.7%)
volts: 12.8 min: 11.6 model: Hewlett-Packard PABAS0241231 type: Li-ion
serial: <filter> status: full
CPU:
Info: model: Intel Core i5-10300H bits: 64 type: MT MCP arch: Comet Lake
gen: core 10 built: 2020 process: Intel 14nm family: 6 model-id: 0xA5 (165)
stepping: 2 microcode: 0xF0
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 4350 high: 4477 min/max: 800/4500 scaling:
driver: intel_pstate governor: performance cores: 1: 3934 2: 4392 3: 4399
4: 4391 5: 4475 6: 4401 7: 4477 8: 4338 bogomips: 39999
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Hewlett-Packard
driver: i915 v: kernel arch: Gen9.5 process: Intel 14nm built: 2016-20
ports: active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 00:02.0
chip-ID: 8086:9bc4 class-ID: 0300
Device-2: NVIDIA TU117M vendor: Hewlett-Packard driver: nvidia
v: 515.48.07 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-06) arch: Turing process: TSMC 12nm
built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 8 link-max: lanes: 16
ports: active: none empty: DP-2,HDMI-A-2 bus-ID: 01:00.0
chip-ID: 10de:1f99 class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia gpu: i915
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: AU Optronics 0x2792 built: 2020 res: 1920x1080
hz: 144 dpi: 128 gamma: 1.2 size: 382x215mm (15.04x8.46")
diag: 438mm (17.3") ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 22.1.1
direct render: Yes
Audio:
Device-1: Intel Comet Lake PCH cAVS vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:06c8 class-ID: 0403
Device-2: NVIDIA vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
pcie: gen: 3 speed: 8 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.1
chip-ID: 10de:10fa class-ID: 0403
Sound Server-1: ALSA v: k5.18.3-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.0 running: no
Sound Server-3: PipeWire v: 0.3.52 running: yes
Network:
Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 07:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: eno1 state: down mac: <filter>
IF-ID-1: docker0 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-14:3 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
RAID:
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
v: 3.0 port: 5060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: class-ID: 0104
Drives:
Local Storage: total: 953.87 GiB used: 90.83 GiB (9.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: A-Data model: SX8100NP
size: 953.87 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: VB421D57
temp: 47.9 C scheme: GPT
Partition:
ID-1: / raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 90.83 GiB (9.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 90.83 GiB (9.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 90.83 GiB (9.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 90.83 GiB (9.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.43 GiB used: 1.8 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 60.0 C pch: 50.0 C mobo: 10.0 C
Fan Speeds (RPM): cpu: 0 fan-2: 0
Info:
Processes: 292 Uptime: 9m wakeups: 2 Memory: 15.43 GiB
used: 3.41 GiB (22.1%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1792
lib: 513 Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.17
Garuda (2.6.3-2):
System install date:     2022-06-10
Last full system update: 2022-06-13
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

hi all, sorry for bad english

i plugged in my ds4 to the laptop, then type command

ls /dev/input/by-id/

lrwxrwxrwx   9 root 13 июн 21:55  usb-Logitech_Wireless_Receiver-event-mouse -> ../event6
lrwxrwxrwx   9 root 13 июн 21:55  usb-Logitech_Wireless_Receiver-mouse -> ../mouse0
lrwxrwxrwx  10 root 13 июн 22:07  usb-Sony_Computer_Entertainment_Wireless_Controller-event-if00 -> ../event25
[email protected] 10 root 13 июн 22:07  usb-Sony_Computer_Entertainment_Wireless_Controller-event-joystick -> ../event26
lrwxrwxrwx  10 root 13 июн 22:07  usb-Sony_Computer_Entertainment_Wireless_Controller-event-mouse -> ../event24
[email protected]  6 root 13 июн 22:07  usb-Sony_Computer_Entertainment_Wireless_Controller-joystick -> ../js1
lrwxrwxrwx   9 root 13 июн 22:07  usb-Sony_Computer_Entertainment_Wireless_Controller-mouse -> ../mouse3

ok, looks well, i suppose

then i start steam's game - and controller doesn't work, i type prev command again

ls /dev/input/by-id/

lrwxrwxrwx 9 root 13 июн 21:55  usb-Logitech_Wireless_Receiver-event-mouse -> ../event6
lrwxrwxrwx 9 root 13 июн 21:55  usb-Logitech_Wireless_Receiver-mouse -> ../mouse0

wow, no ds4 files at all

it happens exactly when I start the game, if I end game and replug controller it creates files again and they will be deleted when I start the game

if I replug controller during game still running - it not creates any files and controller would not work

ok, problem was in proton-ge-custom, changed it to GE-PROTON7-16 and problem is gone. The game was Elden Ring by the way

1 Like

If this is solved, mark your post as "solution" by clicking the tick icon to the left of the emoji icon.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.