[SOLVED] Realtek RTL8822CE - Wifi drops often

Hello.
during using my laptop system is loosing wifi connection very often. I must turn wifi off and then turn it on to make it work again. That happen ater some of the last updates.

 ╰─λ garuda-inxi
System:
  Kernel: 5.17.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=417f187a-a42b-44a5-b6b3-c27517119ed0 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=8f7c97f0-2758-4001-95b0-57f15fb14228 loglevel=3
  Desktop: GNOME v: 42.0 tk: GTK v: 3.24.33 wm: gnome-shell dm: GDM v: 42.0
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: HUAWEI product: KLVL-WXX9 v: M1300
    serial: <superuser required>
  Mobo: HUAWEI model: KLVL-WXX9-PCB v: M1300 serial: <superuser required>
    UEFI: HUAWEI v: 1.06 date: 09/14/2020
Battery:
  ID-1: BAT0 charge: 35.9 Wh (72.7%) condition: 49.4/54.9 Wh (90.0%)
    volts: 8.0 min: 7.6 model: SUNWODA HB4593R1ECW-22S0 type: Li-ion
    serial: <filter> status: discharging cycles: 162
CPU:
  Info: model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 2 family: 0x17 (23) model-id: 0x60 (96) stepping: 1
    microcode: 0x8600104
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 8 MiB desc: 2x4 MiB
  Speed (MHz): avg: 1397 high: 1406 min/max: 1400/3000 boost: enabled
    scaling: driver: acpi-cpufreq governor: powersave cores: 1: 1397 2: 1397
    3: 1398 4: 1397 5: 1396 6: 1397 7: 1406 8: 1397 9: 1396 10: 1395 11: 1397
    12: 1392 bogomips: 71865
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Renoir driver: amdgpu v: kernel pcie: gen: 4 speed: 16 GT/s
    lanes: 16 ports: active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 04:00.0
    chip-ID: 1002:1636 class-ID: 0300
  Device-2: IMC Networks HD Camera type: USB driver: uvcvideo bus-ID: 3-4:3
    chip-ID: 13d3:5451 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
    compositor: gnome-shell driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2160x1440 s-dpi: 96 s-size: 571x381mm (22.48x15.00")
    s-diag: 686mm (27.03")
  Monitor-1: eDP-1 mapped: eDP model: BOE Display 0x0893 built: 2019
    res: 2160x1440 hz: 60 dpi: 185 gamma: 1.2 size: 296x197mm (11.65x7.76")
    diag: 356mm (14") ratio: 3:2 modes: max: 2160x1440 min: 640x480
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 04:00.1
    chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x,
    snd_sof_amd_renoir
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 04:00.5 chip-ID: 1022:15e2
    class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 04:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Sound Server-1: ALSA v: k5.17.3-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.50 running: yes
Network:
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
    vendor: & Tele RSH driver: rtw_8822ce v: N/A modules: rtw88_8822ce pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 01:00.0
    chip-ID: 10ec:c822 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
Bluetooth:
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 3-3:2 chip-ID: 1358:c123 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 51.83 GiB (10.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: PC SN530 SDBPNPZ-512G-1027 size: 476.94 GiB block-size:
    physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
    serial: <filter> rev: 21117000 temp: 37.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
    used: 51.83 GiB (11.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
    used: 51.83 GiB (11.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
    used: 51.83 GiB (11.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
    used: 51.83 GiB (11.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: swap-2 type: zram size: 7.2 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 34.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 323 Uptime: 31m wakeups: 1 Memory: 7.2 GiB
  used: 2.96 GiB (41.1%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 Packages: 1262 pacman: 1257 lib: 327 flatpak: 5 Shell: fish
  v: 3.4.1 default: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.15
Garuda (2.6.1-3):
  System install date:     2022-04-09
  Last full system update: 2022-04-20
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:            mnt-Seagate.mount mnt-Toshiba.mount 

Regards,
Przemek

change to the lts kernel see if that help

3 Likes

Thanks, is there a tool to change kernels in Garuda?

Yes, but read below.

The link above is for rtl8821ce, you must substitute rtl8822ce in any commands given above.

1 Like

I was streaming movie in browser in my Emby server so I was using internet. It drops also when I use browser.

The link I posted above was for rtl8821ce, you must substitute rtl8822ce in any commands given in that post above.

Read the post below it relates directly to rtl8822ce.

1 Like

I change DNS from Quad9 to Adguard in Settings and see how it work.

It is likely WiFi power saving that causes the dropped connections.

Follow the directions below:

Install the rtw88-dkms-git driver from the Chaotic AUR.

If you have already installed any other driver version then uninstall that driver before proceeding. Once the driver has been uninstalled, then install the rtw88-dkms-git Chaotic AUR driver with the following command:

sudo  pacman -Syu rtw88-dkms-git

Then reboot.


Create a driver options file:

 sudo touch /etc/modprobe.d/rtl8822ce.conf

Open the /etc/modprobe.d/rtl8822ce.conf file in your text editor and paste the following contents:

options rtw_pci disable_aspm=1
blacklist rtw88_8822ce

Save the configuration file and then reboot.


Or, you can generate the above file automatically with this command:

echo -e "options rtw_pci disable_aspm=1\nblacklist rtw88_8822ce" | sudo tee /etc/modprobe.d/rtl8822ce.conf

This will automatically generate the required rtl8822ce driver option configuration file.

Reboot after creating this file.


If there is no improvement try adding a new kernel boot parameter.

Backup your grub config file:

sudo cp /etc/default/grub /etc/default/grub.bak 

Then edit /etc/default/grub and add pci=noaer to the end of the following line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 pci=noaer"

After adding the boot parameter and saving your changes, run:

sudo update-grub 

Reboot

Or, you can generate the grub change automatically with this command::

sudo cp /etc/default/grub /etc/default/grub.bak && sudo sed '/^GRUB_CMDLINE_LINUX_DEFAULT=/s/"$/ pci=noaer"/g' -i /etc/default/grub

After adding the boot parameter(s), run:

sudo update-grub 

Reboot.


4 Likes

Hi, can I just uncheck Wifi power Safe in Garuda Network Settings?

Try that first and see what happens. If it works then great. If not, revert and try the instructions above.

Toggling that Wifi power saving option in the Garuda Network app is unlikely to be all you need with your adapter. Your adapter often needs power saving to be disabled directly in its driver options or sometimes a kernel boot parameter.

I apologize, I forgot the driver install info in my last post so I have edited it in now. The post I copied most of that info from the user had already installed the driver from the Chaotic AUR. Hopefully the full instructions above should get now get your adapter working.

2 Likes

Thanks, I will try that solution and let You know it works.
When I install driver I get at the end:

==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: bfa
==> WARNING: Possibly missing firmware for module: qed
==> WARNING: Possibly missing firmware for module: qla1280
==> WARNING: Possibly missing firmware for module: qla2xxx
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: xhci_pci

do i have to install some stuff?
Regards.

Those warnings are unrelated and likely of no consequence.

For now it's working fine so thanks for help. If that problem will occur again I will reopen thread.
Regards.

I'm glad to hear your wifi is now working properly.

Did you have to use the kernel parameter to get your wifi working properly or was the conf file in /etc/modprobe.d sufficient?

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.