[solved]Qt5 apps does not render correctly in XFCE

Problem:-

All QT apps(including garuda utilities) do not show correct dark-light areas. Like text is not visible when window is in focus.

Since when:-

Since I updated garuda 3-4 days back.

What I have done to solve this issue:-

I googled about this issue, I found this topic https://bbs.archlinux.org/viewtopic.php?id=258335 I tried all the solutions mentioned here but they didn't worked.

My inxi

System:
  Kernel: 6.3.2-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux
    root=UUID=6274dc26-bdbc-4b4c-8121-1b55111145e5 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3 ibt=off
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: HP product: HP Laptop 15s-fq5xxx v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 8A20 v: 20.19 serial: <superuser required> UEFI: AMI
    v: F.17 date: 10/20/2022
Battery:
  ID-1: BAT0 charge: 24.0 Wh (63.0%) condition: 38.1/41.0 Wh (92.8%)
    volts: 11.5 min: 11.4 model: HP Primary type: Li-ion serial: <filter>
    status: discharging cycles: 206
CPU:
  Info: model: 12th Gen Intel Core i5-1235U bits: 64 type: MST AMCP
    arch: Alder Lake level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 4
    microcode: 0x42A
  Topology: cpus: 1x cores: 10 mt: 2 tpc: 2 st: 8 threads: 12 smt: enabled
    cache: L1: 928 KiB desc: d-8x32 KiB, 2x48 KiB; i-2x32 KiB, 8x64 KiB
    L2: 6.5 MiB desc: 2x1.2 MiB, 2x2 MiB L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 2500 min/max: 400/4400:3300 scaling:
    driver: intel_pstate governor: powersave cores: 1: 2500 2: 2500 3: 2500
    4: 2500 5: 2500 6: 2500 7: 2500 8: 2500 9: 2500 10: 2500 11: 2500 12: 2500
    bogomips: 59916
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
Graphics:
  Device-1: Intel Alder Lake-UP3 GT2 [Iris Xe Graphics]
    vendor: Hewlett-Packard driver: i915 v: kernel arch: Gen-12.2
    process: Intel 10nm built: 2021-22+ ports: active: eDP-1 empty: DP-1,
    DP-2, DP-3, DP-4, HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:46a8
    class-ID: 0300
  Device-2: Quanta HP TrueVision HD Camera driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-3:3 chip-ID: 0408:536c
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
    compositor: xfwm v: 4.18.0 driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0.0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: ChiMei InnoLux 0x153b built: 2020 res: 1920x1080
    hz: 60 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
    ratio: 16:9 modes: 1920x1080
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
    missing.
Audio:
  Device-1: Intel Alder Lake PCH-P High Definition Audio
    vendor: Hewlett-Packard driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:51c8 class-ID: 0401
  API: ALSA v: k6.3.2-arch1-1 status: kernel-api with: aoss
    type: oss-emulator tools: N/A
  Server-1: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtw_8822ce v: N/A modules: rtw88_8822ce
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 01:00.0
    chip-ID: 10ec:c822 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
Bluetooth:
  Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:4 chip-ID: 0bda:b00c
    class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 111.19 GiB (23.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNU512GZH
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: HPS1 temp: 32.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 56.59 GiB size: 56.59 GiB (100.00%)
    used: 22.07 GiB (39.0%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 576 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p8 maj-min: 259:8
  ID-3: /home raw-size: 119.27 GiB size: 119.27 GiB (100.00%)
    used: 89.12 GiB (74.7%) fs: btrfs dev: /dev/nvme0n1p7 maj-min: 259:7
  ID-4: /var/log raw-size: 56.59 GiB size: 56.59 GiB (100.00%)
    used: 22.07 GiB (39.0%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-5: /var/tmp raw-size: 56.59 GiB size: 56.59 GiB (100.00%)
    used: 22.07 GiB (39.0%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.44 GiB used: 768 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 58.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 361 Uptime: 3h 14m wakeups: 4816 Memory: available: 7.44 GiB
  used: 3.39 GiB (45.5%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1622 libs: 451 tools: pamac,paru,yay Shell: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.27
Garuda (2.6.16-1):
  System install date:     2023-05-01
  Last full system update: 2023-05-21 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            dev-binderfs.mount 

Useful outputs:-

 ╰─λ printenv | grep Q
QT_QPA_PLATFORMTHEME=kvantum
QT_STYLE_OVERRIDE=kvantum
QT_SCALE_FACTOR=1

etc:-

  • Text can be seen after window is not focused, But theme is still ugly.
  • I tried to use kvantum but it didn't worked.
  • I have installed manual GTK theme and all GTK apps work fine.
  • I have changed fonts from settings manager.

Pictures

When not in focus:-

Use qt5-settings and kvantum.

3 Likes

The issue is solved. It was my bad.
I previously added environment variable in bashrc.
Now I have put it in profile. Everything works.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.