[Solved] Change mouse debounce time

Hello Community,
I have a new mouse (Roccat Kain 100).
On Windows, I set the debounce time of the mouse in the (Roccat Swarm) software to "Zero Debounce", which means that the debounce time is nearly zero. On Windows, I got up to 25 (twenty-five) CPS (Clicks per second).
Then, I plugged that mouse into my Linux Laptop. The RGB settings that I set up on Windows applied, but it seems like the zero debounce isn't working, because I'm struggling to get even 10 (ten) CPS.
I think that is caused because of some software limitations that impact mouse debounce time.
Here are my research results (that haven't worked):

This would might be helpful, not done so many research:
[SOLVED] Lowering mouse debounce time / Kernel & Hardware / Arch Linux Forums

I'm hoping that anyone could help me.

Best regards, FuchsCrafter

EDIT

Edit: I found a way: How to disable mouse debouncing in libinput - Ask Ubuntu

Brief summary:

sudo su
mkdir /etc/libinput/
cd /etc/libinput/
nano local-overrides.quirks

Write this in the file (you could use another editor, but nano is my favorite):

[Never Debounce]
MatchUdevType=mouse
ModelBouncingKeys=1

Then strg+x, y, local-overrides.quirks, enter, done!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.