[SOLVED] Can't Load kernel on Snapshoot

Hi, Team Garuda Linux.

This is My problem. I can't to booting normally after entry on grub menu. I got a blank screen. So, I restarted with ctrl+alt+del. And I choose Garuda Linux Snapshot and rollback.
I get some error message :
Error: you need to load the kernel first

Sorry for my bad English :grin:

Try fallback image or alternative one

Still error.
Same message error : you need load to the kernel first

Are all snapshots giving same error

What did you do Prior to booting to blackscreen

Yes, all snapshot giving same error.

I booted into Garuda Linux

Is the blackscreen coming after an update ?

Can you go to tty

Ctrl + alt + f2

Yes, i got a black screen after update.
Nope, i can't to enter into tty.
My pc like a hang

You can live boot and
Restore snapshot from timeshift

1 Like

I have done it through live boot, but it still gets an error. I've also done via Arch-chroot. Still get some error

Perhaps reinstall

sudo pacman -S grub-btrfs grub os-prober-garuda
sudo grub-install
sudo mkinitcpio -P
sudo update-grub
1 Like

Another option you might want to test is booting to run level 3. Search those terms if you are unfamiliar with that method of booting into a console.

Once in run level 3, you can install an alternate kernel, (and finish a full update). Perhaps you received a kernel update that was not compatible with your system. Testing an alternate kernel would be the best way to find out, (and it's always best to have a fallback kernel installed).

I would suggest perhaps testing linux-lts and the mainline kernel. Don't forget to install the headers as well.

Example (from a run level 3 console):

sudo pacman -Syyu linux-lts linux-lts-headers

You could also do this from a chroot, but that is more complicated than accessing a console in run level 3.

Good luck.

1 Like

Thank you so much guys, you helped me. In this case are solved.
I sign to live boot mode, and i run via arch-chroot.
Reinstalled grub, and update-grub.
And also i run level 3 to testing my kernel with install linux-lts with the header.

Thanks to Garuda Team


So glad our reccomendations fixed you up, and welcome to the forum BTW. :smiley:

1 Like