[Solved] Can not start garuda after editing grub file

This happend after I added this command in /etc/default/grub :
GRUB_CMDLINE_LINUX_DEFAULT="hugepagesz=1G hugepages=3"

Then I sudo update-grub and rebooted and got to this screen.

Cheers

Edit: I tried using a snapshot. That didnt work

Welcome, remove the line :slight_smile: and did you try all snapshot's?

Yes I tried all the snapshot. I tried to remove the line but I dont know how.

Use live USB (KDE) then use path and edit with kate.

A little late now, but always make a backup copy of any important config files before you edit them. Grub and fstab rate as two of your most important boot configuration files, always back these files up before altering.

Timeshift is nice, but as you've learned the hard way now, it can't always be relied upon to save your chestnuts from the fire.

How did you try to remove the line if you don't know how?

Press e at the GRUB boot menu to access the Edit option (like it says on the menu) and then remove the part of the line you added (that broke things) and then boot using the shortcut key it tells you (F10).

1 Like

Tried the USB Option and the grub file didnt show the line I added. Now I tried what jonathon recommend. Also doesnt show the line I added.

I can still move my important files from the Hard drive to a USB and reinstall garuda, right? Thanks for the support and patience. :heart:

I don't think that is true. I can see it right there:

4 Likes

Ok im kinda stupid lol. Its 3am and im tired af

This is why you don't mess with things after midnight. :wink:

I know it's tempting, but leave it alone. :grin:

2 Likes

How do I save the changes? I delete the command line press f10 and I get the same error. I reboot press e and the command is there again

This means the issue was not because you

and you must have made some other change.

1 Like

I dont think I did. Do I need to delete "hugepagesz=1g hugepages=3" or the whole line?

You added only

therefore remove only that part.

1 Like

I reinstalled Gadura and I learned my lesson. Thanks for the support guys, I really aprecciate it!

1 Like

Spelling next then! :rofl: - it's GARUDA

3 Likes

Gadura sounds good too, maybe with the next distribution :wink:

1 Like